DPDK-dev Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Konstantin Ananyev <konstantin.ananyev@huawei.com>
To: Marat Khalili <marat.khalili@huawei.com>,
	Wathsala Vithanage <wathsala.vithanage@arm.com>
Cc: "dev@dpdk.org" <dev@dpdk.org>
Subject: RE: [PATCH v2 1/2] bpf: make bpf_def.h private
Date: Wed, 16 Sep 2026 12:59:44 +0000	[thread overview]
Message-ID: <49e32535a57345dba590877bc861bb30@huawei.com> (raw)
In-Reply-To: <20260911124414.63321-2-marat.khalili@huawei.com>



> Both `bpf_def.h` header file and the symbols it defined were not
> previously prefixed with `rte_`, creating an opportunity for name
> conflicts. Status of the file itself (private or public) was unclear.
> 
> Move public symbols after adding the necessary prefix (`rte_ebpf_insn`
> and `RTE_BPF_FUNC_MAX_ARGS`) into the public header file `rte_bpf.h`,
> and make the rest private.
> 
> Signed-off-by: Marat Khalili <marat.khalili@huawei.com>
> ---

Acked-by: Konstantin Ananyev <konstantin.ananyev@huawei.com>
As it is a public API change - It is probably worth a line or two in official RN for 26.11

> --
> 2.43.0


  reply	other threads:[~2026-09-16 12:59 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-05  9:46 [RFC 0/2] bpf_def.h cleanups Marat Khalili
2026-08-05  9:46 ` [RFC 1/2] bpf: make bpf_def.h private Marat Khalili
2026-08-05  9:46 ` [RFC 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-11 12:44 ` [PATCH v2 0/2] bpf_def.h cleanups Marat Khalili
2026-09-11 12:44   ` [PATCH v2 1/2] bpf: make bpf_def.h private Marat Khalili
2026-09-16 12:59     ` Konstantin Ananyev [this message]
2026-09-11 12:44   ` [PATCH v2 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-16 13:07     ` Konstantin Ananyev
2026-09-17 15:19   ` [PATCH v3 0/1] bpf_def.h cleanups Marat Khalili
2026-09-17 15:19     ` [PATCH v3 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-17 19:29       ` Marat Khalili
2026-09-18  9:21     ` [PATCH v4 0/1] bpf_def.h cleanups Marat Khalili
2026-09-18  9:21       ` [PATCH v4 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-18 10:28         ` Marat Khalili
2026-09-21 10:16         ` Marat Khalili
2026-09-21 20:19         ` Marat Khalili

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=49e32535a57345dba590877bc861bb30@huawei.com \
    --to=konstantin.ananyev@huawei.com \
    --cc=dev@dpdk.org \
    --cc=marat.khalili@huawei.com \
    --cc=wathsala.vithanage@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox