DPDK-dev Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Konstantin Ananyev <konstantin.ananyev@huawei.com>
To: Marat Khalili <marat.khalili@huawei.com>,
	Wathsala Vithanage <wathsala.vithanage@arm.com>
Cc: "dev@dpdk.org" <dev@dpdk.org>
Subject: RE: [PATCH v2 2/2] bpf: rename macros to match Linux kernel
Date: Wed, 16 Sep 2026 13:07:48 +0000	[thread overview]
Message-ID: <792142d15a764d5e9f6d693aa2f42e0c@huawei.com> (raw)
In-Reply-To: <20260911124414.63321-3-marat.khalili@huawei.com>



> BPF opcode macro names had small deviations from the ones defined in
> Linux headers, confusing humans and AI tools during code generation and
> analysis, since both are mostly trained on the Linux spelling.
> 
> Rename them to match Linux counterparts.

But then, there would be a risk that inside DPDK code we will use
definitions provided by linux includes without even noticing that?
I understand that both should boil down to the same values, but still
sort of grey area here...
Shall we add 'RTE_' or '_RTE_' prefix to our own ones? 

> 
> Signed-off-by: Marat Khalili <marat.khalili@huawei.com>
> ---

  reply	other threads:[~2026-09-16 13:07 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-08-05  9:46 [RFC 0/2] bpf_def.h cleanups Marat Khalili
2026-08-05  9:46 ` [RFC 1/2] bpf: make bpf_def.h private Marat Khalili
2026-08-05  9:46 ` [RFC 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-11 12:44 ` [PATCH v2 0/2] bpf_def.h cleanups Marat Khalili
2026-09-11 12:44   ` [PATCH v2 1/2] bpf: make bpf_def.h private Marat Khalili
2026-09-16 12:59     ` Konstantin Ananyev
2026-09-11 12:44   ` [PATCH v2 2/2] bpf: rename macros to match Linux kernel Marat Khalili
2026-09-16 13:07     ` Konstantin Ananyev [this message]
2026-09-17 15:19   ` [PATCH v3 0/1] bpf_def.h cleanups Marat Khalili
2026-09-17 15:19     ` [PATCH v3 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-17 19:29       ` Marat Khalili
2026-09-18  9:21     ` [PATCH v4 0/1] bpf_def.h cleanups Marat Khalili
2026-09-18  9:21       ` [PATCH v4 1/1] bpf: make bpf_def.h private Marat Khalili
2026-09-18 10:28         ` Marat Khalili
2026-09-21 10:16         ` Marat Khalili
2026-09-21 20:19         ` Marat Khalili

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=792142d15a764d5e9f6d693aa2f42e0c@huawei.com \
    --to=konstantin.ananyev@huawei.com \
    --cc=dev@dpdk.org \
    --cc=marat.khalili@huawei.com \
    --cc=wathsala.vithanage@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox