dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Thierry Reding <thierry.reding@avionic-design.de>
To: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
Cc: Paulo Zanoni <paulo.r.zanoni@intel.com>, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v3 9/9] drm: Remove duplicate drm_mode_cea_vic()
Date: Mon, 14 Jan 2013 16:03:33 +0100	[thread overview]
Message-ID: <20130114150333.GA24129@avionic-0098.adnet.avionic-design.de> (raw)
In-Reply-To: <20130114145756.GG3867@intel.com>


[-- Attachment #1.1: Type: text/plain, Size: 1159 bytes --]

On Mon, Jan 14, 2013 at 04:57:56PM +0200, Ville Syrjälä wrote:
> On Mon, Jan 14, 2013 at 03:30:28PM +0100, Thierry Reding wrote:
> > The same function had already been merged with a different name. Remove
> > the duplicate one but reuse some of its kerneldoc fragments for the
> > existing implementation.
> 
> And I just used that function. Oh well ;)
> 
> Personally I would have kept the other function instead since it has a
> more descriptive name, but I can't be bothered to care enough to
> complain too much.

drm_mode_cea_vic() was introduced later, so I preferred the older
variant.

> The patch could be moved to the beginning of the series, so it can be
> merged w/o being blocked by the more invasive stuff. Well, assuming that
> the more invasive stuff still needs discussing.

I had it at the beginning of the series, then realized that I hadn't
updated the i915 driver properly. So I cheated a bit and just moved the
patch instead of updating i915 and then resolving the conflict in the
subsequent i915 HDMI helper patch. =)

If the series can't be merged as-is, I can work this in for the next
version.

Thierry

[-- Attachment #1.2: Type: application/pgp-signature, Size: 836 bytes --]

[-- Attachment #2: Type: text/plain, Size: 159 bytes --]

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

      reply	other threads:[~2013-01-14 15:03 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-01-14 14:30 [PATCH v3 0/9] Add HDMI infoframe helpers Thierry Reding
2013-01-14 14:30 ` [PATCH v3 1/9] drm: Make drm_num_cea_modes unsigned Thierry Reding
2013-01-14 14:42   ` Ville Syrjälä
2013-01-14 15:06     ` Thierry Reding
2013-01-14 15:47       ` Ville Syrjälä
2013-01-18 10:30         ` Thierry Reding
2013-01-18 10:51           ` Ville Syrjälä
2013-01-18 11:08             ` Thierry Reding
2013-01-14 14:30 ` [PATCH v3 2/9] drm: Add some missing forward declarations Thierry Reding
2013-01-14 14:30 ` [PATCH v3 3/9] video: Add generic HDMI infoframe helpers Thierry Reding
2013-01-16 13:27   ` Ville Syrjälä
2013-01-18  8:56     ` Thierry Reding
2013-01-18 10:50       ` Ville Syrjälä
2013-01-14 14:30 ` [PATCH v3 4/9] drm: Add " Thierry Reding
2013-01-14 14:30 ` [PATCH v3 5/9] drm: Add EDID helper documentation Thierry Reding
2013-01-14 14:30 ` [PATCH v3 6/9] drm/tegra: Use generic HDMI infoframe helpers Thierry Reding
2013-01-14 14:30 ` [PATCH v3 7/9] drm/i915: " Thierry Reding
2013-01-14 14:30 ` [PATCH v3 8/9] drm/radeon: " Thierry Reding
2013-01-14 14:30 ` [PATCH v3 9/9] drm: Remove duplicate drm_mode_cea_vic() Thierry Reding
2013-01-14 14:57   ` Ville Syrjälä
2013-01-14 15:03     ` Thierry Reding [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130114150333.GA24129@avionic-0098.adnet.avionic-design.de \
    --to=thierry.reding@avionic-design.de \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=paulo.r.zanoni@intel.com \
    --cc=ville.syrjala@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox