dri-devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Thierry Reding <thierry.reding@gmail.com>
To: Andrzej Hajda <a.hajda@samsung.com>
Cc: dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 03/15] drm/dsi: Add mipi_dsi_set_maximum_return_packet_size() helper
Date: Tue, 14 Oct 2014 11:05:40 +0200	[thread overview]
Message-ID: <20141014090539.GB18993@ulmo> (raw)
In-Reply-To: <543BDD57.9090407@samsung.com>


[-- Attachment #1.1: Type: text/plain, Size: 2762 bytes --]

On Mon, Oct 13, 2014 at 04:10:31PM +0200, Andrzej Hajda wrote:
> On 10/13/2014 12:16 PM, Thierry Reding wrote:
> > From: YoungJun Cho <yj44.cho@samsung.com>
> > 
> > This function can be used to set the maximum return packet size for a
> > MIPI DSI peripheral.
> > 
> > Signed-off-by: YoungJun Cho <yj44.cho@samsung.com>
> > [treding: endianess, kerneldoc, return value]
> > Signed-off-by: Thierry Reding <treding@nvidia.com>
> > ---
> >  drivers/gpu/drm/drm_mipi_dsi.c | 30 ++++++++++++++++++++++++++++++
> >  include/drm/drm_mipi_dsi.h     |  2 ++
> >  2 files changed, 32 insertions(+)
> > 
> > diff --git a/drivers/gpu/drm/drm_mipi_dsi.c b/drivers/gpu/drm/drm_mipi_dsi.c
> > index 1702ffd07986..27fc6dac5e4a 100644
> > --- a/drivers/gpu/drm/drm_mipi_dsi.c
> > +++ b/drivers/gpu/drm/drm_mipi_dsi.c
> > @@ -198,6 +198,36 @@ int mipi_dsi_detach(struct mipi_dsi_device *dsi)
> >  }
> >  EXPORT_SYMBOL(mipi_dsi_detach);
> >  
> > +/*
> > + * mipi_dsi_set_maximum_return_packet_size() - specify the maximum size of the
> > + *    the payload in a long packet transmitted from the peripheral back to the
> > + *    host processor
> > + * @dsi: DSI peripheral device
> > + * @value: the maximum size of the payload
> > + *
> > + * Return: 0 on success or a negative error code on failure.
> > + */
> > +int mipi_dsi_set_maximum_return_packet_size(struct mipi_dsi_device *dsi,
> > +					    u16 value)
> > +{
> > +	u8 tx[2] = { value & 0xff, value >> 8 };
> > +	struct mipi_dsi_msg msg;
> > +	ssize_t err;
> > +
> > +	memset(&msg, 0, sizeof(msg));
> > +	msg.channel = dsi->channel;
> > +	msg.type = MIPI_DSI_SET_MAXIMUM_RETURN_PACKET_SIZE;
> > +	msg.tx_len = sizeof(tx);
> > +	msg.tx_buf = tx;
> 
> 
> An alternative (without tx variable) could be:
> 
> 	__cpu_to_le16s(&value);
> 	msg.tx_len = sizeof(value);
> 	msg.tx_buf = &value;
> 
> But it is just pico-optimization.
> 
> 
> > +
> > +	err = dsi->host->ops->transfer(dsi->host, &msg);
> 
> I guess the sequence:
> 	if (dsi->mode_flags & MIPI_DSI_MODE_LPM)
> 		msg.flags = MIPI_DSI_MSG_USE_LPM;
> 
> should be before this callback.
> 
> The same should be in all other helpers calling ops->transfer,
> so I guess it may be good to move it all to separate function, for
> example sth like:
> ... dsi_transfer(dsi, msg)
> {
> 	if (!ops || !ops->transfer)
> 		return -NOSYS;
> 
> 	if (dsi->mode_flags & MIPI_DSI_MODE_LPM)
> 		msg.flags = MIPI_DSI_MSG_USE_LPM;
> 
> 
> 	return ops->transfer(dsi->host, msg);
> }

Good idea. It'd be slightly better if we could check for valid ops
earlier, but I don't think it's really worth it. I'll add a helper that
performs these common checks and rebase the other patches on top of it.

Thierry

[-- Attachment #1.2: Type: application/pgp-signature, Size: 819 bytes --]

[-- Attachment #2: Type: text/plain, Size: 159 bytes --]

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2014-10-14  9:05 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-10-13 10:16 [PATCH v2 01/15] drm/dsi: Make mipi_dsi_dcs_{read, write}() symmetrical Thierry Reding
2014-10-13 10:16 ` [PATCH 02/15] drm/dsi: Constify mipi_dsi_msg Thierry Reding
2014-10-13 13:41   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 03/15] drm/dsi: Add mipi_dsi_set_maximum_return_packet_size() helper Thierry Reding
2014-10-13 14:10   ` Andrzej Hajda
2014-10-14  9:05     ` Thierry Reding [this message]
2014-10-13 14:23   ` Andrzej Hajda
2014-10-14  9:31     ` Thierry Reding
2014-10-13 10:16 ` [PATCH 04/15] drm/panel: s6e8aa0: Use standard MIPI DSI function Thierry Reding
2014-10-13 14:13   ` Andrzej Hajda
2014-10-14  9:46     ` Thierry Reding
2014-10-13 10:16 ` [PATCH 05/15] drm/dsi: Implement generic read and write commands Thierry Reding
2014-10-14  8:59   ` Andrzej Hajda
2014-10-14 10:03     ` Thierry Reding
2014-10-15 13:32       ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 06/15] drm/dsi: Implement some standard DCS commands Thierry Reding
2014-10-21  8:36   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 07/15] drm/dsi: Add to DocBook documentation Thierry Reding
2014-10-21  9:26   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 08/15] drm/dsi: Implement DCS nop command Thierry Reding
2014-10-21  9:53   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 09/15] drm/dsi: Implement DCS soft_reset command Thierry Reding
2014-10-13 10:16 ` [PATCH 10/15] drm/dsi: Implement DCS get_power_mode command Thierry Reding
2014-10-21  9:48   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 11/15] drm/dsi: Implement DCS {get,set}_pixel_format commands Thierry Reding
2014-10-13 10:16 ` [PATCH 12/15] drm/dsi: Implement DCS set_{column, page}_address commands Thierry Reding
2014-10-13 10:16 ` [PATCH 13/15] drm/dsi: Always use low-power mode for DCS commands Thierry Reding
2014-10-16  7:00   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 14/15] drm/dsi: Resolve MIPI DSI device from phandle Thierry Reding
2014-10-16  7:03   ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 15/15] drm/panel: Add Sharp LQ101R1SX01 support Thierry Reding
2014-10-20 15:56   ` Andrzej Hajda
2014-10-31 14:28     ` Thierry Reding
2014-10-13 12:29 ` [PATCH v2 01/15] drm/dsi: Make mipi_dsi_dcs_{read,write}() symmetrical Andrzej Hajda
2014-10-14  9:00   ` Thierry Reding
2014-10-21 11:10     ` Andrzej Hajda
2014-10-21 11:19       ` Andrzej Hajda
2014-10-14  8:00 ` [PATCH v2 01/15] drm/dsi: Make mipi_dsi_dcs_{read, write}() symmetrical Andrzej Hajda
2014-10-14  9:44   ` Thierry Reding
2014-10-14 10:38     ` Andrzej Hajda
2014-10-14 10:57       ` Thierry Reding
2014-10-14 11:13         ` Thierry Reding
2014-10-14 11:47           ` Thierry Reding
2014-10-14 11:25         ` Andrzej Hajda
2014-10-14 11:29           ` Thierry Reding
2014-10-14 13:53             ` Andrzej Hajda
2014-10-14 14:16               ` Thierry Reding
2014-10-15 11:01                 ` Andrzej Hajda
2014-10-15 11:11                   ` Thierry Reding
2014-10-15 11:22                     ` Andrzej Hajda
2014-10-14 10:59     ` Andrzej Hajda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20141014090539.GB18993@ulmo \
    --to=thierry.reding@gmail.com \
    --cc=a.hajda@samsung.com \
    --cc=dri-devel@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox