From: Andrzej Hajda <a.hajda@samsung.com>
To: Thierry Reding <thierry.reding@gmail.com>,
dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 04/15] drm/panel: s6e8aa0: Use standard MIPI DSI function
Date: Mon, 13 Oct 2014 16:13:16 +0200 [thread overview]
Message-ID: <543BDDFC.2090500@samsung.com> (raw)
In-Reply-To: <1413195395-3355-4-git-send-email-thierry.reding@gmail.com>
On 10/13/2014 12:16 PM, Thierry Reding wrote:
> From: Thierry Reding <treding@nvidia.com>
>
> Use the newly introduced mipi_dsi_set_maximum_return_packet_size()
> function to replace an open-coded version.
>
> Signed-off-by: Thierry Reding <treding@nvidia.com>
> ---
> drivers/gpu/drm/panel/panel-s6e8aa0.c | 16 ++--------------
> 1 file changed, 2 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/gpu/drm/panel/panel-s6e8aa0.c b/drivers/gpu/drm/panel/panel-s6e8aa0.c
> index 0f85a7c37687..c31e2953f290 100644
> --- a/drivers/gpu/drm/panel/panel-s6e8aa0.c
> +++ b/drivers/gpu/drm/panel/panel-s6e8aa0.c
> @@ -800,27 +800,15 @@ static void s6e8aa0_panel_init(struct s6e8aa0 *ctx)
> }
>
> static void s6e8aa0_set_maximum_return_packet_size(struct s6e8aa0 *ctx,
> - int size)
> + u16 size)
I guess this whole function should be removed and direct call to
mipi_dsi_set_maximum_return_packet_size should be used.
Regards
Andrzej
> {
> struct mipi_dsi_device *dsi = to_mipi_dsi_device(ctx->dev);
> - const struct mipi_dsi_host_ops *ops = dsi->host->ops;
> - u8 buf[] = {size, 0};
> - struct mipi_dsi_msg msg = {
> - .channel = dsi->channel,
> - .type = MIPI_DSI_SET_MAXIMUM_RETURN_PACKET_SIZE,
> - .tx_len = sizeof(buf),
> - .tx_buf = buf
> - };
> int ret;
>
> if (ctx->error < 0)
> return;
>
> - if (!ops || !ops->transfer)
> - ret = -EIO;
> - else
> - ret = ops->transfer(dsi->host, &msg);
> -
> + ret = mipi_dsi_set_maximum_return_packet_size(dsi, size);
> if (ret < 0) {
> dev_err(ctx->dev,
> "error %d setting maximum return packet size to %d\n",
>
next prev parent reply other threads:[~2014-10-13 14:13 UTC|newest]
Thread overview: 51+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-10-13 10:16 [PATCH v2 01/15] drm/dsi: Make mipi_dsi_dcs_{read, write}() symmetrical Thierry Reding
2014-10-13 10:16 ` [PATCH 02/15] drm/dsi: Constify mipi_dsi_msg Thierry Reding
2014-10-13 13:41 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 03/15] drm/dsi: Add mipi_dsi_set_maximum_return_packet_size() helper Thierry Reding
2014-10-13 14:10 ` Andrzej Hajda
2014-10-14 9:05 ` Thierry Reding
2014-10-13 14:23 ` Andrzej Hajda
2014-10-14 9:31 ` Thierry Reding
2014-10-13 10:16 ` [PATCH 04/15] drm/panel: s6e8aa0: Use standard MIPI DSI function Thierry Reding
2014-10-13 14:13 ` Andrzej Hajda [this message]
2014-10-14 9:46 ` Thierry Reding
2014-10-13 10:16 ` [PATCH 05/15] drm/dsi: Implement generic read and write commands Thierry Reding
2014-10-14 8:59 ` Andrzej Hajda
2014-10-14 10:03 ` Thierry Reding
2014-10-15 13:32 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 06/15] drm/dsi: Implement some standard DCS commands Thierry Reding
2014-10-21 8:36 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 07/15] drm/dsi: Add to DocBook documentation Thierry Reding
2014-10-21 9:26 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 08/15] drm/dsi: Implement DCS nop command Thierry Reding
2014-10-21 9:53 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 09/15] drm/dsi: Implement DCS soft_reset command Thierry Reding
2014-10-13 10:16 ` [PATCH 10/15] drm/dsi: Implement DCS get_power_mode command Thierry Reding
2014-10-21 9:48 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 11/15] drm/dsi: Implement DCS {get,set}_pixel_format commands Thierry Reding
2014-10-13 10:16 ` [PATCH 12/15] drm/dsi: Implement DCS set_{column, page}_address commands Thierry Reding
2014-10-13 10:16 ` [PATCH 13/15] drm/dsi: Always use low-power mode for DCS commands Thierry Reding
2014-10-16 7:00 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 14/15] drm/dsi: Resolve MIPI DSI device from phandle Thierry Reding
2014-10-16 7:03 ` Andrzej Hajda
2014-10-13 10:16 ` [PATCH 15/15] drm/panel: Add Sharp LQ101R1SX01 support Thierry Reding
2014-10-20 15:56 ` Andrzej Hajda
2014-10-31 14:28 ` Thierry Reding
2014-10-13 12:29 ` [PATCH v2 01/15] drm/dsi: Make mipi_dsi_dcs_{read,write}() symmetrical Andrzej Hajda
2014-10-14 9:00 ` Thierry Reding
2014-10-21 11:10 ` Andrzej Hajda
2014-10-21 11:19 ` Andrzej Hajda
2014-10-14 8:00 ` [PATCH v2 01/15] drm/dsi: Make mipi_dsi_dcs_{read, write}() symmetrical Andrzej Hajda
2014-10-14 9:44 ` Thierry Reding
2014-10-14 10:38 ` Andrzej Hajda
2014-10-14 10:57 ` Thierry Reding
2014-10-14 11:13 ` Thierry Reding
2014-10-14 11:47 ` Thierry Reding
2014-10-14 11:25 ` Andrzej Hajda
2014-10-14 11:29 ` Thierry Reding
2014-10-14 13:53 ` Andrzej Hajda
2014-10-14 14:16 ` Thierry Reding
2014-10-15 11:01 ` Andrzej Hajda
2014-10-15 11:11 ` Thierry Reding
2014-10-15 11:22 ` Andrzej Hajda
2014-10-14 10:59 ` Andrzej Hajda
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=543BDDFC.2090500@samsung.com \
--to=a.hajda@samsung.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=thierry.reding@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox