* [PATCH] drm: Remove complete task from TODO documentation
@ 2018-12-13 22:55 Shayenne da Luz Moura
2018-12-14 8:35 ` [Outreachy kernel] " Daniel Vetter
0 siblings, 1 reply; 2+ messages in thread
From: Shayenne da Luz Moura @ 2018-12-13 22:55 UTC (permalink / raw)
To: Maarten Lankhorst, Maxime Ripard, Sean Paul, David Airlie
Cc: dri-devel, linux-kernel, outreachy-kernel
This patch remove the follow complete task from TODO documentation:
drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
Should be renamed to drm_mode_config.object_idr.
Signed-off-by: Shayenne da Luz Moura <shayenneluzmoura@gmail.com>
---
Documentation/gpu/todo.rst | 3 ---
1 file changed, 3 deletions(-)
diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
index 14191b64446d..41da7b06195c 100644
--- a/Documentation/gpu/todo.rst
+++ b/Documentation/gpu/todo.rst
@@ -354,9 +354,6 @@ KMS cleanups
Some of these date from the very introduction of KMS in 2008 ...
-- drm_mode_config.crtc_idr is misnamed, since it contains all KMS object. Should
- be renamed to drm_mode_config.object_idr.
-
- drm_display_mode doesn't need to be derived from drm_mode_object. That's
leftovers from older (never merged into upstream) KMS designs where modes
where set using their ID, including support to add/remove modes.
--
2.19.2
^ permalink raw reply related [flat|nested] 2+ messages in thread
* Re: [Outreachy kernel] [PATCH] drm: Remove complete task from TODO documentation
2018-12-13 22:55 [PATCH] drm: Remove complete task from TODO documentation Shayenne da Luz Moura
@ 2018-12-14 8:35 ` Daniel Vetter
0 siblings, 0 replies; 2+ messages in thread
From: Daniel Vetter @ 2018-12-14 8:35 UTC (permalink / raw)
To: Shayenne da Luz Moura
Cc: Maarten Lankhorst, Maxime Ripard, Sean Paul, David Airlie,
dri-devel, linux-kernel, outreachy-kernel
On Thu, Dec 13, 2018 at 08:55:37PM -0200, Shayenne da Luz Moura wrote:
> This patch remove the follow complete task from TODO documentation:
>
> drm_mode_config.crtc_idr is misnamed, since it contains all KMS object.
> Should be renamed to drm_mode_config.object_idr.
>
> Signed-off-by: Shayenne da Luz Moura <shayenneluzmoura@gmail.com>
Applied, thanks for your patch.
-Daniel
> ---
> Documentation/gpu/todo.rst | 3 ---
> 1 file changed, 3 deletions(-)
>
> diff --git a/Documentation/gpu/todo.rst b/Documentation/gpu/todo.rst
> index 14191b64446d..41da7b06195c 100644
> --- a/Documentation/gpu/todo.rst
> +++ b/Documentation/gpu/todo.rst
> @@ -354,9 +354,6 @@ KMS cleanups
>
> Some of these date from the very introduction of KMS in 2008 ...
>
> -- drm_mode_config.crtc_idr is misnamed, since it contains all KMS object. Should
> - be renamed to drm_mode_config.object_idr.
> -
> - drm_display_mode doesn't need to be derived from drm_mode_object. That's
> leftovers from older (never merged into upstream) KMS designs where modes
> where set using their ID, including support to add/remove modes.
> --
> 2.19.2
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@googlegroups.com.
> To post to this group, send email to outreachy-kernel@googlegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/20181213225537.nq4dwidn6tma33iv%40smtp.gmail.com.
> For more options, visit https://groups.google.com/d/optout.
--
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2018-12-14 8:35 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2018-12-13 22:55 [PATCH] drm: Remove complete task from TODO documentation Shayenne da Luz Moura
2018-12-14 8:35 ` [Outreachy kernel] " Daniel Vetter
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox