From: Sam Ravnborg <sam@ravnborg.org>
To: Thomas Zimmermann <tzimmermann@suse.de>
Cc: john.p.donnelly@oracle.com, dri-devel@lists.freedesktop.org,
kraxel@redhat.com, airlied@redhat.com
Subject: Re: [PATCH 10/17] drm/mgag200: Set pitch in a separate helper function
Date: Sun, 3 May 2020 17:42:09 +0200 [thread overview]
Message-ID: <20200503154209.GC23105@ravnborg.org> (raw)
In-Reply-To: <20200429143238.10115-11-tzimmermann@suse.de>
Hi Thomas.
On Wed, Apr 29, 2020 at 04:32:31PM +0200, Thomas Zimmermann wrote:
> The framebuffer's pitch is now set in mgag200_set_offset().
>
> Signed-off-by: Thomas Zimmermann <tzimmermann@suse.de>
I failed to follow this code.
> ---
> drivers/gpu/drm/mgag200/mgag200_mode.c | 41 +++++++++++++++++---------
> 1 file changed, 27 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/gpu/drm/mgag200/mgag200_mode.c b/drivers/gpu/drm/mgag200/mgag200_mode.c
> index 92dee31f16c42..eb83e471d72fc 100644
> --- a/drivers/gpu/drm/mgag200/mgag200_mode.c
> +++ b/drivers/gpu/drm/mgag200/mgag200_mode.c
> @@ -1003,6 +1003,32 @@ static void mgag200_set_mode_regs(struct mga_device *mdev,
> mga_crtc_set_plls(mdev, mode->clock);
> }
>
> +static void mgag200_set_offset(struct mga_device *mdev,
> + const struct drm_framebuffer *fb)
> +{
> + unsigned int offset;
> + uint8_t crtc13, crtcext0;
> + u8 bppshift;
> +
> + bppshift = mdev->bpp_shifts[fb->format->cpp[0] - 1];
Hmm, use of cpp is deprecated. But is continue to be used all over.
> +
> + offset = fb->pitches[0] / fb->format->cpp[0];
> + if (fb->format->cpp[0] * 8 == 24)
> + offset = (offset * 3) >> (4 - bppshift);
> + else
> + offset = offset >> (4 - bppshift);
> +
> + RREG_ECRT(0, crtcext0);
> +
> + crtc13 = offset & 0xff;
> +
> + crtcext0 &= ~GENMASK(5, 4);
> + crtcext0 |= (offset & GENMASK(9, 8)) >> 4;
Lot's of hardcoded numbers.
Could the reg file include these so you had more readable defined names?
> +
> + WREG_CRT(0x13, crtc13);
> + WREG_ECRT(0x00, crtcext0);
> +}
> +
> static int mga_crtc_mode_set(struct drm_crtc *crtc,
> struct drm_display_mode *mode,
> struct drm_display_mode *adjusted_mode,
> @@ -1011,7 +1037,6 @@ static int mga_crtc_mode_set(struct drm_crtc *crtc,
> struct drm_device *dev = crtc->dev;
> struct mga_device *mdev = dev->dev_private;
> const struct drm_framebuffer *fb = crtc->primary->fb;
> - int pitch;
> int option = 0, option2 = 0;
> int i;
> unsigned char misc = 0;
> @@ -1122,12 +1147,6 @@ static int mga_crtc_mode_set(struct drm_crtc *crtc,
> WREG_SEQ(3, 0);
> WREG_SEQ(4, 0xe);
>
> - pitch = fb->pitches[0] / fb->format->cpp[0];
> - if (fb->format->cpp[0] * 8 == 24)
> - pitch = (pitch * 3) >> (4 - bppshift);
> - else
> - pitch = pitch >> (4 - bppshift);
> -
> WREG_GFX(0, 0);
> WREG_GFX(1, 0);
> WREG_GFX(2, 0);
> @@ -1144,20 +1163,15 @@ static int mga_crtc_mode_set(struct drm_crtc *crtc,
> WREG_CRT(13, 0);
> WREG_CRT(14, 0);
> WREG_CRT(15, 0);
> - WREG_CRT(19, pitch & 0xFF);
> -
> - ext_vga[0] = 0;
>
> /* TODO interlace */
>
> - ext_vga[0] |= (pitch & 0x300) >> 4;
> if (fb->format->cpp[0] * 8 == 24)
> ext_vga[3] = (((1 << bppshift) * 3) - 1) | 0x80;
> else
> ext_vga[3] = ((1 << bppshift) - 1) | 0x80;
> ext_vga[4] = 0;
>
> - WREG_ECRT(0, ext_vga[0]);
> WREG_ECRT(3, ext_vga[3]);
> WREG_ECRT(4, ext_vga[4]);
>
> @@ -1171,8 +1185,6 @@ static int mga_crtc_mode_set(struct drm_crtc *crtc,
> WREG_ECRT(6, 0);
> }
>
> - WREG_ECRT(0, ext_vga[0]);
> -
> misc = RREG8(MGA_MISC_IN);
> misc |= MGAREG_MISC_IOADSEL |
> MGAREG_MISC_RAMMAPEN |
> @@ -1180,6 +1192,7 @@ static int mga_crtc_mode_set(struct drm_crtc *crtc,
> WREG8(MGA_MISC_OUT, misc);
>
> mga_crtc_do_set_base(mdev, fb, old_fb);
> + mgag200_set_offset(mdev, fb);
>
> mgag200_set_mode_regs(mdev, mode);
Sam
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel
next prev parent reply other threads:[~2020-05-03 15:42 UTC|newest]
Thread overview: 55+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-29 14:32 [PATCH 00/17] drm/mgag200: Convert to atomic modesetting Thomas Zimmermann
2020-04-29 14:32 ` [PATCH 01/17] drm/mgag200: Remove HW cursor Thomas Zimmermann
2020-04-29 17:51 ` Sam Ravnborg
2020-04-30 7:03 ` Gerd Hoffmann
2020-04-30 8:10 ` Thomas Zimmermann
2020-04-30 9:19 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 02/17] drm/mgag200: Remove unused fields from struct mga_device Thomas Zimmermann
2020-04-29 17:49 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 03/17] drm/mgag200: Embed connector instance in " Thomas Zimmermann
2020-04-29 15:24 ` Ruhl, Michael J
2020-04-29 17:49 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 04/17] drm/mgag200: Use managed mode-config initialization Thomas Zimmermann
2020-04-29 17:55 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 05/17] drm/mgag200: Clean up mga_set_start_address() Thomas Zimmermann
2020-04-29 18:20 ` Sam Ravnborg
2020-04-30 8:23 ` Thomas Zimmermann
2020-05-11 12:41 ` Thomas Zimmermann
2020-04-29 14:32 ` [PATCH 06/17] drm/mgag200: Clean up mga_crtc_do_set_base() Thomas Zimmermann
2020-04-29 18:23 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 07/17] drm/mgag200: Move mode-setting code into separate helper function Thomas Zimmermann
2020-04-29 18:24 ` Sam Ravnborg
2020-04-30 8:27 ` Thomas Zimmermann
2020-04-29 14:32 ` [PATCH 08/17] drm/mgag200: Split MISC register update into PLL selection, SYNC and I/O Thomas Zimmermann
2020-05-03 15:34 ` Sam Ravnborg
2020-05-04 13:03 ` Thomas Zimmermann
2020-05-04 14:25 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 09/17] drm/mgag200: Update mode registers after plane registers Thomas Zimmermann
2020-05-03 15:34 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 10/17] drm/mgag200: Set pitch in a separate helper function Thomas Zimmermann
2020-05-03 15:42 ` Sam Ravnborg [this message]
2020-05-04 13:10 ` Thomas Zimmermann
2020-04-29 14:32 ` [PATCH 11/17] drm/mgag200: Set primary plane's format in " Thomas Zimmermann
2020-04-29 14:32 ` [PATCH 12/17] drm/mgag200: Move TAGFIFO reset into separate function Thomas Zimmermann
2020-05-03 16:25 ` Sam Ravnborg
2020-05-04 13:11 ` Thomas Zimmermann
2020-05-04 14:29 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 13/17] drm/mgag200: Move hiprilvl setting into separate functions Thomas Zimmermann
2020-05-03 17:23 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 14/17] drm/mgag200: Move register initialization into separate function Thomas Zimmermann
2020-05-03 17:25 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 15/17] drm/mgag200: Remove waiting from DPMS code Thomas Zimmermann
2020-05-04 12:10 ` Daniel Vetter
2020-05-04 12:40 ` Thomas Zimmermann
2020-04-29 14:32 ` [PATCH 16/17] drm/mgag200: Convert to simple KMS helper Thomas Zimmermann
2020-05-03 17:36 ` Sam Ravnborg
2020-04-29 14:32 ` [PATCH 17/17] drm/mgag200: Replace VRAM helpers with SHMEM helpers Thomas Zimmermann
2020-05-04 12:29 ` Emil Velikov
2020-05-04 12:45 ` Thomas Zimmermann
2020-04-30 0:11 ` [PATCH 00/17] drm/mgag200: Convert to atomic modesetting John Donnelly
2020-04-30 8:29 ` Thomas Zimmermann
2020-04-30 12:09 ` John Donnelly
2020-05-04 13:39 ` Thomas Zimmermann
2020-05-04 20:39 ` John Donnelly
2020-05-05 12:20 ` John Donnelly
2020-05-06 7:29 ` Thomas Zimmermann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200503154209.GC23105@ravnborg.org \
--to=sam@ravnborg.org \
--cc=airlied@redhat.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=john.p.donnelly@oracle.com \
--cc=kraxel@redhat.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox