From: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
To: Jani Nikula <jani.nikula@intel.com>
Cc: intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 10/15] drm/edid/firmware: drop redundant connector_name variable/parameter
Date: Wed, 19 Oct 2022 22:52:51 +0300 [thread overview]
Message-ID: <Y1BVk/Hcjevbkd/p@intel.com> (raw)
In-Reply-To: <e4580510282e9f88c73ea10bab34ba502dae1bb9.1665496046.git.jani.nikula@intel.com>
On Tue, Oct 11, 2022 at 04:49:44PM +0300, Jani Nikula wrote:
> Stop passing around something that's readily available in
> connector->name.
>
> Signed-off-by: Jani Nikula <jani.nikula@intel.com>
Weird. Did we not have a connector in there at some point or something?
Shrug.
Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> ---
> drivers/gpu/drm/drm_edid_load.c | 16 +++++++---------
> 1 file changed, 7 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_edid_load.c b/drivers/gpu/drm/drm_edid_load.c
> index 37d8ba3ddb46..13cdbfb991eb 100644
> --- a/drivers/gpu/drm/drm_edid_load.c
> +++ b/drivers/gpu/drm/drm_edid_load.c
> @@ -167,8 +167,7 @@ static int edid_size(const u8 *edid, int data_size)
> return (edid[0x7e] + 1) * EDID_LENGTH;
> }
>
> -static void *edid_load(struct drm_connector *connector, const char *name,
> - const char *connector_name)
> +static void *edid_load(struct drm_connector *connector, const char *name)
> {
> const struct firmware *fw = NULL;
> const u8 *fwdata;
> @@ -185,10 +184,10 @@ static void *edid_load(struct drm_connector *connector, const char *name,
> struct platform_device *pdev;
> int err;
>
> - pdev = platform_device_register_simple(connector_name, -1, NULL, 0);
> + pdev = platform_device_register_simple(connector->name, -1, NULL, 0);
> if (IS_ERR(pdev)) {
> DRM_ERROR("Failed to register EDID firmware platform device "
> - "for connector \"%s\"\n", connector_name);
> + "for connector \"%s\"\n", connector->name);
> return ERR_CAST(pdev);
> }
>
> @@ -244,7 +243,7 @@ static void *edid_load(struct drm_connector *connector, const char *name,
> edid[EDID_LENGTH-1] += edid[0x7e] - valid_extensions;
> DRM_INFO("Found %d valid extensions instead of %d in EDID data "
> "\"%s\" for connector \"%s\"\n", valid_extensions,
> - edid[0x7e], name, connector_name);
> + edid[0x7e], name, connector->name);
> edid[0x7e] = valid_extensions;
>
> new_edid = krealloc(edid, (valid_extensions + 1) * EDID_LENGTH,
> @@ -256,7 +255,7 @@ static void *edid_load(struct drm_connector *connector, const char *name,
> DRM_INFO("Got %s EDID base block and %d extension%s from "
> "\"%s\" for connector \"%s\"\n", (builtin >= 0) ? "built-in" :
> "external", valid_extensions, valid_extensions == 1 ? "" : "s",
> - name, connector_name);
> + name, connector->name);
>
> out:
> release_firmware(fw);
> @@ -265,7 +264,6 @@ static void *edid_load(struct drm_connector *connector, const char *name,
>
> struct edid *drm_load_edid_firmware(struct drm_connector *connector)
> {
> - const char *connector_name = connector->name;
> char *edidname, *last, *colon, *fwstr, *edidstr, *fallback = NULL;
> struct edid *edid;
>
> @@ -288,7 +286,7 @@ struct edid *drm_load_edid_firmware(struct drm_connector *connector)
> while ((edidname = strsep(&edidstr, ","))) {
> colon = strchr(edidname, ':');
> if (colon != NULL) {
> - if (strncmp(connector_name, edidname, colon - edidname))
> + if (strncmp(connector->name, edidname, colon - edidname))
> continue;
> edidname = colon + 1;
> break;
> @@ -310,7 +308,7 @@ struct edid *drm_load_edid_firmware(struct drm_connector *connector)
> if (*last == '\n')
> *last = '\0';
>
> - edid = edid_load(connector, edidname, connector_name);
> + edid = edid_load(connector, edidname);
> kfree(fwstr);
>
> return edid;
> --
> 2.34.1
--
Ville Syrjälä
Intel
next prev parent reply other threads:[~2022-10-19 19:53 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-10-11 13:49 [PATCH 00/15] drm/edid: EDID override refactoring and fixes Jani Nikula
2022-10-11 13:49 ` [PATCH 01/15] drm/i915/hdmi: do dual mode detect only if connected Jani Nikula
2022-10-13 18:41 ` Ville Syrjälä
2022-10-13 19:24 ` Ville Syrjälä
2022-10-14 8:14 ` Jani Nikula
2022-10-19 18:56 ` Ville Syrjälä
2022-10-19 19:23 ` [Intel-gfx] " Ville Syrjälä
2022-10-20 8:57 ` Jani Nikula
2022-10-20 9:25 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 02/15] drm/i915/hdmi: stop using connector->override_edid Jani Nikula
2022-10-19 19:36 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 03/15] drm/amd/display: " Jani Nikula
2022-10-11 14:07 ` Harry Wentland
2022-10-11 14:11 ` Jani Nikula
2022-10-11 14:19 ` Alex Deucher
2022-10-11 13:49 ` [PATCH 04/15] drm/edid: debug log EDID override set/reset Jani Nikula
2022-10-19 19:36 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 05/15] drm/edid: abstract debugfs override EDID show better Jani Nikula
2022-10-19 19:37 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 06/15] drm/edid: rename drm_add_override_edid_modes() to drm_edid_override_connector_update() Jani Nikula
2022-10-19 20:04 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 07/15] drm/edid: split drm_edid block count helper Jani Nikula
2022-10-19 19:44 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 08/15] drm/edid: add function for checking drm_edid validity Jani Nikula
2022-10-19 19:46 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 09/15] drm/edid: detach debugfs EDID override from EDID property update Jani Nikula
2022-10-19 20:07 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 10/15] drm/edid/firmware: drop redundant connector_name variable/parameter Jani Nikula
2022-10-19 19:52 ` Ville Syrjälä [this message]
2022-10-11 13:49 ` [PATCH 11/15] drm/edid/firmware: rename drm_load_edid_firmware() to drm_edid_load_firmware() Jani Nikula
2022-10-19 20:07 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 12/15] drm/edid: use struct drm_edid for override/firmware EDID Jani Nikula
2022-10-19 20:01 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 13/15] drm/edid: move edid load declarations to internal header Jani Nikula
2022-10-19 20:08 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 14/15] drm/edid/firmware: convert to drm device specific logging Jani Nikula
2022-10-19 20:10 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 15/15] drm/edid: convert to " Jani Nikula
2022-10-19 20:12 ` Ville Syrjälä
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Y1BVk/Hcjevbkd/p@intel.com \
--to=ville.syrjala@linux.intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox