From: Jani Nikula <jani.nikula@intel.com>
To: dri-devel@lists.freedesktop.org
Cc: jani.nikula@intel.com, intel-gfx@lists.freedesktop.org
Subject: [PATCH 00/15] drm/edid: EDID override refactoring and fixes
Date: Tue, 11 Oct 2022 16:49:34 +0300 [thread overview]
Message-ID: <cover.1665496046.git.jani.nikula@intel.com> (raw)
I set out to fix some issues in switching i915 over to use drm_edid more
widely, and stumbled onto issues with edid override usage. Here's some
resulting fixes, refactoring and cleanup.
BR,
Jani.
Jani Nikula (15):
drm/i915/hdmi: do dual mode detect only if connected
drm/i915/hdmi: stop using connector->override_edid
drm/amd/display: stop using connector->override_edid
drm/edid: debug log EDID override set/reset
drm/edid: abstract debugfs override EDID show better
drm/edid: rename drm_add_override_edid_modes() to
drm_edid_override_connector_update()
drm/edid: split drm_edid block count helper
drm/edid: add function for checking drm_edid validity
drm/edid: detach debugfs EDID override from EDID property update
drm/edid/firmware: drop redundant connector_name variable/parameter
drm/edid/firmware: rename drm_load_edid_firmware() to
drm_edid_load_firmware()
drm/edid: use struct drm_edid for override/firmware EDID
drm/edid: move edid load declarations to internal header
drm/edid/firmware: convert to drm device specific logging
drm/edid: convert to device specific logging
.../gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 3 -
drivers/gpu/drm/drm_crtc_internal.h | 15 +-
drivers/gpu/drm/drm_debugfs.c | 8 +-
drivers/gpu/drm/drm_edid.c | 259 ++++++++++--------
drivers/gpu/drm/drm_edid_load.c | 107 ++------
drivers/gpu/drm/drm_probe_helper.c | 2 +-
drivers/gpu/drm/i915/display/intel_hdmi.c | 21 +-
include/drm/drm_connector.h | 11 +-
include/drm/drm_edid.h | 10 +-
9 files changed, 206 insertions(+), 230 deletions(-)
--
2.34.1
next reply other threads:[~2022-10-11 13:50 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-10-11 13:49 Jani Nikula [this message]
2022-10-11 13:49 ` [PATCH 01/15] drm/i915/hdmi: do dual mode detect only if connected Jani Nikula
2022-10-13 18:41 ` Ville Syrjälä
2022-10-13 19:24 ` Ville Syrjälä
2022-10-14 8:14 ` Jani Nikula
2022-10-19 18:56 ` Ville Syrjälä
2022-10-19 19:23 ` [Intel-gfx] " Ville Syrjälä
2022-10-20 8:57 ` Jani Nikula
2022-10-20 9:25 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 02/15] drm/i915/hdmi: stop using connector->override_edid Jani Nikula
2022-10-19 19:36 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 03/15] drm/amd/display: " Jani Nikula
2022-10-11 14:07 ` Harry Wentland
2022-10-11 14:11 ` Jani Nikula
2022-10-11 14:19 ` Alex Deucher
2022-10-11 13:49 ` [PATCH 04/15] drm/edid: debug log EDID override set/reset Jani Nikula
2022-10-19 19:36 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 05/15] drm/edid: abstract debugfs override EDID show better Jani Nikula
2022-10-19 19:37 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 06/15] drm/edid: rename drm_add_override_edid_modes() to drm_edid_override_connector_update() Jani Nikula
2022-10-19 20:04 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 07/15] drm/edid: split drm_edid block count helper Jani Nikula
2022-10-19 19:44 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 08/15] drm/edid: add function for checking drm_edid validity Jani Nikula
2022-10-19 19:46 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 09/15] drm/edid: detach debugfs EDID override from EDID property update Jani Nikula
2022-10-19 20:07 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 10/15] drm/edid/firmware: drop redundant connector_name variable/parameter Jani Nikula
2022-10-19 19:52 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 11/15] drm/edid/firmware: rename drm_load_edid_firmware() to drm_edid_load_firmware() Jani Nikula
2022-10-19 20:07 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 12/15] drm/edid: use struct drm_edid for override/firmware EDID Jani Nikula
2022-10-19 20:01 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 13/15] drm/edid: move edid load declarations to internal header Jani Nikula
2022-10-19 20:08 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 14/15] drm/edid/firmware: convert to drm device specific logging Jani Nikula
2022-10-19 20:10 ` Ville Syrjälä
2022-10-11 13:49 ` [PATCH 15/15] drm/edid: convert to " Jani Nikula
2022-10-19 20:12 ` Ville Syrjälä
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1665496046.git.jani.nikula@intel.com \
--to=jani.nikula@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox