Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel.vetter@ffwll.ch>
To: Intel Graphics Development <intel-gfx@lists.freedesktop.org>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>
Subject: [PATCH 1/5] tests: Start to document naming conventions
Date: Sat,  2 Nov 2013 13:04:32 +0100	[thread overview]
Message-ID: <1383393876-2921-2-git-send-email-daniel.vetter@ffwll.ch> (raw)
In-Reply-To: <1383393876-2921-1-git-send-email-daniel.vetter@ffwll.ch>

Just a start and we need more work here. Some follow-up patches will
clear up some of the historical confusion.

While at it rename the pc8 "basic" test to "rte".

Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
---
 README                  |  3 +++
 tests/NAMING-CONVENTION | 56 +++++++++++++++++++++++++++++++++++++++++++++++++
 tests/pc8.c             |  2 +-
 3 files changed, 60 insertions(+), 1 deletion(-)
 create mode 100644 tests/NAMING-CONVENTION

diff --git a/README b/README
index a04c987dc691..246e24c47ffe 100644
--- a/README
+++ b/README
@@ -62,6 +62,9 @@ tests/
 	  options to test different kms functionality, again read the source for
 	  the details.
 
+	When creating new tests or subtests please read and follow
+	tests/NAMING-CONVENTION.
+
 lib/
 	Common helper functions and headers used by the other tools.
 
diff --git a/tests/NAMING-CONVENTION b/tests/NAMING-CONVENTION
new file mode 100644
index 000000000000..4ae98481ebeb
--- /dev/null
+++ b/tests/NAMING-CONVENTION
@@ -0,0 +1,56 @@
+Naming Convention of i-g-t Tests and Subtests
+=============================================
+
+To facilitate easy test selection with piglit we need a somewhat consistent
+naming scheme for tests and subtests.
+
+Test Prefixes
+-------------
+
+kms_: Used for modesetting tests.
+
+drm_: Tests for libdrm behaviour, currently just testing the buffer cache
+reaping.
+
+gem_: Used for all kinds of GEM tests.
+
+prime_: Used for buffer sharing tests, both for self-importing (used by
+dri3/wayland) and actual multi-gpu tests.
+
+gen3_: Used by Chris' gen3 specific tiling/fencing tests. Generally tests that
+only run on some platforms don't have a specific prefix but just skip on
+platforms where the test doesn't apply.
+
+debugfs_/sysfs_: Mostly for tests that use sysfs/debugfs but tend to tests all
+sorts of things. Please consider using a more appropriate prefix from above if
+the main point isn't to test sysfs/debugfs, but a driver subsystem/feature.
+
+igt_: Testcase which test the i-g-t infrastructure itself and which are all run
+through "make check" while building i-g-t.
+
+(Sub-)Test patterns
+-------------------
+
+Much more powerful for filtering sets of tests are patterns anywhere in either
+the test or subtest name.
+
+hang: Tests that provoke gpu hangs
+
+swap: Tests that force their full working sets through swap. Dreadfully slow on
+machines with spinning rust and tons of memory.
+
+thrash: Tests that tend to have really slow forward progress due to
+gtt/memory/.. thrashing. Mostly used to stress-test error-handling corner-cases.
+
+crc: Tests that use the display CRC infrastructure to check the results.
+
+tiled/tiling: Tests that exercise behaviour on tiled buffers.
+
+normal/uncached/snooped: Usual 3 variants for tests that use different coherency
+modes for the buffer objects they're using.
+
+rte: _R_un_t_ime _e_nviroment checks. For testcases which will fail if the
+machine isn't configured properly there should be a first subtest to just check
+for that.
+
+ctx: Tests that exercise the hw context support.
diff --git a/tests/pc8.c b/tests/pc8.c
index 0ec011e3b87f..e56a5f8c7a65 100644
--- a/tests/pc8.c
+++ b/tests/pc8.c
@@ -790,7 +790,7 @@ int main(int argc, char *argv[])
 	igt_fixture
 		setup_environment();
 
-	igt_subtest("basic")
+	igt_subtest("rte")
 		basic_subtest();
 	igt_subtest("drm-resources-equal")
 		drm_resources_equal_subtest();
-- 
1.8.4.rc3

  reply	other threads:[~2013-11-02 12:04 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-11-02 12:04 [PATCH 0/5] igt test naming conventions Daniel Vetter
2013-11-02 12:04 ` Daniel Vetter [this message]
2013-11-02 12:04 ` [PATCH 2/5] tests: estbalish drv_ prefix Daniel Vetter
2013-11-02 12:04 ` [PATCH 3/5] tests: establish pm_ prefix Daniel Vetter
2013-11-02 12:04 ` [PATCH 4/5] tests: Use kms_ prefix a bit more Daniel Vetter
2013-11-02 12:04 ` [PATCH 5/5] tests: establish core_ prefix Daniel Vetter
2013-11-04 18:53 ` [PATCH 0/5] igt test naming conventions Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1383393876-2921-2-git-send-email-daniel.vetter@ffwll.ch \
    --to=daniel.vetter@ffwll.ch \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox