Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Ben Widawsky <ben@bwidawsk.net>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH] drm/i915: consolidate interrupt naming scheme
Date: Mon, 21 May 2012 14:01:52 -0700	[thread overview]
Message-ID: <20120521140152.49a91dd4@bwidawsk.net> (raw)
In-Reply-To: <1337589967_155276@CP5-2952>

On Mon, 21 May 2012 09:46:00 +0100
Chris Wilson <chris@chris-wilson.co.uk> wrote:

> On Fri, 18 May 2012 09:02:09 -0700, Ben Widawsky <ben@bwidawsk.net> wrote:
> > here are some opportunities to do things a bit better with the naming of
> > things now that our hindsight is better.
> 
> The major problem with this is that it breaks the expectations of the
> INTEL_ namespace, masquerading per-gen values as fixed constants for all
> chipsets.
> -Chris
> 

With only a couple of exceptions (BSD user interrupt) there is no need
for per-gen values. I think we shouldn't have much trouble maintaining
this as is. The existing naming scheme wrongly calls things GEN6 when
they were introduced earlier (I'm also not sure GT_ is valid for every
interrupt). So the goal was to have I915_* for old stuff, INTEL_* for
everything, and DEVICENAME_ for special cases.


-- 
Ben Widawsky, Intel Open Source Technology Center

  reply	other threads:[~2012-05-21 21:03 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-05-18 16:02 [PATCH] drm/i915: consolidate interrupt naming scheme Ben Widawsky
2012-05-21  8:46 ` Chris Wilson
2012-05-21 21:01   ` Ben Widawsky [this message]
2012-05-21 21:45     ` Chris Wilson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120521140152.49a91dd4@bwidawsk.net \
    --to=ben@bwidawsk.net \
    --cc=chris@chris-wilson.co.uk \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox