From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH] drm/i915: Refactor the wait_rendering completion into a common routine
Date: Sat, 29 Jun 2013 23:34:39 +0200 [thread overview]
Message-ID: <20130629213438.GC18285@phenom.ffwll.local> (raw)
In-Reply-To: <1372539926-25587-1-git-send-email-chris@chris-wilson.co.uk>
On Sat, Jun 29, 2013 at 10:05:26PM +0100, Chris Wilson wrote:
> Harmonise the completion logic between the non-blocking and normal
> wait_rendering paths, and move that logic into a common function.
>
> In the process, we note that the last_write_seqno is by definition the
> earlier of the two read/write seqnos and so all successful waits will
> have passed the last_write_seqno. Therefore we can unconditionally clear
> the write seqno and its domains in the completion logic.
>
> v2: Add the missing ring parameter, because sometimes it is good to have
> things compile.
>
> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Queued for -next, thanks for the patch.
-Daniel
> ---
> drivers/gpu/drm/i915/i915_gem.c | 48 ++++++++++++++++++++---------------------
> 1 file changed, 23 insertions(+), 25 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_gem.c b/drivers/gpu/drm/i915/i915_gem.c
> index 8e9e9d7..7c9ed3a 100644
> --- a/drivers/gpu/drm/i915/i915_gem.c
> +++ b/drivers/gpu/drm/i915/i915_gem.c
> @@ -1087,6 +1087,25 @@ i915_wait_seqno(struct intel_ring_buffer *ring, uint32_t seqno)
> interruptible, NULL);
> }
>
> +static int
> +i915_gem_object_wait_rendering__tail(struct drm_i915_gem_object *obj,
> + struct intel_ring_buffer *ring)
> +{
> + i915_gem_retire_requests_ring(ring);
> +
> + /* Manually manage the write flush as we may have not yet
> + * retired the buffer.
> + *
> + * Note that the last_write_seqno is always the earlier of
> + * the two (read/write) seqno, so if we haved successfully waited,
> + * we know we have passed the last write.
> + */
> + obj->last_write_seqno = 0;
> + obj->base.write_domain &= ~I915_GEM_GPU_DOMAINS;
> +
> + return 0;
> +}
> +
> /**
> * Ensures that all rendering to the object has completed and the object is
> * safe to unbind from the GTT or access from the CPU.
> @@ -1107,18 +1126,7 @@ i915_gem_object_wait_rendering(struct drm_i915_gem_object *obj,
> if (ret)
> return ret;
>
> - i915_gem_retire_requests_ring(ring);
> -
> - /* Manually manage the write flush as we may have not yet
> - * retired the buffer.
> - */
> - if (obj->last_write_seqno &&
> - i915_seqno_passed(seqno, obj->last_write_seqno)) {
> - obj->last_write_seqno = 0;
> - obj->base.write_domain &= ~I915_GEM_GPU_DOMAINS;
> - }
> -
> - return 0;
> + return i915_gem_object_wait_rendering__tail(obj, ring);
> }
>
> /* A nonblocking variant of the above wait. This is a highly dangerous routine
> @@ -1154,20 +1162,10 @@ i915_gem_object_wait_rendering__nonblocking(struct drm_i915_gem_object *obj,
> mutex_unlock(&dev->struct_mutex);
> ret = __wait_seqno(ring, seqno, reset_counter, true, NULL);
> mutex_lock(&dev->struct_mutex);
> + if (ret)
> + return ret;
>
> - i915_gem_retire_requests_ring(ring);
> -
> - /* Manually manage the write flush as we may have not yet
> - * retired the buffer.
> - */
> - if (ret == 0 &&
> - obj->last_write_seqno &&
> - i915_seqno_passed(seqno, obj->last_write_seqno)) {
> - obj->last_write_seqno = 0;
> - obj->base.write_domain &= ~I915_GEM_GPU_DOMAINS;
> - }
> -
> - return ret;
> + return i915_gem_object_wait_rendering__tail(obj, ring);
> }
>
> /**
> --
> 1.8.3.1
>
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
prev parent reply other threads:[~2013-06-29 21:34 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-29 7:36 [PATCH] drm/i915: Refactor the wait_rendering completion into a common routine Chris Wilson
2013-06-29 14:35 ` Daniel Vetter
2013-06-29 15:55 ` Daniel Vetter
2013-06-29 20:03 ` Daniel Vetter
2013-06-29 21:05 ` Chris Wilson
2013-06-29 21:34 ` Daniel Vetter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130629213438.GC18285@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox