From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>,
Mika Kuoppala <mika.kuoppala@linux.intel.com>,
intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 4/4] drm/i915: add error_state sysfs entry
Date: Mon, 1 Jul 2013 18:56:46 +0200 [thread overview]
Message-ID: <20130701165646.GV18285@phenom.ffwll.local> (raw)
In-Reply-To: <20130701161959.GB4340@cantiga.alporthouse.com>
On Mon, Jul 01, 2013 at 05:19:59PM +0100, Chris Wilson wrote:
> On Thu, Jun 06, 2013 at 05:38:54PM +0300, Mika Kuoppala wrote:
> > As getting error state doesn't anymore require big kmallocs,
> > make error state accessible also from sysfs.
> >
> > v2: - error state clearing (Chris Wilson)
> > - user hint, proper access mode bits and name (Daniel Vetter)
> >
> > v3: release resources in proper order (Chris Wilson)
> >
> > Suggested-by: Daniel Vetter <daniel.vetter@ffwll.ch>
> > Signed-off-by: Mika Kuoppala <mika.kuoppala@intel.com>
>
> I am happy overall here. We could take the plunge and use this as an
> excuse to move all the error-state string handling into a new file,
> which would be useful for when we pull the hangcheck mechanism out of
> i915_irq.c.
>
> Perhaps the more pressing bikeshed is that after years of
> i915_error_state, I'm tired of the name and think that the 'state' was
> just redundant, so perhaps '/sys/class/drm/card0/error' is a nice
> minimalist and modern looking name.
Series merged with this bikeshed applied and your r-b from irc added.
Thanks, Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
prev parent reply other threads:[~2013-07-01 16:56 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-06 12:18 [PATCH 1/4] drm/i915: export error state to string conversion Mika Kuoppala
2013-06-06 12:18 ` [PATCH 2/4] drm/i915: export error state ref handling Mika Kuoppala
2013-06-06 12:18 ` [PATCH 3/4] drm/i915: introduce i915_error_state_buf_init Mika Kuoppala
2013-06-06 12:18 ` [PATCH 4/4] drm/i915: add i915_error_state sysfs entry Mika Kuoppala
2013-06-06 12:22 ` Chris Wilson
2013-06-06 12:24 ` Daniel Vetter
2013-06-06 13:33 ` [PATCH 4/4] drm/i915: add error_state " Mika Kuoppala
2013-06-06 13:48 ` Chris Wilson
2013-06-06 14:38 ` Mika Kuoppala
2013-07-01 16:19 ` Chris Wilson
2013-07-01 16:56 ` Daniel Vetter [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130701165646.GV18285@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
--cc=mika.kuoppala@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox