From: Daniel Vetter <daniel@ffwll.ch>
To: Jani Nikula <jani.nikula@intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH v2 2/2] drm/i915: move module parameters into a struct, in a new file
Date: Sun, 26 Jan 2014 15:38:41 +0100 [thread overview]
Message-ID: <20140126143841.GU9772@phenom.ffwll.local> (raw)
In-Reply-To: <1390296265-23565-2-git-send-email-jani.nikula@intel.com>
On Tue, Jan 21, 2014 at 11:24:25AM +0200, Jani Nikula wrote:
> With 20+ module parameters, I think referring to them via a struct
> improves clarity over just having a bunch of globals. While at it, move
> the parameter initialization and definitions into a new file
> i915_params.c to reduce clutter in i915_drv.c.
>
> Apart from the ill-named i915_enable_rc6, i915_enable_fbc and
> i915_enable_ppgtt parameters, for which we lose the "i915_" prefix
> internally, the module parameters now look the same both on the kernel
> command line and in code. For example, "i915.modeset".
>
> The downsides of the change are losing static on a couple of variables
> and not having the initialization and module_param_named() right next to
> each other. On the other hand, all module parameters are now defined in
> one place at i915_params.c. Plus you can do this to find all module
> parameter references:
>
> $ git grep "i915\." -- drivers/gpu/drm/i915
>
> v2:
> - move the definitions into a new file
> - s/i915_params/i915/
> - make i915_try_reset i915.reset, for consistency
>
> Signed-off-by: Jani Nikula <jani.nikula@intel.com>
Queued for -next, thanks for the patch. While we're at it: Can you please
smash another patch on top ot drop the i915_ prefix from the module
parameters? i915.i915_ really is a bit verbose ;-) and I think we can declare
this to be non-abi, i.e. a good excuse to update all the various bug
reports ;-)
-Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
next prev parent reply other threads:[~2014-01-26 14:38 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-01-03 11:26 [RFC PATCH] drm/i915: move module parameters into a struct Jani Nikula
2014-01-03 16:19 ` Paulo Zanoni
2014-01-07 7:55 ` Daniel Vetter
2014-01-21 9:24 ` [PATCH v2 1/2] drm/i915: drop the i915.fbpercrtc module parameter Jani Nikula
2014-01-21 9:24 ` [PATCH v2 2/2] drm/i915: move module parameters into a struct, in a new file Jani Nikula
2014-01-26 14:38 ` Daniel Vetter [this message]
2014-01-21 9:28 ` [PATCH v2 1/2] drm/i915: drop the i915.fbpercrtc module parameter Daniel Vetter
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140126143841.GU9772@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox