Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
To: Jani Nikula <jani.nikula@intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH v2 5/7] drm/i915: rename has_edp_a() to ilk_has_edp_a()
Date: Wed, 23 Jan 2019 20:35:51 +0200	[thread overview]
Message-ID: <20190123183551.GF20097@intel.com> (raw)
In-Reply-To: <20190122082307.4003-5-jani.nikula@intel.com>

On Tue, Jan 22, 2019 at 10:23:05AM +0200, Jani Nikula wrote:
> Clarify that the name is specific to ILK+ PCH platforms.
> 
> v2: prefix the name with ilk rather than pch (Ville)
> 
> Signed-off-by: Jani Nikula <jani.nikula@intel.com>

Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

> ---
>  drivers/gpu/drm/i915/intel_display.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
> index 8e89f04ddd9c..9895ea566f99 100644
> --- a/drivers/gpu/drm/i915/intel_display.c
> +++ b/drivers/gpu/drm/i915/intel_display.c
> @@ -14231,7 +14231,7 @@ static int intel_encoder_clones(struct intel_encoder *encoder)
>  	return index_mask;
>  }
>  
> -static bool has_edp_a(struct drm_i915_private *dev_priv)
> +static bool ilk_has_edp_a(struct drm_i915_private *dev_priv)
>  {
>  	if (!IS_MOBILE(dev_priv))
>  		return false;
> @@ -14388,7 +14388,7 @@ static void intel_setup_outputs(struct drm_i915_private *dev_priv)
>  
>  		dpd_is_edp = intel_dp_is_port_edp(dev_priv, PORT_D);
>  
> -		if (has_edp_a(dev_priv))
> +		if (ilk_has_edp_a(dev_priv))
>  			intel_dp_init(dev_priv, DP_A, PORT_A);
>  
>  		if (I915_READ(PCH_HDMIB) & SDVO_DETECTED) {
> -- 
> 2.20.1

-- 
Ville Syrjälä
Intel
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2019-01-23 18:35 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-01-22  8:23 [PATCH v2 1/7] drm/i915/crt: split out intel_crt_present() to platform specific setup Jani Nikula
2019-01-22  8:23 ` [PATCH v2 2/7] drm/i915/lvds: only call intel_lvds_init() on platforms that might have LVDS Jani Nikula
2019-01-22  8:23 ` [PATCH v2 3/7] drm/i915/lvds: nuke intel_lvds_supported() Jani Nikula
2019-01-22  8:23 ` [PATCH v2 4/7] drm/i915/tv: only call intel_tv_init() on platforms that might have TV Jani Nikula
2019-01-22  8:23 ` [PATCH v2 5/7] drm/i915: rename has_edp_a() to ilk_has_edp_a() Jani Nikula
2019-01-23 18:35   ` Ville Syrjälä [this message]
2019-01-22  8:23 ` [PATCH v2 6/7] drm/i915/lvds: simplify gen 2 lvds presence Jani Nikula
2019-01-23 18:36   ` Ville Syrjälä
2019-01-22  8:23 ` [PATCH v2 7/7] drm/i915/crt: simplify CRT VBT check on pre-VLV/DDI Jani Nikula
2019-01-23 18:36   ` Ville Syrjälä
2019-01-24  7:40     ` Jani Nikula
2019-01-22  9:01 ` ✓ Fi.CI.BAT: success for series starting with [v2,1/7] drm/i915/crt: split out intel_crt_present() to platform specific setup Patchwork
2019-01-22  9:50 ` ✓ Fi.CI.IGT: " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190123183551.GF20097@intel.com \
    --to=ville.syrjala@linux.intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=jani.nikula@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox