Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
	intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v2 1/4] drm: Expose a method for creating anonymous struct file around drm_minor
Date: Wed, 6 Nov 2019 15:22:31 +0100	[thread overview]
Message-ID: <20191106142231.GH23790@phenom.ffwll.local> (raw)
In-Reply-To: <20191106135739.7583-1-chris@chris-wilson.co.uk>

On Wed, Nov 06, 2019 at 01:57:36PM +0000, Chris Wilson wrote:
> Sometimes we need to create a struct file to wrap a drm_device, as it
> the user were to have opened /dev/dri/card0 but to do so anonymously
> (i.e. for internal use). Provide a utility method to create a struct
> file with the drm_device->driver.fops, that wrap the drm_device.
> 
> v2: Restrict usage to selftests
> 
> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>

Not fully sold on the name, but then fget/fput/get_file and friends are
all supremely confusing naming already, so meh.

And on 2nd reading the f_mapping is the only thing we need for
unmap_mapping_range, so should be all fine too.

Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>

> ---
>  drivers/gpu/drm/Kconfig    |  4 ++++
>  drivers/gpu/drm/drm_file.c | 42 ++++++++++++++++++++++++++++++++++++++
>  include/drm/drm_file.h     |  3 +++
>  3 files changed, 49 insertions(+)
> 
> diff --git a/drivers/gpu/drm/Kconfig b/drivers/gpu/drm/Kconfig
> index 617d9c3a86c3..589d5d693855 100644
> --- a/drivers/gpu/drm/Kconfig
> +++ b/drivers/gpu/drm/Kconfig
> @@ -70,6 +70,10 @@ config DRM_DEBUG_SELFTEST
>  
>  	  If in doubt, say "N".
>  
> +config DRM_DEBUG_SELFTEST_MODULE
> +	bool
> +	depends on DRM_DEBUG_SELFTEST
> +
>  config DRM_KMS_HELPER
>  	tristate
>  	depends on DRM
> diff --git a/drivers/gpu/drm/drm_file.c b/drivers/gpu/drm/drm_file.c
> index ea34bc991858..4d9385d1bf2d 100644
> --- a/drivers/gpu/drm/drm_file.c
> +++ b/drivers/gpu/drm/drm_file.c
> @@ -31,7 +31,9 @@
>   * OTHER DEALINGS IN THE SOFTWARE.
>   */
>  
> +#include <linux/anon_inodes.h>
>  #include <linux/dma-fence.h>
> +#include <linux/file.h>
>  #include <linux/module.h>
>  #include <linux/pci.h>
>  #include <linux/poll.h>
> @@ -754,3 +756,43 @@ void drm_send_event(struct drm_device *dev, struct drm_pending_event *e)
>  	spin_unlock_irqrestore(&dev->event_lock, irqflags);
>  }
>  EXPORT_SYMBOL(drm_send_event);
> +
> +/**
> + * mock_drm_getfile - Create a new struct file for the drm device
> + * @minor: drm minor to wrap (e.g. #drm_device.primary)
> + * @flags: file creation mode (O_RDWR etc)
> + *
> + * This create a new struct file that wraps a DRM file context around a
> + * DRM minor. This mimicks userspace opening e.g. /dev/dri/card0, but without
> + * invoking userspace. The struct file may be operated on using its f_op
> + * (the drm_device.driver.fops) to mimick userspace operations, or be supplied
> + * to userspace facing functions as an internal/anonymous client.
> + *
> + * RETURNS:
> + * Pointer to newly created struct file, ERR_PTR on failure.
> + */
> +struct file *mock_drm_getfile(struct drm_minor *minor, unsigned int flags)
> +{
> +	struct drm_device *dev = minor->dev;
> +	struct drm_file *priv;
> +	struct file *file;
> +
> +	priv = drm_file_alloc(minor);
> +	if (IS_ERR(priv))
> +		return ERR_CAST(priv);
> +
> +	file = anon_inode_getfile("drm", dev->driver->fops, priv, flags);
> +	if (IS_ERR(file)) {
> +		drm_file_free(priv);
> +		return file;
> +	}
> +
> +	/* Everyone shares a single global address space */
> +	file->f_mapping = dev->anon_inode->i_mapping;
> +
> +	drm_dev_get(dev);
> +	priv->filp = file;
> +
> +	return file;
> +}
> +EXPORT_SYMBOL_FOR_TESTS_ONLY(mock_drm_getfile);
> diff --git a/include/drm/drm_file.h b/include/drm/drm_file.h
> index 67af60bb527a..8b099b347817 100644
> --- a/include/drm/drm_file.h
> +++ b/include/drm/drm_file.h
> @@ -42,6 +42,7 @@ struct dma_fence;
>  struct drm_file;
>  struct drm_device;
>  struct device;
> +struct file;
>  
>  /*
>   * FIXME: Not sure we want to have drm_minor here in the end, but to avoid
> @@ -387,4 +388,6 @@ void drm_event_cancel_free(struct drm_device *dev,
>  void drm_send_event_locked(struct drm_device *dev, struct drm_pending_event *e);
>  void drm_send_event(struct drm_device *dev, struct drm_pending_event *e);
>  
> +struct file *mock_drm_getfile(struct drm_minor *minor, unsigned int flags);
> +
>  #endif /* _DRM_FILE_H_ */
> -- 
> 2.24.0
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

WARNING: multiple messages have this Message-ID (diff)
From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
	intel-gfx@lists.freedesktop.org, dri-devel@lists.freedesktop.org
Subject: Re: [Intel-gfx] [PATCH v2 1/4] drm: Expose a method for creating anonymous struct file around drm_minor
Date: Wed, 6 Nov 2019 15:22:31 +0100	[thread overview]
Message-ID: <20191106142231.GH23790@phenom.ffwll.local> (raw)
Message-ID: <20191106142231.Gf8BKEYGjswyqzkItGUxhCBbcAFztiNe2P8P-Oo5DAI@z> (raw)
In-Reply-To: <20191106135739.7583-1-chris@chris-wilson.co.uk>

On Wed, Nov 06, 2019 at 01:57:36PM +0000, Chris Wilson wrote:
> Sometimes we need to create a struct file to wrap a drm_device, as it
> the user were to have opened /dev/dri/card0 but to do so anonymously
> (i.e. for internal use). Provide a utility method to create a struct
> file with the drm_device->driver.fops, that wrap the drm_device.
> 
> v2: Restrict usage to selftests
> 
> Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
> Cc: Daniel Vetter <daniel.vetter@ffwll.ch>

Not fully sold on the name, but then fget/fput/get_file and friends are
all supremely confusing naming already, so meh.

And on 2nd reading the f_mapping is the only thing we need for
unmap_mapping_range, so should be all fine too.

Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>

> ---
>  drivers/gpu/drm/Kconfig    |  4 ++++
>  drivers/gpu/drm/drm_file.c | 42 ++++++++++++++++++++++++++++++++++++++
>  include/drm/drm_file.h     |  3 +++
>  3 files changed, 49 insertions(+)
> 
> diff --git a/drivers/gpu/drm/Kconfig b/drivers/gpu/drm/Kconfig
> index 617d9c3a86c3..589d5d693855 100644
> --- a/drivers/gpu/drm/Kconfig
> +++ b/drivers/gpu/drm/Kconfig
> @@ -70,6 +70,10 @@ config DRM_DEBUG_SELFTEST
>  
>  	  If in doubt, say "N".
>  
> +config DRM_DEBUG_SELFTEST_MODULE
> +	bool
> +	depends on DRM_DEBUG_SELFTEST
> +
>  config DRM_KMS_HELPER
>  	tristate
>  	depends on DRM
> diff --git a/drivers/gpu/drm/drm_file.c b/drivers/gpu/drm/drm_file.c
> index ea34bc991858..4d9385d1bf2d 100644
> --- a/drivers/gpu/drm/drm_file.c
> +++ b/drivers/gpu/drm/drm_file.c
> @@ -31,7 +31,9 @@
>   * OTHER DEALINGS IN THE SOFTWARE.
>   */
>  
> +#include <linux/anon_inodes.h>
>  #include <linux/dma-fence.h>
> +#include <linux/file.h>
>  #include <linux/module.h>
>  #include <linux/pci.h>
>  #include <linux/poll.h>
> @@ -754,3 +756,43 @@ void drm_send_event(struct drm_device *dev, struct drm_pending_event *e)
>  	spin_unlock_irqrestore(&dev->event_lock, irqflags);
>  }
>  EXPORT_SYMBOL(drm_send_event);
> +
> +/**
> + * mock_drm_getfile - Create a new struct file for the drm device
> + * @minor: drm minor to wrap (e.g. #drm_device.primary)
> + * @flags: file creation mode (O_RDWR etc)
> + *
> + * This create a new struct file that wraps a DRM file context around a
> + * DRM minor. This mimicks userspace opening e.g. /dev/dri/card0, but without
> + * invoking userspace. The struct file may be operated on using its f_op
> + * (the drm_device.driver.fops) to mimick userspace operations, or be supplied
> + * to userspace facing functions as an internal/anonymous client.
> + *
> + * RETURNS:
> + * Pointer to newly created struct file, ERR_PTR on failure.
> + */
> +struct file *mock_drm_getfile(struct drm_minor *minor, unsigned int flags)
> +{
> +	struct drm_device *dev = minor->dev;
> +	struct drm_file *priv;
> +	struct file *file;
> +
> +	priv = drm_file_alloc(minor);
> +	if (IS_ERR(priv))
> +		return ERR_CAST(priv);
> +
> +	file = anon_inode_getfile("drm", dev->driver->fops, priv, flags);
> +	if (IS_ERR(file)) {
> +		drm_file_free(priv);
> +		return file;
> +	}
> +
> +	/* Everyone shares a single global address space */
> +	file->f_mapping = dev->anon_inode->i_mapping;
> +
> +	drm_dev_get(dev);
> +	priv->filp = file;
> +
> +	return file;
> +}
> +EXPORT_SYMBOL_FOR_TESTS_ONLY(mock_drm_getfile);
> diff --git a/include/drm/drm_file.h b/include/drm/drm_file.h
> index 67af60bb527a..8b099b347817 100644
> --- a/include/drm/drm_file.h
> +++ b/include/drm/drm_file.h
> @@ -42,6 +42,7 @@ struct dma_fence;
>  struct drm_file;
>  struct drm_device;
>  struct device;
> +struct file;
>  
>  /*
>   * FIXME: Not sure we want to have drm_minor here in the end, but to avoid
> @@ -387,4 +388,6 @@ void drm_event_cancel_free(struct drm_device *dev,
>  void drm_send_event_locked(struct drm_device *dev, struct drm_pending_event *e);
>  void drm_send_event(struct drm_device *dev, struct drm_pending_event *e);
>  
> +struct file *mock_drm_getfile(struct drm_minor *minor, unsigned int flags);
> +
>  #endif /* _DRM_FILE_H_ */
> -- 
> 2.24.0
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
http://blog.ffwll.ch
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  parent reply	other threads:[~2019-11-06 14:22 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-11-06 13:57 [PATCH v2 1/4] drm: Expose a method for creating anonymous struct file around drm_minor Chris Wilson
2019-11-06 13:57 ` [Intel-gfx] " Chris Wilson
2019-11-06 13:57 ` [PATCH v2 2/4] drm/i915/selftests: Replace mock_file hackery with drm's true fake Chris Wilson
2019-11-06 13:57   ` [Intel-gfx] " Chris Wilson
2019-11-06 13:57 ` [PATCH v2 3/4] drm/i915/selftests: Wrap vm_mmap() around GEM objects Chris Wilson
2019-11-06 13:57   ` [Intel-gfx] " Chris Wilson
2019-11-06 13:57 ` [PATCH v2 4/4] drm/i915/selftests: Verify mmap_gtt revocation on unbinding Chris Wilson
2019-11-06 13:57   ` [Intel-gfx] " Chris Wilson
2019-11-06 14:22 ` Daniel Vetter [this message]
2019-11-06 14:22   ` [Intel-gfx] [PATCH v2 1/4] drm: Expose a method for creating anonymous struct file around drm_minor Daniel Vetter
2019-11-06 16:54 ` ✗ Fi.CI.CHECKPATCH: warning for series starting with [v2,1/4] " Patchwork
2019-11-06 16:54   ` [Intel-gfx] " Patchwork
2019-11-06 17:16 ` ✗ Fi.CI.BAT: failure " Patchwork
2019-11-06 17:16   ` [Intel-gfx] " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191106142231.GH23790@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=chris@chris-wilson.co.uk \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox