From: Ville Syrjala <ville.syrjala@linux.intel.com>
To: intel-gfx@lists.freedesktop.org
Subject: [PATCH 01/13] drm/i915: Correct for_each_old_global_obj_in_state() arguments
Date: Thu, 8 Feb 2024 17:17:08 +0200 [thread overview]
Message-ID: <20240208151720.7866-2-ville.syrjala@linux.intel.com> (raw)
In-Reply-To: <20240208151720.7866-1-ville.syrjala@linux.intel.com>
From: Ville Syrjälä <ville.syrjala@linux.intel.com>
for_each_old_global_obj_in_state() gives us the old state, not the
new state. Correct the name of the macro argument.
Note that while the argument was misnamed the macro did work
correctly regardless.
Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
---
drivers/gpu/drm/i915/display/intel_global_state.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/i915/display/intel_global_state.h b/drivers/gpu/drm/i915/display/intel_global_state.h
index 5c8545d7a76a..6506a8e32972 100644
--- a/drivers/gpu/drm/i915/display/intel_global_state.h
+++ b/drivers/gpu/drm/i915/display/intel_global_state.h
@@ -37,11 +37,11 @@ struct intel_global_obj {
(__i)++) \
for_each_if(obj)
-#define for_each_old_global_obj_in_state(__state, obj, new_obj_state, __i) \
+#define for_each_old_global_obj_in_state(__state, obj, old_obj_state, __i) \
for ((__i) = 0; \
(__i) < (__state)->num_global_objs && \
((obj) = (__state)->global_objs[__i].ptr, \
- (new_obj_state) = (__state)->global_objs[__i].old_state, 1); \
+ (old_obj_state) = (__state)->global_objs[__i].old_state, 1); \
(__i)++) \
for_each_if(obj)
--
2.43.0
next prev parent reply other threads:[~2024-02-08 15:17 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-08 15:17 [PATCH 00/13] drm/i915: drm_dbg_kms() conversions and cleanups Ville Syrjala
2024-02-08 15:17 ` Ville Syrjala [this message]
2024-02-08 15:17 ` [PATCH 02/13] drm/i915/sdvo: Convert to per-device debugs Ville Syrjala
2024-02-08 15:17 ` [PATCH 03/13] drm/i915/sdvo: Fix up code alignment Ville Syrjala
2024-02-08 15:17 ` [PATCH 04/13] drm/i915/color: Use per-device debugs Ville Syrjala
2024-02-08 15:17 ` [PATCH 05/13] drm/i915/fb: " Ville Syrjala
2024-02-08 15:17 ` [PATCH 06/13] drm/i915/bios: Switch to kms debugs Ville Syrjala
2024-02-08 15:17 ` [PATCH 07/13] drm/i915/bios: Use per-device debugs for VBT related stuff Ville Syrjala
2024-02-08 15:17 ` [PATCH 08/13] drm/i915/hdcp: Use per-device debugs Ville Syrjala
2024-02-08 15:17 ` [PATCH 09/13] drm/i915/wm: Pass the whole i916 to intel_get_cxsr_latency() Ville Syrjala
2024-02-08 15:17 ` [PATCH 10/13] drm/i915/wm: Use per-device debugs in pre-ilk wm code Ville Syrjala
2024-02-08 15:17 ` [PATCH 11/13] drm/i915/wm: Use per-device debugs ilk " Ville Syrjala
2024-02-08 15:17 ` [PATCH 12/13] drm/i915/dvo/ns2501: Nuke pointless casts Ville Syrjala
2024-02-08 15:17 ` [PATCH 13/13] drm/i915/dvo: Use sizeof(*variable) instead of sizeof(type) Ville Syrjala
2024-02-08 15:52 ` [PATCH 00/13] drm/i915: drm_dbg_kms() conversions and cleanups Jani Nikula
2024-02-09 12:54 ` Ville Syrjälä
2024-02-08 21:43 ` ✗ Fi.CI.CHECKPATCH: warning for " Patchwork
2024-02-08 21:43 ` ✗ Fi.CI.SPARSE: " Patchwork
2024-02-08 22:02 ` ✓ Fi.CI.BAT: success " Patchwork
2024-02-09 3:35 ` ✗ Fi.CI.IGT: failure " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240208151720.7866-2-ville.syrjala@linux.intel.com \
--to=ville.syrjala@linux.intel.com \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox