From: Imre Deak <imre.deak@intel.com>
To: <intel-gfx@lists.freedesktop.org>, <intel-xe@lists.freedesktop.org>
Cc: "Ankit Nautiyal" <ankit.k.nautiyal@intel.com>,
"Luca Coelho" <luciano.coelho@intel.com>,
"Jouni Högander" <jouni.hogander@intel.com>,
"Vinod Govindapillai" <vinod.govindapillai@intel.com>
Subject: [PATCH 00/15] drm/i915/dp: Clean up link BW/DSC slice config computation (DSC slice)
Date: Wed, 14 Jan 2026 18:22:17 +0200 [thread overview]
Message-ID: <20260114162232.92731-1-imre.deak@intel.com> (raw)
This is the third part of patchset [1] containing the refactoring
(patches 36-50) of the DSC slice config computation. The first and
second part of [1] are merged now to drm-tip, see [2] and [3].
[1] https://lore.kernel.org/all/20251127175023.1522538-1-imre.deak@intel.com
[2] https://lore.kernel.org/all/20251215192357.172201-1-imre.deak@intel.com
[3] https://lore.kernel.org/all/20251222153547.713360-1-imre.deak@intel.com
Cc: Ankit Nautiyal <ankit.k.nautiyal@intel.com>
Cc: Luca Coelho <luciano.coelho@intel.com>
Cc: Jouni Högander <jouni.hogander@intel.com>
Cc: Vinod Govindapillai <vinod.govindapillai@intel.com>
Imre Deak (15):
drm/i915/dsc: Track the detaild DSC slice configuration
drm/i915/dsc: Track the DSC stream count in the DSC slice config state
drm/i915/dsi: Move initialization of DSI DSC streams-per-pipe to
fill_dsc()
drm/i915/dsi: Track the detailed DSC slice configuration
drm/i915/dp: Track the detailed DSC slice configuration
drm/i915/dsc: Switch to using intel_dsc_line_slice_count()
drm/i915/dp: Factor out intel_dp_dsc_min_slice_count()
drm/i915/dp: Use int for DSC slice count variables
drm/i915/dp: Rename test_slice_count to slices_per_line
drm/i915/dp: Simplify the DSC slice config loop's slices-per-pipe
iteration
drm/i915/dsc: Add intel_dsc_get_slice_config()
drm/i915/dsi: Use intel_dsc_get_slice_config()
drm/i915/dp: Unify DP and eDP slice count computation
drm/i915/dp: Add intel_dp_dsc_get_slice_config()
drm/i915/dp: Use intel_dp_dsc_get_slice_config()
drivers/gpu/drm/i915/display/icl_dsi.c | 6 -
drivers/gpu/drm/i915/display/intel_bios.c | 27 ++-
drivers/gpu/drm/i915/display/intel_display.c | 2 +-
.../drm/i915/display/intel_display_types.h | 7 +-
drivers/gpu/drm/i915/display/intel_dp.c | 184 +++++++++---------
drivers/gpu/drm/i915/display/intel_vdsc.c | 73 ++++++-
drivers/gpu/drm/i915/display/intel_vdsc.h | 6 +
7 files changed, 186 insertions(+), 119 deletions(-)
--
2.49.1
next reply other threads:[~2026-01-14 16:23 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-14 16:22 Imre Deak [this message]
2026-01-14 16:22 ` [PATCH 01/15] drm/i915/dsc: Track the detaild DSC slice configuration Imre Deak
2026-01-14 16:22 ` [PATCH 02/15] drm/i915/dsc: Track the DSC stream count in the DSC slice config state Imre Deak
2026-01-14 16:22 ` [PATCH 03/15] drm/i915/dsi: Move initialization of DSI DSC streams-per-pipe to fill_dsc() Imre Deak
2026-01-14 16:22 ` [PATCH 04/15] drm/i915/dsi: Track the detailed DSC slice configuration Imre Deak
2026-01-14 16:22 ` [PATCH 05/15] drm/i915/dp: " Imre Deak
2026-01-14 16:22 ` [PATCH 06/15] drm/i915/dsc: Switch to using intel_dsc_line_slice_count() Imre Deak
2026-01-14 16:22 ` [PATCH 07/15] drm/i915/dp: Factor out intel_dp_dsc_min_slice_count() Imre Deak
2026-01-14 16:22 ` [PATCH 08/15] drm/i915/dp: Use int for DSC slice count variables Imre Deak
2026-01-14 16:22 ` [PATCH 09/15] drm/i915/dp: Rename test_slice_count to slices_per_line Imre Deak
2026-01-14 16:22 ` [PATCH 10/15] drm/i915/dp: Simplify the DSC slice config loop's slices-per-pipe iteration Imre Deak
2026-01-14 16:22 ` [PATCH 11/15] drm/i915/dsc: Add intel_dsc_get_slice_config() Imre Deak
2026-01-14 16:22 ` [PATCH 12/15] drm/i915/dsi: Use intel_dsc_get_slice_config() Imre Deak
2026-01-14 16:22 ` [PATCH 13/15] drm/i915/dp: Unify DP and eDP slice count computation Imre Deak
2026-01-14 16:22 ` [PATCH 14/15] drm/i915/dp: Add intel_dp_dsc_get_slice_config() Imre Deak
2026-01-14 16:22 ` [PATCH 15/15] drm/i915/dp: Use intel_dp_dsc_get_slice_config() Imre Deak
2026-01-14 19:08 ` ✓ i915.CI.BAT: success for drm/i915/dp: Clean up link BW/DSC slice config computation (DSC slice) Patchwork
2026-01-14 23:56 ` ✗ i915.CI.Full: failure " Patchwork
2026-01-15 18:36 ` Imre Deak
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260114162232.92731-1-imre.deak@intel.com \
--to=imre.deak@intel.com \
--cc=ankit.k.nautiyal@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=intel-xe@lists.freedesktop.org \
--cc=jouni.hogander@intel.com \
--cc=luciano.coelho@intel.com \
--cc=vinod.govindapillai@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox