From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: Matt Atwood <matthew.s.atwood@intel.com>,
intel-gfx@lists.freedesktop.org
Cc: ashutosh.dixit@linux.intel.com, matthew.d.roper@intel.com,
andy.shyti@linux.intel.com
Subject: Re: [Intel-gfx] [PATCH 2/2] drm/i915: rename I915_PMU_MAX_GTS to I915_PMU_MAX_GT
Date: Mon, 5 Jun 2023 10:24:15 +0100 [thread overview]
Message-ID: <48132996-4fad-c802-6147-e95db60d9d0c@linux.intel.com> (raw)
In-Reply-To: <20230602231754.1596433-3-matthew.s.atwood@intel.com>
On 03/06/2023 00:17, Matt Atwood wrote:
> _GTS as an abbreviation here leads to some confusion, match other
> definitions and drop the s.
>
> Cc: Matt Roper <matthew.d.roper@intel.com>
> Cc: Ashutosh Dixit <ashutosh.dixit@linux.intel.com>
> Cc: Andi Shyti <andy.shyti@linux.intel.com>
> Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
> Cc: Umesh Nerlige Ramappa <umesh.nerlige.ramappa@intel.com>
>
> Signed-off-by: Matt Atwood <matthew.s.atwood@intel.com>
> ---
> drivers/gpu/drm/i915/i915_pmu.c | 2 +-
> drivers/gpu/drm/i915/i915_pmu.h | 8 ++++----
> 2 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_pmu.c b/drivers/gpu/drm/i915/i915_pmu.c
> index f96fe92dca4e..d35973b41186 100644
> --- a/drivers/gpu/drm/i915/i915_pmu.c
> +++ b/drivers/gpu/drm/i915/i915_pmu.c
> @@ -132,7 +132,7 @@ static u32 frequency_enabled_mask(void)
> unsigned int i;
> u32 mask = 0;
>
> - for (i = 0; i < I915_PMU_MAX_GTS; i++)
> + for (i = 0; i < I915_PMU_MAX_GT; i++)
> mask |= config_mask(__I915_PMU_ACTUAL_FREQUENCY(i)) |
> config_mask(__I915_PMU_REQUESTED_FREQUENCY(i));
>
> diff --git a/drivers/gpu/drm/i915/i915_pmu.h b/drivers/gpu/drm/i915/i915_pmu.h
> index d20592e7db99..41af038c3738 100644
> --- a/drivers/gpu/drm/i915/i915_pmu.h
> +++ b/drivers/gpu/drm/i915/i915_pmu.h
> @@ -38,7 +38,7 @@ enum {
> __I915_NUM_PMU_SAMPLERS
> };
>
> -#define I915_PMU_MAX_GTS 2
> +#define I915_PMU_MAX_GT 2
Shrug from me since I wasn't a fan* of the original s/gts/gt/ effort.
But AFAIR that has been done already, I guess consistency wins so I am
not blocking it either.
Regards,
Tvrtko
*) What is a max gt? Can I index it into the array? Or expect the gt id
to contain that value? Neither is true hence my dislike.
>
> /*
> * How many different events we track in the global PMU mask.
> @@ -47,7 +47,7 @@ enum {
> */
> #define I915_PMU_MASK_BITS \
> (I915_ENGINE_SAMPLE_COUNT + \
> - I915_PMU_MAX_GTS * __I915_PMU_TRACKED_EVENT_COUNT)
> + I915_PMU_MAX_GT * __I915_PMU_TRACKED_EVENT_COUNT)
>
> #define I915_ENGINE_SAMPLE_COUNT (I915_SAMPLE_SEMA + 1)
>
> @@ -127,11 +127,11 @@ struct i915_pmu {
> * Only global counters are held here, while the per-engine ones are in
> * struct intel_engine_cs.
> */
> - struct i915_pmu_sample sample[I915_PMU_MAX_GTS][__I915_NUM_PMU_SAMPLERS];
> + struct i915_pmu_sample sample[I915_PMU_MAX_GT][__I915_NUM_PMU_SAMPLERS];
> /**
> * @sleep_last: Last time GT parked for RC6 estimation.
> */
> - ktime_t sleep_last[I915_PMU_MAX_GTS];
> + ktime_t sleep_last[I915_PMU_MAX_GT];
> /**
> * @irq_count: Number of interrupts
> *
next prev parent reply other threads:[~2023-06-05 9:24 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-06-02 23:17 [Intel-gfx] [PATCH 0/2] Update various *MAX_GT* definitions Matt Atwood
2023-06-02 23:17 ` [Intel-gfx] [PATCH 1/2] drm/i915: Reduce I915_MAX_GT to 2 Matt Atwood
2023-06-03 0:13 ` Matt Roper
2023-06-03 0:38 ` Dixit, Ashutosh
2023-06-02 23:17 ` [Intel-gfx] [PATCH 2/2] drm/i915: rename I915_PMU_MAX_GTS to I915_PMU_MAX_GT Matt Atwood
2023-06-03 0:15 ` Matt Roper
2023-06-05 9:24 ` Tvrtko Ursulin [this message]
2023-06-03 1:34 ` [Intel-gfx] ✗ Fi.CI.SPARSE: warning for Update various *MAX_GT* definitions Patchwork
2023-06-03 1:42 ` [Intel-gfx] ✓ Fi.CI.BAT: success " Patchwork
2023-06-05 17:00 ` [Intel-gfx] ✓ Fi.CI.IGT: " Patchwork
2023-06-06 18:05 ` Matt Roper
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=48132996-4fad-c802-6147-e95db60d9d0c@linux.intel.com \
--to=tvrtko.ursulin@linux.intel.com \
--cc=andy.shyti@linux.intel.com \
--cc=ashutosh.dixit@linux.intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=matthew.d.roper@intel.com \
--cc=matthew.s.atwood@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox