Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Chad Versace <chad.versace@linux.intel.com>
To: Daniel Vetter <daniel@ffwll.ch>
Cc: Ben Widawsky <ben@bwidawsk.net>,
	Intel GFX <intel-gfx@lists.freedesktop.org>
Subject: Re: [PATCH] drm/i915: Make i915 events part of uapi
Date: Wed, 17 Jul 2013 14:12:21 -0700	[thread overview]
Message-ID: <51E708B5.1000307@linux.intel.com> (raw)
In-Reply-To: <20130717050706.GZ5784@phenom.ffwll.local>

On 07/16/2013 10:07 PM, Daniel Vetter wrote:
> On Tue, Jul 16, 2013 at 04:41:13PM -0700, Ben Widawsky wrote:
>> Make the uevent strings part of the user API for people who wish to
>> write their own listeners.
>>
>> CC: Chad Versace <chad.versace@linux.intel.com>
>> Signed-off-by: Ben Widawsky <ben@bwidawsk.net>
>
> One thing I've toyed around with a bit is that we should add kerneldoc to
> our uapi headers and create a DocBook out of it (maybe as a subsection in
> the drm userspace api chapter). I guess the DocBook integration needs an
> overall approach, but we should start to add comments to each piece of
> userspace api to clearly spec them. See below for what I have in mind ...

Yes, docs please. I don't have the kernel-fu of a kernel-dev, so without
docs I don't know what these events mean and what to expect from them.

>> -	parity_event[0] = "L3_PARITY_ERROR=1";
>> +	parity_event[0] = I915_L3_PARITY_EVENT"=1";

Small nitpick. I usually find string concatenation more readable like this,
with a space:
     parity_event[0] = I915_L3_PARITY_EVENT "=1";
But, that's just my preference, so feel free to ignore me.

>> +#define I915_L3_PARITY_EVENT "L3_PARITY_ERROR"
>> +#define I915_ERROR_EVENT "ERROR"
>> +#define I915_RESET_EVENT "RESET"

Maybe this is a dumb question... since these are uevents, do you think the names
would be improved by given them a "UEVENT" suffix? Like I915_ERROR_UEVENT? Or is
that dumb, because these tokens are intended to serve more purposes than uevents?

  reply	other threads:[~2013-07-17 21:12 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-07-16 23:41 [PATCH] drm/i915: Make i915 events part of uapi Ben Widawsky
2013-07-17  5:07 ` Daniel Vetter
2013-07-17 21:12   ` Chad Versace [this message]
2013-07-19  5:42 ` [PATCH 1/3] drm/i915: Move error uevent to detection time Ben Widawsky
2013-07-19  5:42   ` [PATCH 2/3] drm/i915: Change uevent for reset completion Ben Widawsky
2013-07-19  6:57     ` Daniel Vetter
2013-07-19  5:42   ` [PATCH 3/3] [v2] drm/i915: Make i915 events part of uapi Ben Widawsky
2013-07-19  8:45   ` [PATCH 1/3] drm/i915: Move error uevent to detection time Chris Wilson
2013-07-19 16:16 ` [PATCH] [v3] drm/i915: Make i915 events part of uapi Ben Widawsky
2013-07-19 16:27   ` Daniel Vetter
2013-07-19 22:35   ` Chad Versace

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=51E708B5.1000307@linux.intel.com \
    --to=chad.versace@linux.intel.com \
    --cc=ben@bwidawsk.net \
    --cc=daniel@ffwll.ch \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox