Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: Matthew Auld <matthew.auld@intel.com>, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH] drm/i915: simplify bind_to_vm init code
Date: Thu, 17 Mar 2016 10:00:46 +0000	[thread overview]
Message-ID: <56EA804E.6030807@linux.intel.com> (raw)
In-Reply-To: <1458148026-3057-1-git-send-email-matthew.auld@intel.com>


Hi,

On 16/03/16 17:07, Matthew Auld wrote:
> No functional change, just makes the code easier to follow.
>
> Signed-off-by: Matthew Auld <matthew.auld@intel.com>
> ---
>   drivers/gpu/drm/i915/i915_gem.c | 41 +++++++++++------------------------------
>   1 file changed, 11 insertions(+), 30 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_gem.c b/drivers/gpu/drm/i915/i915_gem.c
> index b854af2..5a8d69d 100644
> --- a/drivers/gpu/drm/i915/i915_gem.c
> +++ b/drivers/gpu/drm/i915/i915_gem.c
> @@ -3470,46 +3470,27 @@ i915_gem_object_bind_to_vm(struct drm_i915_gem_object *obj,
>   	u32 fence_alignment, unfenced_alignment;
>   	u32 search_flag, alloc_flag;
>   	u64 start, end;
> -	u64 size, fence_size;
> +	u64 size, obj_size, fence_size;
>   	struct i915_vma *vma;
>   	int ret;
>
>   	if (i915_is_ggtt(vm)) {
> -		u32 view_size;
> -
>   		if (WARN_ON(!ggtt_view))
>   			return ERR_PTR(-EINVAL);
>
> -		view_size = i915_ggtt_view_size(obj, ggtt_view);
> -
> -		fence_size = i915_gem_get_gtt_size(dev,
> -						   view_size,
> -						   obj->tiling_mode);
> -		fence_alignment = i915_gem_get_gtt_alignment(dev,
> -							     view_size,
> -							     obj->tiling_mode,
> -							     true);
> -		unfenced_alignment = i915_gem_get_gtt_alignment(dev,
> -								view_size,
> -								obj->tiling_mode,
> -								false);
> -		size = flags & PIN_MAPPABLE ? fence_size : view_size;
> +		obj_size = i915_ggtt_view_size(obj, ggtt_view);
>   	} else {
> -		fence_size = i915_gem_get_gtt_size(dev,
> -						   obj->base.size,
> -						   obj->tiling_mode);
> -		fence_alignment = i915_gem_get_gtt_alignment(dev,
> -							     obj->base.size,
> -							     obj->tiling_mode,
> -							     true);
> -		unfenced_alignment =
> -			i915_gem_get_gtt_alignment(dev,
> -						   obj->base.size,
> -						   obj->tiling_mode,
> -						   false);
> -		size = flags & PIN_MAPPABLE ? fence_size : obj->base.size;
> +		obj_size = obj->base.size;
>   	}

PIN_MAPPABLE mandates PIN_GLOBAL, and PIN_GLOBAL mandates GGTT (see 
i915_gem_object_do_pin), so I think the cleanup should be just not to do 
any of the fence business on if !ggtt branch.

if (i915_is_ggtt(vm)) {
	... existing code ...
} else {
	size = obj->base.size;
}

Check for NULL ggtt_view is also done on the higher level so perhaps 
that can go as well to consolidate the checks at one place.

> +	fence_size = i915_gem_get_gtt_size(dev, obj_size, obj->tiling_mode);
> +	fence_alignment = i915_gem_get_gtt_alignment(dev, obj_size,
> +						     obj->tiling_mode, true);
> +	unfenced_alignment = i915_gem_get_gtt_alignment(dev, obj_size,
> +							obj->tiling_mode,
> +							false);
> +	size = flags & PIN_MAPPABLE ? fence_size : obj_size;
> +
>   	start = flags & PIN_OFFSET_BIAS ? flags & PIN_OFFSET_MASK : 0;
>   	end = vm->total;
>   	if (flags & PIN_MAPPABLE)
>

Regards,

Tvrtko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2016-03-17 10:00 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-16 17:07 [PATCH] drm/i915: simplify bind_to_vm init code Matthew Auld
2016-03-17 10:00 ` Tvrtko Ursulin [this message]
2016-03-17 13:41   ` Matthew Auld
2016-03-17 13:53     ` Chris Wilson
2016-03-17 17:36     ` Tvrtko Ursulin
2016-03-17 10:36 ` ✗ Fi.CI.BAT: failure for " Patchwork
  -- strict thread matches above, loose matches on Subject: below --
2016-03-18 10:46 [PATCH] " Matthew Auld
2016-03-18 11:10 ` Tvrtko Ursulin
2016-03-18 11:26   ` Chris Wilson
2016-03-18 13:54 Matthew Auld
2016-03-22 10:36 ` Matthew Auld

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=56EA804E.6030807@linux.intel.com \
    --to=tvrtko.ursulin@linux.intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=matthew.auld@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox