From: Chris Wilson <chris@chris-wilson.co.uk>
To: Keith Packard <keithp@keithp.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 08/16] drm/i915/i2c: Convert from using GMBUS1 + reg_offset idiom to reg + 0
Date: Fri, 13 May 2011 10:28:34 +0100 [thread overview]
Message-ID: <72a37e$j4eltu@orsmga002.jf.intel.com> (raw)
In-Reply-To: <yunfwoj8mb9.fsf@aiko.keithp.com>
On Thu, 12 May 2011 17:40:42 -0700, Keith Packard <keithp@keithp.com> wrote:
> On Thu, 12 May 2011 22:17:16 +0100, Chris Wilson <chris@chris-wilson.co.uk> wrote:
>
> > Keith complained that GMBUSx + reg_offset was ugly. An alternative
> > naming scheme which is more consistent with the reset of the code base
> > is to store the address of the GMBUS0 and then reference each of the
> > GMBUSx registers as an offset from GMBUS0.
>
> This looks completely wrong -- GMBUS1 is GMBUS0 + 4, not GMBUS0 + 1.
That was shameful.
> How about a simple function that computes the GMBUS register address
> based on the device and a number? like:
>
> static int intel_gmbus_reg(struct drm_device *dev, int reg) {
> int base = HAS_PCH_SPLIT(dev) ? PCH_GMBUS0 : GMBUS0;
>
> return base + reg * 4;
And how about something like:
#define I915_GMBUS_WRITE(reg, val) \
I915_WRITE(intel_gmbus_reg(dev_priv->dev, reg), val)
I915_GMBUS_WRITE(0, val);
For the body?
-Chris
--
Chris Wilson, Intel Open Source Technology Centre
next prev parent reply other threads:[~2011-05-13 9:28 UTC|newest]
Thread overview: 56+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-05-12 21:17 Select patches for 2.6.40 Chris Wilson
2011-05-12 21:17 ` [PATCH 01/16] drm/i915: Cache GT fifo count for SandyBridge Chris Wilson
2011-05-12 21:17 ` [PATCH 02/16] drm/i915: Refactor pwrite/pread to use single copy of get_user_pages Chris Wilson
2011-05-13 0:21 ` Keith Packard
2011-05-15 8:00 ` Chris Wilson
2011-05-15 15:36 ` Keith Packard
2011-05-12 21:17 ` [PATCH 03/16] drm/i915: s/addr & ~PAGE_MASK/offset_in_page(addr)/ Chris Wilson
2011-05-13 0:26 ` Keith Packard
2011-05-12 21:17 ` [PATCH 04/16] drm/i915: Only print out the actual number of fences for i915_error_state Chris Wilson
2011-05-13 0:28 ` Keith Packard
2011-05-12 21:17 ` [PATCH 05/16] drm/i915/tv: Use a direct pointer for tv_mode Chris Wilson
2011-05-13 0:30 ` Keith Packard
2011-05-12 21:17 ` [PATCH 06/16] drm/i915: Replace ironlake_compute_wm0 with g4x_compute_wm0 Chris Wilson
2011-05-13 0:34 ` Keith Packard
2011-05-13 9:19 ` Chris Wilson
2011-05-13 15:00 ` Keith Packard
2011-05-12 21:17 ` [PATCH 07/16] drm/i915/crt: Explicitly return false if connected to a digital monitor Chris Wilson
2011-05-12 21:17 ` [PATCH 08/16] drm/i915/i2c: Convert from using GMBUS1 + reg_offset idiom to reg + 0 Chris Wilson
2011-05-13 0:36 ` Keith Packard
2011-05-13 0:40 ` Keith Packard
2011-05-13 9:28 ` Chris Wilson [this message]
2011-05-13 15:00 ` Keith Packard
2011-06-03 20:55 ` Keith Packard
2011-06-03 23:09 ` Chris Wilson
2011-06-03 23:48 ` Keith Packard
2011-07-13 18:33 ` Keith Packard
2011-07-13 19:22 ` Chris Wilson
2011-05-12 21:17 ` [PATCH 09/16] drm/i915/gmbus: Reset the controller on initialisation Chris Wilson
2011-05-13 0:41 ` Keith Packard
2011-05-13 9:32 ` Chris Wilson
2011-05-13 15:01 ` Keith Packard
2011-05-13 15:53 ` Chris Wilson
2011-06-03 20:56 ` Keith Packard
2011-05-12 21:17 ` [PATCH 10/16] drm/i915: Retire requests before disabling pagefaults Chris Wilson
2011-05-13 1:08 ` Keith Packard
2011-05-12 21:17 ` [PATCH 11/16] drm/i915: not finding a fence is a non-recoverable condition Chris Wilson
2011-05-13 1:10 ` Keith Packard
2011-05-15 20:38 ` Daniel Vetter
2011-05-12 21:17 ` [PATCH 12/16] drm/915: fix relaxed tiling on gen2: tile height Chris Wilson
2011-05-13 1:13 ` Keith Packard
2011-05-15 20:43 ` Daniel Vetter
2011-05-15 21:58 ` Keith Packard
2011-05-16 17:48 ` Daniel Vetter
2011-05-12 21:17 ` [PATCH 13/16] drm/i915: Remove unused enum "chip_family" Chris Wilson
2011-05-13 1:13 ` Keith Packard
2011-05-12 21:17 ` [PATCH 14/16] drm/i915: Use PCI-ID to identify Broadwater and Crestline Chris Wilson
2011-05-13 1:16 ` Keith Packard
2011-05-13 9:39 ` Chris Wilson
2011-05-15 20:49 ` Daniel Vetter
2011-05-15 22:01 ` Keith Packard
2011-06-03 20:59 ` Keith Packard
2011-05-12 21:17 ` [PATCH 15/16] drm/i915: Convert partial to full CPU read domain if we touch every page Chris Wilson
2011-05-13 1:17 ` Keith Packard
2011-05-12 21:17 ` [PATCH 16/16] drm/i915: Share the common force-audio property between connectors Chris Wilson
2011-05-13 1:21 ` Keith Packard
2011-05-13 3:39 ` Select patches for 2.6.40 Zou, Nanhai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='72a37e$j4eltu@orsmga002.jf.intel.com' \
--to=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
--cc=keithp@keithp.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox