From: Jani Nikula <jani.nikula@linux.intel.com>
To: Lucas De Marchi <lucas.demarchi@intel.com>,
intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 2/4] drm/i915/bios: rename bios to oprom when mapping pci rom
Date: Fri, 08 Nov 2019 12:01:46 +0200 [thread overview]
Message-ID: <87k18a660l.fsf@intel.com> (raw)
In-Reply-To: <20191108003602.33526-2-lucas.demarchi@intel.com>
On Thu, 07 Nov 2019, Lucas De Marchi <lucas.demarchi@intel.com> wrote:
> oprom is actually a better name to use when using
> pci_map_rom(). "bios" is way too generic and confusing.
>
> Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
Reviewed-by: Jani Nikula <jani.nikula@intel.com>
> ---
> drivers/gpu/drm/i915/display/intel_bios.c | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_bios.c b/drivers/gpu/drm/i915/display/intel_bios.c
> index a03f56b7b4ef..1f83616cfc32 100644
> --- a/drivers/gpu/drm/i915/display/intel_bios.c
> +++ b/drivers/gpu/drm/i915/display/intel_bios.c
> @@ -1804,7 +1804,7 @@ bool intel_bios_is_valid_vbt(const void *buf, size_t size)
> return vbt;
> }
>
> -static const struct vbt_header *find_vbt(void __iomem *bios, size_t size)
> +static const struct vbt_header *find_vbt(void __iomem *oprom, size_t size)
> {
> size_t i;
>
> @@ -1812,14 +1812,14 @@ static const struct vbt_header *find_vbt(void __iomem *bios, size_t size)
> for (i = 0; i + 4 < size; i++) {
> void *vbt;
>
> - if (ioread32(bios + i) != *((const u32 *) "$VBT"))
> + if (ioread32(oprom + i) != *((const u32 *)"$VBT"))
> continue;
>
> /*
> * This is the one place where we explicitly discard the address
> * space (__iomem) of the BIOS/VBT.
> */
> - vbt = (void __force *) bios + i;
> + vbt = (void __force *)oprom + i;
> if (intel_bios_is_valid_vbt(vbt, size - i))
> return vbt;
>
> @@ -1842,7 +1842,7 @@ void intel_bios_init(struct drm_i915_private *dev_priv)
> struct pci_dev *pdev = dev_priv->drm.pdev;
> const struct vbt_header *vbt = dev_priv->opregion.vbt;
> const struct bdb_header *bdb;
> - u8 __iomem *bios = NULL;
> + u8 __iomem *oprom = NULL;
>
> if (!HAS_DISPLAY(dev_priv) || !INTEL_DISPLAY_ENABLED(dev_priv)) {
> DRM_DEBUG_KMS("Skipping VBT init due to disabled display.\n");
> @@ -1855,11 +1855,11 @@ void intel_bios_init(struct drm_i915_private *dev_priv)
> if (!vbt) {
> size_t size;
>
> - bios = pci_map_rom(pdev, &size);
> - if (!bios)
> + oprom = pci_map_rom(pdev, &size);
> + if (!oprom)
> goto out;
>
> - vbt = find_vbt(bios, size);
> + vbt = find_vbt(oprom, size);
> if (!vbt)
> goto out;
>
> @@ -1893,8 +1893,8 @@ void intel_bios_init(struct drm_i915_private *dev_priv)
> init_vbt_missing_defaults(dev_priv);
> }
>
> - if (bios)
> - pci_unmap_rom(pdev, bios);
> + if (oprom)
> + pci_unmap_rom(pdev, oprom);
> }
>
> /**
--
Jani Nikula, Intel Open Source Graphics Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
WARNING: multiple messages have this Message-ID (diff)
From: Jani Nikula <jani.nikula@linux.intel.com>
To: Lucas De Marchi <lucas.demarchi@intel.com>,
intel-gfx@lists.freedesktop.org
Subject: Re: [Intel-gfx] [PATCH 2/4] drm/i915/bios: rename bios to oprom when mapping pci rom
Date: Fri, 08 Nov 2019 12:01:46 +0200 [thread overview]
Message-ID: <87k18a660l.fsf@intel.com> (raw)
Message-ID: <20191108100146.NVvpYoSjp7sFi8Nh96UVSizdgHAq_B9zx4m9LkLmQMc@z> (raw)
In-Reply-To: <20191108003602.33526-2-lucas.demarchi@intel.com>
On Thu, 07 Nov 2019, Lucas De Marchi <lucas.demarchi@intel.com> wrote:
> oprom is actually a better name to use when using
> pci_map_rom(). "bios" is way too generic and confusing.
>
> Signed-off-by: Lucas De Marchi <lucas.demarchi@intel.com>
Reviewed-by: Jani Nikula <jani.nikula@intel.com>
> ---
> drivers/gpu/drm/i915/display/intel_bios.c | 18 +++++++++---------
> 1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/display/intel_bios.c b/drivers/gpu/drm/i915/display/intel_bios.c
> index a03f56b7b4ef..1f83616cfc32 100644
> --- a/drivers/gpu/drm/i915/display/intel_bios.c
> +++ b/drivers/gpu/drm/i915/display/intel_bios.c
> @@ -1804,7 +1804,7 @@ bool intel_bios_is_valid_vbt(const void *buf, size_t size)
> return vbt;
> }
>
> -static const struct vbt_header *find_vbt(void __iomem *bios, size_t size)
> +static const struct vbt_header *find_vbt(void __iomem *oprom, size_t size)
> {
> size_t i;
>
> @@ -1812,14 +1812,14 @@ static const struct vbt_header *find_vbt(void __iomem *bios, size_t size)
> for (i = 0; i + 4 < size; i++) {
> void *vbt;
>
> - if (ioread32(bios + i) != *((const u32 *) "$VBT"))
> + if (ioread32(oprom + i) != *((const u32 *)"$VBT"))
> continue;
>
> /*
> * This is the one place where we explicitly discard the address
> * space (__iomem) of the BIOS/VBT.
> */
> - vbt = (void __force *) bios + i;
> + vbt = (void __force *)oprom + i;
> if (intel_bios_is_valid_vbt(vbt, size - i))
> return vbt;
>
> @@ -1842,7 +1842,7 @@ void intel_bios_init(struct drm_i915_private *dev_priv)
> struct pci_dev *pdev = dev_priv->drm.pdev;
> const struct vbt_header *vbt = dev_priv->opregion.vbt;
> const struct bdb_header *bdb;
> - u8 __iomem *bios = NULL;
> + u8 __iomem *oprom = NULL;
>
> if (!HAS_DISPLAY(dev_priv) || !INTEL_DISPLAY_ENABLED(dev_priv)) {
> DRM_DEBUG_KMS("Skipping VBT init due to disabled display.\n");
> @@ -1855,11 +1855,11 @@ void intel_bios_init(struct drm_i915_private *dev_priv)
> if (!vbt) {
> size_t size;
>
> - bios = pci_map_rom(pdev, &size);
> - if (!bios)
> + oprom = pci_map_rom(pdev, &size);
> + if (!oprom)
> goto out;
>
> - vbt = find_vbt(bios, size);
> + vbt = find_vbt(oprom, size);
> if (!vbt)
> goto out;
>
> @@ -1893,8 +1893,8 @@ void intel_bios_init(struct drm_i915_private *dev_priv)
> init_vbt_missing_defaults(dev_priv);
> }
>
> - if (bios)
> - pci_unmap_rom(pdev, bios);
> + if (oprom)
> + pci_unmap_rom(pdev, oprom);
> }
>
> /**
--
Jani Nikula, Intel Open Source Graphics Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2019-11-08 10:01 UTC|newest]
Thread overview: 42+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-11-08 0:35 [PATCH 1/4] drm/i915/opregion: fix leaking fw on error path Lucas De Marchi
2019-11-08 0:35 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 0:36 ` [PATCH 2/4] drm/i915/bios: rename bios to oprom when mapping pci rom Lucas De Marchi
2019-11-08 0:36 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 10:01 ` Jani Nikula [this message]
2019-11-08 10:01 ` Jani Nikula
2019-11-08 0:36 ` [PATCH 3/4] drm/i915/bios: make sure to check vbt size Lucas De Marchi
2019-11-08 0:36 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 10:08 ` Jani Nikula
2019-11-08 10:08 ` [Intel-gfx] " Jani Nikula
2019-11-08 17:41 ` Lucas De Marchi
2019-11-08 17:41 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 0:36 ` [PATCH 4/4] drm/i915/bios: do not discard address space Lucas De Marchi
2019-11-08 0:36 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 11:14 ` Jani Nikula
2019-11-08 11:14 ` [Intel-gfx] " Jani Nikula
2019-11-08 18:18 ` Lucas De Marchi
2019-11-08 18:18 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 19:19 ` Ville Syrjälä
2019-11-08 19:19 ` [Intel-gfx] " Ville Syrjälä
2019-11-08 20:14 ` Lucas De Marchi
2019-11-08 20:14 ` [Intel-gfx] " Lucas De Marchi
2019-11-08 21:02 ` Ville Syrjälä
2019-11-08 21:02 ` [Intel-gfx] " Ville Syrjälä
2019-11-08 21:09 ` Lucas De Marchi
2019-11-08 21:09 ` [Intel-gfx] " Lucas De Marchi
2019-11-11 11:10 ` Jani Nikula
2019-11-11 11:10 ` [Intel-gfx] " Jani Nikula
2019-11-10 16:57 ` kbuild test robot
2019-11-10 16:57 ` [Intel-gfx] " kbuild test robot
2019-11-10 16:57 ` [RFC PATCH] drm/i915/bios: find_vbt() can be static kbuild test robot
2019-11-10 16:57 ` [Intel-gfx] " kbuild test robot
2019-11-08 1:53 ` ✗ Fi.CI.SPARSE: warning for series starting with [1/4] drm/i915/opregion: fix leaking fw on error path Patchwork
2019-11-08 1:53 ` [Intel-gfx] " Patchwork
2019-11-08 2:18 ` ✓ Fi.CI.BAT: success " Patchwork
2019-11-08 2:18 ` [Intel-gfx] " Patchwork
2019-11-08 9:16 ` [PATCH 1/4] " Jani Nikula
2019-11-08 9:16 ` [Intel-gfx] " Jani Nikula
2019-11-08 17:34 ` Lucas De Marchi
2019-11-08 17:34 ` [Intel-gfx] " Lucas De Marchi
2019-11-09 13:23 ` ✓ Fi.CI.IGT: success for series starting with [1/4] " Patchwork
2019-11-09 13:23 ` [Intel-gfx] " Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87k18a660l.fsf@intel.com \
--to=jani.nikula@linux.intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=lucas.demarchi@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox