Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Jani Nikula <jani.nikula@intel.com>
To: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 1/2] drm/i915/dsi: lose the loose 666 format name in favor of packed
Date: Wed, 16 Mar 2016 17:58:03 +0200	[thread overview]
Message-ID: <87shzq76us.fsf@intel.com> (raw)
In-Reply-To: <20160316141820.GC4329@intel.com>

On Wed, 16 Mar 2016, Ville Syrjälä <ville.syrjala@linux.intel.com> wrote:
> [ text/plain ]
> On Wed, Mar 16, 2016 at 12:21:39PM +0200, Jani Nikula wrote:
>> The enum mipi_dsi_pixel_format defines MIPI_DSI_FMT_RGB666 for the
>> "loose" 24 bpp format and MIPI_DSI_FMT_RGB666_PACKED for the 18 bpp
>> format. We have this the other way round, defining a loose version for
>> 24 bpp.
>> 
>> Follow suit with what's in enum mipi_dsi_pixel_format to avoid future
>> confusion. Rename
>> 
>> VID_MODE_FORMAT_RGB666 -> VID_MODE_FORMAT_RGB666_PACKED
>> VID_MODE_FORMAT_RGB666_LOOSE -> VID_MODE_FORMAT_RGB666
>
> This goes against our spec a bit, and the DSI spec calls these
> "packed" and "loosly packed". So I'm not entirely thrilled about the
> names used in the mipi_dsi_pixel_format either. I think the best
> option would be to call them something like 666_18 and 666_24 to
> avoid all the confusion.

Agreed, but for now I think conforming to mipi_dsi_pixel_format is the
least bad option.

> But patch looks sane anyway so
> Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

Thanks, both pushed to drm-intel-next-queued.

BR,
Jani.

>
>> 
>> Signed-off-by: Jani Nikula <jani.nikula@intel.com>
>> ---
>>  drivers/gpu/drm/i915/i915_reg.h      | 4 ++--
>>  drivers/gpu/drm/i915/intel_dsi_pll.c | 4 ++--
>>  2 files changed, 4 insertions(+), 4 deletions(-)
>> 
>> diff --git a/drivers/gpu/drm/i915/i915_reg.h b/drivers/gpu/drm/i915/i915_reg.h
>> index 7dfc4007f3fa..85ceec611412 100644
>> --- a/drivers/gpu/drm/i915/i915_reg.h
>> +++ b/drivers/gpu/drm/i915/i915_reg.h
>> @@ -7887,8 +7887,8 @@ enum skl_disp_power_wells {
>>  #define  VID_MODE_FORMAT_MASK				(0xf << 7)
>>  #define  VID_MODE_NOT_SUPPORTED				(0 << 7)
>>  #define  VID_MODE_FORMAT_RGB565				(1 << 7)
>> -#define  VID_MODE_FORMAT_RGB666				(2 << 7)
>> -#define  VID_MODE_FORMAT_RGB666_LOOSE			(3 << 7)
>> +#define  VID_MODE_FORMAT_RGB666_PACKED			(2 << 7)
>> +#define  VID_MODE_FORMAT_RGB666				(3 << 7)
>>  #define  VID_MODE_FORMAT_RGB888				(4 << 7)
>>  #define  CMD_MODE_CHANNEL_NUMBER_SHIFT			5
>>  #define  CMD_MODE_CHANNEL_NUMBER_MASK			(3 << 5)
>> diff --git a/drivers/gpu/drm/i915/intel_dsi_pll.c b/drivers/gpu/drm/i915/intel_dsi_pll.c
>> index 2451c84949bd..9ef0f7806e4a 100644
>> --- a/drivers/gpu/drm/i915/intel_dsi_pll.c
>> +++ b/drivers/gpu/drm/i915/intel_dsi_pll.c
>> @@ -37,10 +37,10 @@ int dsi_pixel_format_bpp(int pixel_format)
>>  	switch (pixel_format) {
>>  	default:
>>  	case VID_MODE_FORMAT_RGB888:
>> -	case VID_MODE_FORMAT_RGB666_LOOSE:
>> +	case VID_MODE_FORMAT_RGB666:
>>  		bpp = 24;
>>  		break;
>> -	case VID_MODE_FORMAT_RGB666:
>> +	case VID_MODE_FORMAT_RGB666_PACKED:
>>  		bpp = 18;
>>  		break;
>>  	case VID_MODE_FORMAT_RGB565:
>> -- 
>> 2.1.4

-- 
Jani Nikula, Intel Open Source Technology Center
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2016-03-16 15:58 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-16 10:21 [PATCH 1/2] drm/i915/dsi: lose the loose 666 format name in favor of packed Jani Nikula
2016-03-16 10:21 ` [PATCH 2/2] drm/i915/dsi: start using enum mipi_dsi_pixel_format Jani Nikula
2016-03-16 14:20   ` Ville Syrjälä
2016-03-16 12:48 ` ✗ Fi.CI.BAT: failure for series starting with [1/2] drm/i915/dsi: lose the loose 666 format name in favor of packed Patchwork
2016-03-16 13:37   ` Jani Nikula
2016-03-16 14:18 ` [PATCH 1/2] " Ville Syrjälä
2016-03-16 15:58   ` Jani Nikula [this message]
  -- strict thread matches above, loose matches on Subject: below --
2016-01-14 10:28 Jani Nikula
2016-01-14 13:51 ` Mika Kahola

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87shzq76us.fsf@intel.com \
    --to=jani.nikula@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=ville.syrjala@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox