From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 08/11] drm/i915/uc: Simplify firmware path handling
Date: Mon, 13 Mar 2017 13:55:03 +0000 [thread overview]
Message-ID: <faa74839-6695-4703-76fd-b891834d2370@linux.intel.com> (raw)
In-Reply-To: <20170313134817.GC5550@ahiler-desk.igk.intel.com>
On 13/03/2017 13:48, Arkadiusz Hiler wrote:
> On Mon, Mar 13, 2017 at 01:39:45PM +0000, Tvrtko Ursulin wrote:
>>
>> On 13/03/2017 13:15, Arkadiusz Hiler wrote:
>>> Currently fw->path values can represent one of three possible states:
>>>
>>> 1) NULL - device without the uC
>>> 2) '\0' - device with the uC but have no firmware
>>> 3) else - device with the uC and we have firmware
>>>
>>> Second case is used only to WARN at a later stage.
>>>
>>> We can WARN right away and merge cases 1 and 2.
>>>
>>> Code can be even further simplified and common (HuC/GuC logic) happening
>>> right before the fetch can be offloaded to the common function.
>>>
>>> v2: fewer temporary variables, more straightforward flow (M. Wajdeczko)
>>> v3: DRM_ERROR instead of WARN (M. Wajdeczko)
>>> v4: coding standard (J. Lahtinen)
>>> v5: non-trivial rebase
>>> v6: remove path check, we are checking fetch status (M. Wajdeczko)
>>>
>>> Cc: Anusha Srivatsa <anusha.srivatsa@intel.com>
>>> Cc: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
>>> Cc: Michal Winiarski <michal.winiarski@intel.com>
>>> Cc: Michal Wajdeczko <michal.wajdeczko@intel.com>
>>> Cc: Joonas Lahtinen <joonas.lahtinen@linux.intel.com>
>>> Signed-off-by: Arkadiusz Hiler <arkadiusz.hiler@intel.com>
>>> ---
>>> drivers/gpu/drm/i915/intel_guc_loader.c | 36 ++++++++++-----------------------
>>> drivers/gpu/drm/i915/intel_huc.c | 21 ++++++-------------
>>> drivers/gpu/drm/i915/intel_uc.c | 4 +++-
>>> 3 files changed, 20 insertions(+), 41 deletions(-)
>>>
>>> diff --git a/drivers/gpu/drm/i915/intel_guc_loader.c b/drivers/gpu/drm/i915/intel_guc_loader.c
>>> index 0a29c1b..d731f68 100644
>>> --- a/drivers/gpu/drm/i915/intel_guc_loader.c
>>> +++ b/drivers/gpu/drm/i915/intel_guc_loader.c
>>> @@ -368,13 +368,6 @@ int intel_guc_init_hw(struct intel_guc *guc)
>>> intel_uc_fw_status_repr(guc->fw.fetch_status),
>>> intel_uc_fw_status_repr(guc->fw.load_status));
>>>
>>> - if (!fw_path) {
>>> - return -ENXIO;
>>> - } else if (*fw_path == '\0') {
>>> - WARN(1, "No GuC firmware known for this platform!\n");
>>> - return -ENODEV;
>>> - }
>>> -
>>> if (guc->fw.fetch_status != INTEL_UC_FIRMWARE_SUCCESS)
>>> return -EIO;
>>>
>>> @@ -399,7 +392,6 @@ int intel_guc_init_hw(struct intel_guc *guc)
>>> return 0;
>>> }
>>>
>>> -
>>> /**
>>> * intel_guc_init_fw() - select and prepare firmware for loading
>>> * @guc: intel_guc struct
>>> @@ -412,37 +404,31 @@ int intel_guc_init_hw(struct intel_guc *guc)
>>> void intel_guc_init_fw(struct intel_guc *guc)
>>> {
>>> struct drm_i915_private *dev_priv = guc_to_i915(guc);
>>> - const char *fw_path;
>>> +
>>> + guc->fw.path = NULL;
>>> + guc->fw.fetch_status = INTEL_UC_FIRMWARE_NONE;
>>> + guc->fw.load_status = INTEL_UC_FIRMWARE_NONE;
>>> + guc->fw.fw = INTEL_UC_FW_TYPE_GUC;
>>
>> If not too hard on the series and all, maybe bikeshed this field to "type".
>
> Makes sense. Can we do that as a separate patch afterwards?
Fine by me.
>> More importantly, this field wasn't getting set before? I don't see that it
>> got moved in this diff.
>
> Huh. Quick grep on drm-tip revealed that this was not set, only checked
> against. Guess it worked due to pure luck.
:) Okay. This one will be re-spun then?
>>>
>>> if (IS_SKYLAKE(dev_priv)) {
>>> - fw_path = I915_SKL_GUC_UCODE;
>>> + guc->fw.path = I915_SKL_GUC_UCODE;
>>> guc->fw.major_ver_wanted = SKL_FW_MAJOR;
>>> guc->fw.minor_ver_wanted = SKL_FW_MINOR;
>>> } else if (IS_BROXTON(dev_priv)) {
>>> - fw_path = I915_BXT_GUC_UCODE;
>>> + guc->fw.path = I915_BXT_GUC_UCODE;
>>> guc->fw.major_ver_wanted = BXT_FW_MAJOR;
>>> guc->fw.minor_ver_wanted = BXT_FW_MINOR;
>>> } else if (IS_KABYLAKE(dev_priv)) {
>>> - fw_path = I915_KBL_GUC_UCODE;
>>> + guc->fw.path = I915_KBL_GUC_UCODE;
>>> guc->fw.major_ver_wanted = KBL_FW_MAJOR;
>>> guc->fw.minor_ver_wanted = KBL_FW_MINOR;
>>> } else {
>>> - fw_path = ""; /* unknown device */
>>> + DRM_ERROR("No GuC firmware known for platform with GuC!\n");
>>
>> Quick glance over the series suggests intel_guc_init_fw is called
>> unconditionally from i915_load_modeset_init meaning this error gets logged
>> on all non-GuC platforms? I must be missing something..
>
> intel_uc_init_fw which call that, returns early if !enable_guc_loading.
>
> in intel_uc_snitize_options():
> if (!HAS_GUC) enable_guc_loading = 0
>
> The flow is further improved by next patch.
Ah, I was foiled by diff output. It is difficult to follow this series
if one is not 100% invested into it. Looks good to me then.
Assuming the mysterious fw type (fw.fw) assignment is resolved outside
this patch:
Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Regards,
Tvrtko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2017-03-13 13:55 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-03-13 13:14 [PATCH v8 00/11] GuC Scrub vol. 1 Arkadiusz Hiler
2017-03-13 13:14 ` [PATCH 01/11] drm/i915/uc: Drop superfluous externs in intel_uc.h Arkadiusz Hiler
2017-03-13 13:14 ` [PATCH 02/11] drm/i915/huc: Add huc_to_i915 Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 03/11] drm/i915/uc: Rename intel_?uc_{setup, load}() to _init_hw() Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 04/11] drm/i915/uc: Move intel_uc_fw_fetch() to intel_uc.c Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 05/11] drm/i915/uc: Introduce intel_uc_init_fw() Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 06/11] drm/i915/guc: Extract param logic form guc_init_fw() Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 07/11] drm/i915/guc: Simplify intel_guc_init_hw() Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 08/11] drm/i915/uc: Simplify firmware path handling Arkadiusz Hiler
2017-03-13 13:39 ` Tvrtko Ursulin
2017-03-13 13:48 ` Arkadiusz Hiler
2017-03-13 13:55 ` Tvrtko Ursulin [this message]
2017-03-13 13:15 ` [PATCH 09/11] drm/i915/uc: Separate firmware selection and preparation Arkadiusz Hiler
2017-03-13 13:15 ` [PATCH 10/11] drm/i915/uc: Add params for specifying firmware Arkadiusz Hiler
2017-03-14 12:18 ` Joonas Lahtinen
2017-03-13 13:15 ` [PATCH 11/11] HAX enable GuC for CI Arkadiusz Hiler
2017-03-13 13:53 ` ✗ Fi.CI.BAT: failure for GuC Scrub vol. 1 (rev12) Patchwork
-- strict thread matches above, loose matches on Subject: below --
2017-03-14 14:28 [PATCH v9 00/11] GuC Scrub vol. 1 Arkadiusz Hiler
2017-03-14 14:28 ` [PATCH 08/11] drm/i915/uc: Simplify firmware path handling Arkadiusz Hiler
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=faa74839-6695-4703-76fd-b891834d2370@linux.intel.com \
--to=tvrtko.ursulin@linux.intel.com \
--cc=arkadiusz.hiler@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox