From: Dave Martin <Dave.Martin@arm.com>
To: Andrew Jones <drjones@redhat.com>
Cc: Okamoto Takayuki <tokamoto@jp.fujitsu.com>,
Christoffer Dall <cdall@kernel.org>,
Ard Biesheuvel <ard.biesheuvel@linaro.org>,
Marc Zyngier <marc.zyngier@arm.com>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will.deacon@arm.com>,
Zhang Lei <zhang.lei@jp.fujitsu.com>,
Julien Grall <julien.grall@arm.com>,
kvmarm@lists.cs.columbia.edu,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 05/14] KVM: arm64/sve: Clean up UAPI register ID definitions
Date: Tue, 16 Apr 2019 13:37:34 +0100 [thread overview]
Message-ID: <20190416123734.GN3567@e103592.cambridge.arm.com> (raw)
In-Reply-To: <20190415151739.svfcwoybfr5js3wc@kamzik.brq.redhat.com>
On Mon, Apr 15, 2019 at 05:17:39PM +0200, Andrew Jones wrote:
> On Fri, Apr 12, 2019 at 05:28:09PM +0100, Dave Martin wrote:
> > Currently, the SVE register ID macros are not all defined in the
> > same way, and advertise the fact that FFR maps onto the nonexistent
> > predicate register P16. This is really just for kernel
> > convenience, and may lead userspace into bad habits.
> >
> > Instead, this patch masks the ID macro arguments so that
> > architecturally invalid register numbers will not be passed through
> > any more, and uses a literal KVM_REG_ARM64_SVE_FFR_BASE macro to
> > define KVM_REG_ARM64_SVE_FFR(), similarly to the way the _ZREG()
> > and _PREG() macros are defined.
> >
> > Rather than plugging in magic numbers for the number of Z- and P-
> > registers and the maximum possible number of register slices, this
> > patch provides definitions for those too. Userspace is going to
> > need them in any case, and it makes sense for them to come from
> > <uapi/asm/kvm.h>.
> >
> > sve_reg_to_region() uses convenience constants that are defined in
> > a different way, and also makes use of the fact that the FFR IDs
> > are really contiguous with the P15 IDs, so this patch retains the
> > existing convenience constants in guest.c, supplemented with a
> > couple of sanity checks to check for consistency with with the UAPI
>
> s/with with/with/
Good spot, thanks.
> > header.
> >
> > Fixes: e1c9c98345b3 ("KVM: arm64/sve: Add SVE support to register access ioctl interface")
> > Suggested-by: Andrew Jones <drjones@redhat.com>
> > Signed-off-by: Dave Martin <Dave.Martin@arm.com>
> > ---
> > arch/arm64/include/uapi/asm/kvm.h | 32 +++++++++++++++++++++++---------
> > arch/arm64/kvm/guest.c | 9 +++++++++
> > 2 files changed, 32 insertions(+), 9 deletions(-)
> >
>
> Reviewed-by: Andrew Jones <drjones@redhat.com>
Thanks
---Dave
WARNING: multiple messages have this Message-ID (diff)
From: Dave Martin <Dave.Martin@arm.com>
To: Andrew Jones <drjones@redhat.com>
Cc: Okamoto Takayuki <tokamoto@jp.fujitsu.com>,
Christoffer Dall <cdall@kernel.org>,
Ard Biesheuvel <ard.biesheuvel@linaro.org>,
Marc Zyngier <marc.zyngier@arm.com>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will.deacon@arm.com>,
Zhang Lei <zhang.lei@jp.fujitsu.com>,
Julien Grall <julien.grall@arm.com>,
kvmarm@lists.cs.columbia.edu,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 05/14] KVM: arm64/sve: Clean up UAPI register ID definitions
Date: Tue, 16 Apr 2019 13:37:34 +0100 [thread overview]
Message-ID: <20190416123734.GN3567@e103592.cambridge.arm.com> (raw)
Message-ID: <20190416123734.WmychaqVn28vQzhweR7664oEh4p5okMPwoIk9olqOXc@z> (raw)
In-Reply-To: <20190415151739.svfcwoybfr5js3wc@kamzik.brq.redhat.com>
On Mon, Apr 15, 2019 at 05:17:39PM +0200, Andrew Jones wrote:
> On Fri, Apr 12, 2019 at 05:28:09PM +0100, Dave Martin wrote:
> > Currently, the SVE register ID macros are not all defined in the
> > same way, and advertise the fact that FFR maps onto the nonexistent
> > predicate register P16. This is really just for kernel
> > convenience, and may lead userspace into bad habits.
> >
> > Instead, this patch masks the ID macro arguments so that
> > architecturally invalid register numbers will not be passed through
> > any more, and uses a literal KVM_REG_ARM64_SVE_FFR_BASE macro to
> > define KVM_REG_ARM64_SVE_FFR(), similarly to the way the _ZREG()
> > and _PREG() macros are defined.
> >
> > Rather than plugging in magic numbers for the number of Z- and P-
> > registers and the maximum possible number of register slices, this
> > patch provides definitions for those too. Userspace is going to
> > need them in any case, and it makes sense for them to come from
> > <uapi/asm/kvm.h>.
> >
> > sve_reg_to_region() uses convenience constants that are defined in
> > a different way, and also makes use of the fact that the FFR IDs
> > are really contiguous with the P15 IDs, so this patch retains the
> > existing convenience constants in guest.c, supplemented with a
> > couple of sanity checks to check for consistency with with the UAPI
>
> s/with with/with/
Good spot, thanks.
> > header.
> >
> > Fixes: e1c9c98345b3 ("KVM: arm64/sve: Add SVE support to register access ioctl interface")
> > Suggested-by: Andrew Jones <drjones@redhat.com>
> > Signed-off-by: Dave Martin <Dave.Martin@arm.com>
> > ---
> > arch/arm64/include/uapi/asm/kvm.h | 32 +++++++++++++++++++++++---------
> > arch/arm64/kvm/guest.c | 9 +++++++++
> > 2 files changed, 32 insertions(+), 9 deletions(-)
> >
>
> Reviewed-by: Andrew Jones <drjones@redhat.com>
Thanks
---Dave
_______________________________________________
kvmarm mailing list
kvmarm@lists.cs.columbia.edu
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm
next prev parent reply other threads:[~2019-04-16 12:37 UTC|newest]
Thread overview: 59+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-04-12 16:28 [PATCH 00/14] KVM: arm64: SVE cleanups Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 01/14] arm64/sve: Clarify vq map semantics Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 02/14] KVM: arm/arm64: Demote kvm_arm_init_arch_resources() to just set up SVE Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 03/14] KVM: arm: Make vcpu finalization stubs into inline functions Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 04/14] KVM: arm64/sve: sys_regs: Demote redundant vcpu_has_sve() checks to WARNs Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 05/14] KVM: arm64/sve: Clean up UAPI register ID definitions Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-15 15:17 ` Andrew Jones
2019-04-15 15:17 ` Andrew Jones
2019-04-16 12:37 ` Dave Martin [this message]
2019-04-16 12:37 ` Dave Martin
2019-04-12 16:28 ` [PATCH 06/14] KVM: arm64/sve: Miscellaneous tidyups in guest.c Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 07/14] KVM: arm64/sve: Make register ioctl access errors more consistent Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 08/14] KVM: arm64/sve: WARN when avoiding divide-by-zero in sve_reg_to_region() Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 09/14] KVM: arm64/sve: Simplify KVM_REG_ARM64_SVE_VLS array sizing Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-15 15:20 ` Andrew Jones
2019-04-15 15:20 ` Andrew Jones
2019-04-16 12:41 ` Dave Martin
2019-04-16 12:41 ` Dave Martin
2019-04-16 13:00 ` Andrew Jones
2019-04-16 13:00 ` Andrew Jones
2019-04-16 14:10 ` Dave Martin
2019-04-16 14:10 ` Dave Martin
2019-04-16 14:28 ` Andrew Jones
2019-04-16 14:28 ` Andrew Jones
2019-04-16 15:36 ` Dave Martin
2019-04-16 15:36 ` Dave Martin
2019-04-16 15:52 ` Dave Martin
2019-04-16 15:52 ` Dave Martin
2019-04-17 4:16 ` Andrew Jones
2019-04-17 4:16 ` Andrew Jones
2019-04-17 14:01 ` Dave Martin
2019-04-17 14:01 ` Dave Martin
2019-04-12 16:28 ` [PATCH 10/14] KVM: arm64/sve: Explain validity checks in set_sve_vls() Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 11/14] KVM: arm/arm64: Clean up vcpu finalization function parameter naming Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 12/14] KVM: Clarify capability requirements for KVM_ARM_VCPU_FINALIZE Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-12 16:28 ` [PATCH 13/14] KVM: Clarify KVM_{SET, GET}_ONE_REG error code documentation Dave Martin
2019-04-15 15:21 ` [PATCH 13/14] KVM: Clarify KVM_{SET,GET}_ONE_REG " Andrew Jones
2019-04-15 15:21 ` Andrew Jones
2019-04-16 12:42 ` Dave Martin
2019-04-16 12:42 ` Dave Martin
2019-04-12 16:28 ` [PATCH 14/14] KVM: arm64: Clarify access behaviour for out-of-range SVE register slice IDs Dave Martin
2019-04-12 16:28 ` Dave Martin
2019-04-15 15:22 ` [PATCH 00/14] KVM: arm64: SVE cleanups Andrew Jones
2019-04-15 15:22 ` Andrew Jones
2019-04-16 12:46 ` Dave Martin
2019-04-16 12:46 ` Dave Martin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190416123734.GN3567@e103592.cambridge.arm.com \
--to=dave.martin@arm.com \
--cc=ard.biesheuvel@linaro.org \
--cc=catalin.marinas@arm.com \
--cc=cdall@kernel.org \
--cc=drjones@redhat.com \
--cc=julien.grall@arm.com \
--cc=kvmarm@lists.cs.columbia.edu \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=marc.zyngier@arm.com \
--cc=tokamoto@jp.fujitsu.com \
--cc=will.deacon@arm.com \
--cc=zhang.lei@jp.fujitsu.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox