Generic Linux architectural discussions
 help / color / mirror / Atom feed
From: "Li Zhe" <lizhe.67@bytedance.com>
To: <apopple@nvidia.com>
Cc: <akpm@linux-foundation.org>, <arnd@arndb.de>, <bp@alien8.de>,
	 <dave.hansen@linux.intel.com>, <david@kernel.org>,
	<kees@kernel.org>,  <linux-arch@vger.kernel.org>,
	<linux-hardening@vger.kernel.org>,
	 <linux-kernel@vger.kernel.org>, <linux-mm@kvack.org>,
	 <lizhe.67@bytedance.com>, <mingo@redhat.com>, <rppt@kernel.org>,
	 <tglx@kernel.org>, <x86@kernel.org>
Subject: Re: [PATCH v5 4/8] mm: add a template-based fast path for zone-device page init
Date: Tue,  7 Jul 2026 14:33:03 +0800	[thread overview]
Message-ID: <20260707063303.40128-1-lizhe.67@bytedance.com> (raw)
In-Reply-To: <akxpS3WOP7oUBNKF@nvdebian.thelocal>

On Tue, 7 Jul 2026 13:02:52 +1000, apopple@nvidia.com wrote:
> > +static inline bool zone_device_page_init_optimization_enabled(void)
> > +{
> > +	/*
> > +	 * The template fast path copies a preinitialized struct page image.
> > +	 * Skip it when the page_ref_set tracepoint is enabled.
> > +	 */
> > +	return !page_ref_tracepoint_active(page_ref_set);
> > +}
> > +
> > +static inline void zone_device_template_page_init(struct page *template,
> > +						  struct page *src)
> > +{
> > +	memcpy(template, src, sizeof(*template));
> 
> I'd drop this function and just open-code the memcpy as I think that ends up
> being clearer and removes a naming confusion - I kept mixing up the purpose of
> `zone_device_template_page_init` and `zone_device_page_init_from_template`

Agreed. I will drop zone_device_template_page_init() and open-code
that memcpy() in v6.

> > -	for (pfn = start_pfn; pfn < end_pfn; pfn += pfns_per_compound) {
> > -		struct page *page = pfn_to_page(pfn);
> > +
> > +	if (!nr_pages)
> > +		return;
> > +
> > +	pfn = start_pfn;
> > +	/*
> > +	 * Seed the reusable head-page template from the first real struct
> > +	 * page, because the existing page-init and pageblock helpers expect
> > +	 * a real memmap entry rather than a stack object.
> > +	 */
> > +	if (use_template) {
> > +		struct page *page = pfn_to_page(start_pfn);
> >
> >  		zone_device_page_init_slow(page, pfn, zone_idx, nid, pgmap);
> > +		zone_device_template_page_init(&template, page);
> > +		if (pfns_per_compound != 1)
> > +			memmap_init_compound(page, pfn, zone_idx, nid, pgmap,
> > +				compound_nr_pages(start_pfn, altmap, pgmap));
> > +		pfn += pfns_per_compound;
> 
> I think it would be clearer and less error prone to not unroll the loop here.
> Instead just initialise the template page and leave the for loop starting at
> pfn = start_pfn and let it handle the rest of the steps. I can't imagine the
> extra call to zone_deivce_page_init_from_template() would cause a noticable
> perf impact.
> 
> It also avoids the obvious danger of someone updating the loop but missing the
> unrolled version above.

Thanks. I will keep the initial slow-path template seeding as a
separate step, still using the first real memmap entry for that, but
let the main loop start at start_pfn again so the first PFN goes
through the same loop body as the rest. That should make the code
clearer and avoid the duplicated first-iteration path drifting from
the main loop in later changes.

Thanks,
Zhe

  reply	other threads:[~2026-07-07  6:33 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-01  9:05 [PATCH v5 0/8] mm: optimize zone-device memmap initialization Li Zhe
2026-07-01  9:05 ` [PATCH v5 1/8] mm: fix stale ZONE_DEVICE refcount comment Li Zhe
2026-07-06  9:11   ` David Hildenbrand (Arm)
2026-07-07  2:28   ` Alistair Popple
2026-07-01  9:05 ` [PATCH v5 2/8] mm: factor zone-device page init helpers out of __init_zone_device_page Li Zhe
2026-07-06  9:13   ` David Hildenbrand (Arm)
2026-07-06 11:50     ` Li Zhe
2026-07-06 13:47       ` David Hildenbrand (Arm)
2026-07-07  3:25         ` Li Zhe
2026-07-01  9:05 ` [PATCH v5 3/8] mm: add a set_page_section_from_pfn() helper Li Zhe
2026-07-06  9:15   ` David Hildenbrand (Arm)
2026-07-06 11:52     ` Li Zhe
2026-07-06 13:48       ` David Hildenbrand (Arm)
2026-07-07  3:26         ` Li Zhe
2026-07-01  9:05 ` [PATCH v5 4/8] mm: add a template-based fast path for zone-device page init Li Zhe
2026-07-03 14:06   ` Mike Rapoport
2026-07-06  7:45     ` Li Zhe
2026-07-07  3:06       ` Alistair Popple
2026-07-07  6:36         ` Li Zhe
2026-07-07  3:02   ` Alistair Popple
2026-07-07  6:33     ` Li Zhe [this message]
2026-07-01  9:05 ` [PATCH v5 5/8] mm: extend the template fast path to zone-device compound tails Li Zhe
2026-07-07  3:09   ` Alistair Popple
2026-07-07  6:38     ` Li Zhe
2026-07-01  9:05 ` [PATCH v5 6/8] string: introduce memcpy_nt() helpers Li Zhe
2026-07-02  2:16   ` Borislav Petkov
2026-07-02  7:36     ` Li Zhe
2026-07-06  9:18   ` David Hildenbrand (Arm)
2026-07-06 11:53     ` Li Zhe
2026-07-06 13:49       ` David Hildenbrand (Arm)
2026-07-07  3:28         ` Li Zhe
2026-07-01  9:05 ` [PATCH v5 7/8] x86/string: extend memcpy_flushcache() fixed-size fastpaths Li Zhe
2026-07-02  2:23   ` Borislav Petkov
2026-07-02  7:37     ` Li Zhe
2026-07-03 19:56       ` Borislav Petkov
2026-07-06  7:43         ` Li Zhe
2026-07-06 17:19           ` Borislav Petkov
2026-07-07 11:34             ` Li Zhe
2026-07-01  9:05 ` [PATCH v5 8/8] mm: use memcpy_nt() in zone-device template copies Li Zhe
2026-07-01 23:28 ` [PATCH v5 0/8] mm: optimize zone-device memmap initialization Andrew Morton
2026-07-02  2:24   ` Borislav Petkov
2026-07-02  7:39   ` Li Zhe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260707063303.40128-1-lizhe.67@bytedance.com \
    --to=lizhe.67@bytedance.com \
    --cc=akpm@linux-foundation.org \
    --cc=apopple@nvidia.com \
    --cc=arnd@arndb.de \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=david@kernel.org \
    --cc=kees@kernel.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-hardening@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=mingo@redhat.com \
    --cc=rppt@kernel.org \
    --cc=tglx@kernel.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox