From: Sebastian Reichel <sebastian.reichel@collabora.com>
To: Vinod Koul <vkoul@kernel.org>,
Neil Armstrong <neil.armstrong@linaro.org>,
Heiko Stuebner <heiko@sntech.de>,
Frank Wang <frank.wang@rock-chips.com>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Thinh Nguyen <Thinh.Nguyen@synopsys.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Andy Yan <andy.yan@rock-chips.com>,
Dmitry Baryshkov <lumag@kernel.org>,
Yubing Zhang <yubing.zhang@rock-chips.com>,
Alexey Charkov <alchark@gmail.com>,
linux-phy@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-rockchip@lists.infradead.org,
linux-kernel@vger.kernel.org, kernel@collabora.com,
devicetree@vger.kernel.org, linux-usb@vger.kernel.org,
Sebastian Reichel <sebastian.reichel@collabora.com>
Subject: [PATCH v9 19/38] phy: rockchip: usbdp: Rename mode_change to phy_needs_reinit
Date: Thu, 02 Jul 2026 01:35:57 +0200 [thread overview]
Message-ID: <20260702-rockchip-usbdp-cleanup-v9-19-e31efbb62d2e@collabora.com> (raw)
In-Reply-To: <20260702-rockchip-usbdp-cleanup-v9-0-e31efbb62d2e@collabora.com>
Right now the mode_change property is set whenever the mode changes
between USB-only, DP-only and USB-DP. It is needed, because on any
mode change the PHY needs to be re-initialized. Apparently at least
DP also requires a re-init when the cable orientation is changed,
which is currently not being done (except when the orientation switch
also involves a mode change). Prepare for this by renaming mode_change
to phy_needs_reinit.
Signed-off-by: Sebastian Reichel <sebastian.reichel@collabora.com>
---
drivers/phy/rockchip/phy-rockchip-usbdp.c | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/drivers/phy/rockchip/phy-rockchip-usbdp.c b/drivers/phy/rockchip/phy-rockchip-usbdp.c
index 928466659486..8f06bb9b1fcb 100644
--- a/drivers/phy/rockchip/phy-rockchip-usbdp.c
+++ b/drivers/phy/rockchip/phy-rockchip-usbdp.c
@@ -172,7 +172,7 @@ struct rk_udphy {
/* PHY status management */
bool flip;
- bool mode_change;
+ bool phy_needs_reinit;
u8 mode;
u8 status;
@@ -584,7 +584,7 @@ static void rk_udphy_mode_set(struct rk_udphy *udphy, u8 mode)
if (udphy->mode == mode)
return;
- udphy->mode_change = true;
+ udphy->phy_needs_reinit = true;
udphy->mode = mode;
}
@@ -987,15 +987,15 @@ static int rk_udphy_power_on(struct rk_udphy *udphy, u8 mode)
if (udphy->mode & UDPHY_MODE_USB)
rk_udphy_u3_port_disable(udphy, false);
- udphy->mode_change = false;
- } else if (udphy->mode_change) {
+ udphy->phy_needs_reinit = false;
+ } else if (udphy->phy_needs_reinit) {
if (udphy->mode == UDPHY_MODE_DP)
rk_udphy_u3_port_disable(udphy, true);
ret = rk_udphy_init(udphy);
if (ret)
return ret;
- udphy->mode_change = false;
+ udphy->phy_needs_reinit = false;
}
udphy->status |= mode;
--
2.53.0
next prev parent reply other threads:[~2026-07-01 23:36 UTC|newest]
Thread overview: 39+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-01 23:35 [PATCH v9 00/38] phy: rockchip: usbdp: Clean up the mess Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 01/38] dt-bindings: phy: rockchip-usbdp: add improved ports scheme Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 02/38] phy: rockchip: usbdp: Update mode_change after error handling Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 03/38] phy: rockchip: usbdp: Do not lose USB3 PHY status Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 04/38] phy: rockchip: usbdp: Fix devm_clk_bulk_get_all check Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 05/38] phy: rockchip: usbdp: Handle missing clock-names DT property gracefully Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 06/38] phy: rockchip: usbdp: Drop seamless DP takeover Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 07/38] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert_all errors in init check Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 08/38] phy: rockchip: usbdp: Keep clocks running on PHY re-init Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 09/38] phy: rockchip: usbdp: Amend SSC modulation deviation Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 10/38] phy: rockchip: usbdp: Fix LFPS detect threshold control Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 11/38] phy: rockchip: usbdp: Add missing mode_change update Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 12/38] phy: rockchip: usbdp: Support single-lane DP Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 13/38] phy: rockchip: usbdp: Limit DP lane count to muxed lanes Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 14/38] phy: rockchip: usbdp: Rename DP lane functions Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 15/38] phy: rockchip: usbdp: Use FIELD_PREP_WM16_CONST Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 16/38] phy: rockchip: usbdp: Cleanup DP lane selection function Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 17/38] phy: rockchip: usbdp: Register DP aux bridge Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 18/38] phy: rockchip: usbdp: Drop DP HPD handling Sebastian Reichel
2026-07-01 23:35 ` Sebastian Reichel [this message]
2026-07-01 23:35 ` [PATCH v9 20/38] phy: rockchip: usbdp: Re-init the PHY on orientation change Sebastian Reichel
2026-07-01 23:35 ` [PATCH v9 21/38] phy: rockchip: usbdp: Factor out lane_mux_sel setup Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 22/38] phy: rockchip: usbdp: Properly handle TYPEC_STATE_SAFE and TYPEC_STATE_USB Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 23/38] phy: rockchip: usbdp: Use guard functions for mutex Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 24/38] phy: rockchip: usbdp: Clear USB status on PHY exit Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 25/38] phy: rockchip: usbdp: Hold mutex in DP PHY configure Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 26/38] phy: rockchip: usbdp: Add some extra debug messages Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 27/38] phy: rockchip: usbdp: Avoid xHCI SErrors Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 28/38] phy: rockchip: usbdp: Disable USB3 on probe Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 29/38] phy: rockchip: usbdp: Handle rk_udphy_reset_deassert errors Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 30/38] phy: rockchip: usbdp: Only enable USB3 when not in high-speed mode Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 31/38] phy: core: add notifier infrastructure Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 32/38] usb: dwc3: core: support PHY reset notifications Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 33/38] phy: rockchip: usbdp: Add phy reset notification support Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 34/38] phy: rockchip: usbdp: Rename mode to hw_mode Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 35/38] phy: rockchip: usbdp: Simplify power state handling Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 36/38] phy: rockchip: usbdp: Rename phy_needs_reinit to orientation_changed Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 37/38] phy: rockchip: usbdp: Re-init PHY on mux change Sebastian Reichel
2026-07-01 23:36 ` [PATCH v9 38/38] phy: rockchip: usbdp: Power optimizations Sebastian Reichel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260702-rockchip-usbdp-cleanup-v9-19-e31efbb62d2e@collabora.com \
--to=sebastian.reichel@collabora.com \
--cc=Thinh.Nguyen@synopsys.com \
--cc=alchark@gmail.com \
--cc=andy.yan@rock-chips.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=frank.wang@rock-chips.com \
--cc=gregkh@linuxfoundation.org \
--cc=heiko@sntech.de \
--cc=kernel@collabora.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux-usb@vger.kernel.org \
--cc=lumag@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=robh@kernel.org \
--cc=vkoul@kernel.org \
--cc=yubing.zhang@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox