Linux-audit Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Jan Kara <jack@suse.cz>
To: Paul Moore <paul@paul-moore.com>
Cc: rgb@redhat.com, linux-audit@redhat.com, Jan Kara <jack@suse.cz>
Subject: [PATCH] audit: Rename audit mark variable to amark
Date: Thu,  4 Oct 2018 09:07:55 +0200	[thread overview]
Message-ID: <20181004070755.9981-1-jack@suse.cz> (raw)

Variable of audit_tree_mark type was called 'mark' which is confusing as
we usually call fsnotify_mark variables this way. Rename it to 'amark'
to make it explicit this a actually a different thing.

Signed-off-by: Jan Kara <jack@suse.cz>
---
 kernel/audit_tree.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

 Hello Paul,

 here is the patch to rename mark to amark as Richard suggested.

								Honza

diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
index 9c53f7c37bdf..232b8b18cb5b 100644
--- a/kernel/audit_tree.c
+++ b/kernel/audit_tree.c
@@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)
 
 static struct fsnotify_mark *alloc_mark(void)
 {
-	struct audit_tree_mark *mark;
+	struct audit_tree_mark *amark;
 
-	mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
-	if (!mark)
+	amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
+	if (!amark)
 		return NULL;
-	fsnotify_init_mark(&mark->mark, audit_tree_group);
-	mark->mark.mask = FS_IN_IGNORED;
-	return &mark->mark;
+	fsnotify_init_mark(&amark->mark, audit_tree_group);
+	amark->mark.mask = FS_IN_IGNORED;
+	return &amark->mark;
 }
 
 static struct audit_chunk *alloc_chunk(int count)
-- 
2.16.4

             reply	other threads:[~2018-10-04  7:07 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-04  7:07 Jan Kara [this message]
2018-10-04 14:23 ` [PATCH] audit: Rename audit mark variable to amark Paul Moore
2018-10-10 12:27 ` Richard Guy Briggs

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181004070755.9981-1-jack@suse.cz \
    --to=jack@suse.cz \
    --cc=linux-audit@redhat.com \
    --cc=paul@paul-moore.com \
    --cc=rgb@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox