Linux-audit Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] audit: Rename audit mark variable to amark
@ 2018-10-04  7:07 Jan Kara
  2018-10-04 14:23 ` Paul Moore
  2018-10-10 12:27 ` Richard Guy Briggs
  0 siblings, 2 replies; 3+ messages in thread
From: Jan Kara @ 2018-10-04  7:07 UTC (permalink / raw)
  To: Paul Moore; +Cc: rgb, linux-audit, Jan Kara

Variable of audit_tree_mark type was called 'mark' which is confusing as
we usually call fsnotify_mark variables this way. Rename it to 'amark'
to make it explicit this a actually a different thing.

Signed-off-by: Jan Kara <jack@suse.cz>
---
 kernel/audit_tree.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

 Hello Paul,

 here is the patch to rename mark to amark as Richard suggested.

								Honza

diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
index 9c53f7c37bdf..232b8b18cb5b 100644
--- a/kernel/audit_tree.c
+++ b/kernel/audit_tree.c
@@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)
 
 static struct fsnotify_mark *alloc_mark(void)
 {
-	struct audit_tree_mark *mark;
+	struct audit_tree_mark *amark;
 
-	mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
-	if (!mark)
+	amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
+	if (!amark)
 		return NULL;
-	fsnotify_init_mark(&mark->mark, audit_tree_group);
-	mark->mark.mask = FS_IN_IGNORED;
-	return &mark->mark;
+	fsnotify_init_mark(&amark->mark, audit_tree_group);
+	amark->mark.mask = FS_IN_IGNORED;
+	return &amark->mark;
 }
 
 static struct audit_chunk *alloc_chunk(int count)
-- 
2.16.4

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH] audit: Rename audit mark variable to amark
  2018-10-04  7:07 [PATCH] audit: Rename audit mark variable to amark Jan Kara
@ 2018-10-04 14:23 ` Paul Moore
  2018-10-10 12:27 ` Richard Guy Briggs
  1 sibling, 0 replies; 3+ messages in thread
From: Paul Moore @ 2018-10-04 14:23 UTC (permalink / raw)
  To: jack; +Cc: rgb, linux-audit

On Thu, Oct 4, 2018 at 3:07 AM Jan Kara <jack@suse.cz> wrote:
> Variable of audit_tree_mark type was called 'mark' which is confusing as
> we usually call fsnotify_mark variables this way. Rename it to 'amark'
> to make it explicit this a actually a different thing.
>
> Signed-off-by: Jan Kara <jack@suse.cz>
> ---
>  kernel/audit_tree.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
>  Hello Paul,
>
>  here is the patch to rename mark to amark as Richard suggested.

Thanks, merged into audit/working-fsnotify_fixes.

> diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
> index 9c53f7c37bdf..232b8b18cb5b 100644
> --- a/kernel/audit_tree.c
> +++ b/kernel/audit_tree.c
> @@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)
>
>  static struct fsnotify_mark *alloc_mark(void)
>  {
> -       struct audit_tree_mark *mark;
> +       struct audit_tree_mark *amark;
>
> -       mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
> -       if (!mark)
> +       amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
> +       if (!amark)
>                 return NULL;
> -       fsnotify_init_mark(&mark->mark, audit_tree_group);
> -       mark->mark.mask = FS_IN_IGNORED;
> -       return &mark->mark;
> +       fsnotify_init_mark(&amark->mark, audit_tree_group);
> +       amark->mark.mask = FS_IN_IGNORED;
> +       return &amark->mark;
>  }
>
>  static struct audit_chunk *alloc_chunk(int count)
> --
> 2.16.4
>


-- 
paul moore
www.paul-moore.com

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH] audit: Rename audit mark variable to amark
  2018-10-04  7:07 [PATCH] audit: Rename audit mark variable to amark Jan Kara
  2018-10-04 14:23 ` Paul Moore
@ 2018-10-10 12:27 ` Richard Guy Briggs
  1 sibling, 0 replies; 3+ messages in thread
From: Richard Guy Briggs @ 2018-10-10 12:27 UTC (permalink / raw)
  To: Jan Kara; +Cc: linux-audit

On 2018-10-04 09:07, Jan Kara wrote:
> Variable of audit_tree_mark type was called 'mark' which is confusing as
> we usually call fsnotify_mark variables this way. Rename it to 'amark'
> to make it explicit this a actually a different thing.
> 

Better late than never?  I've been offline since Thursday.  Looks good
to me.

> Signed-off-by: Jan Kara <jack@suse.cz>
> ---
>  kernel/audit_tree.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
> 
>  Hello Paul,
> 
>  here is the patch to rename mark to amark as Richard suggested.
> 
> 								Honza
> 
> diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
> index 9c53f7c37bdf..232b8b18cb5b 100644
> --- a/kernel/audit_tree.c
> +++ b/kernel/audit_tree.c
> @@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)
>  
>  static struct fsnotify_mark *alloc_mark(void)
>  {
> -	struct audit_tree_mark *mark;
> +	struct audit_tree_mark *amark;
>  
> -	mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
> -	if (!mark)
> +	amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
> +	if (!amark)
>  		return NULL;
> -	fsnotify_init_mark(&mark->mark, audit_tree_group);
> -	mark->mark.mask = FS_IN_IGNORED;
> -	return &mark->mark;
> +	fsnotify_init_mark(&amark->mark, audit_tree_group);
> +	amark->mark.mask = FS_IN_IGNORED;
> +	return &amark->mark;
>  }
>  
>  static struct audit_chunk *alloc_chunk(int count)
> -- 
> 2.16.4
> 

- RGB

--
Richard Guy Briggs <rgb@redhat.com>
Sr. S/W Engineer, Kernel Security, Base Operating Systems
Remote, Ottawa, Red Hat Canada
IRC: rgb, SunRaycer
Voice: +1.647.777.2635, Internal: (81) 32635

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2018-10-10 12:27 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2018-10-04  7:07 [PATCH] audit: Rename audit mark variable to amark Jan Kara
2018-10-04 14:23 ` Paul Moore
2018-10-10 12:27 ` Richard Guy Briggs

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox