Linux cryptographic layer development
 help / color / mirror / Atom feed
* crypto: Remove duplicate code of SG helpers functions
@ 2015-09-10 13:21 LABBE Corentin
  2015-09-10 13:21 ` [PATCH 1/7] crypto: bfin: replace sg_count by sg_nents LABBE Corentin
                   ` (6 more replies)
  0 siblings, 7 replies; 13+ messages in thread
From: LABBE Corentin @ 2015-09-10 13:21 UTC (permalink / raw)
  To: herbert, davem; +Cc: linux-kernel, linux-crypto


Hello

This patch series try to remove some duplicate code of some SG helpers functions.
The first three patch replace custom functions by already in-tree helper functions.

The fourth add a new functions "sg_nents_for_len2" who is the same as
sg_nents_for_len with an additionnal arguments.
Note that I do not like the name, but I do not find any good name.

The last three patch use sg_nents_for_len2 for removing custom functions.

I send those patch as RFC since I do not own any of those hardware to test.

Regards

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2015-09-18 12:43 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2015-09-10 13:21 crypto: Remove duplicate code of SG helpers functions LABBE Corentin
2015-09-10 13:21 ` [PATCH 1/7] crypto: bfin: replace sg_count by sg_nents LABBE Corentin
2015-09-10 13:21 ` [PATCH 2/7] crypto: amcc replace get_sg_count by sg_nents_for_len LABBE Corentin
2015-09-10 13:21 ` [PATCH 3/7] crypto: sahara replace sahara_sg_length with sg_nents_for_len LABBE Corentin
2015-09-10 13:21 ` [PATCH 4/7] lib: introduce sg_nents_for_len2 LABBE Corentin
2015-09-18 11:53   ` Herbert Xu
2015-09-18 12:20     ` LABBE Corentin
2015-09-18 12:22       ` Herbert Xu
2015-09-18 12:42         ` LABBE Corentin
2015-09-18 12:43           ` Herbert Xu
2015-09-10 13:21 ` [PATCH 5/7] crypto: talitos replace sg_count with sg_nents_for_len2 LABBE Corentin
2015-09-10 13:21 ` [PATCH 6/7] crypto: qce replace qce_countsg " LABBE Corentin
2015-09-10 13:21 ` [PATCH 7/7] crypto: caam replace __sg_count " LABBE Corentin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox