From: Bryan O'Donoghue <bryan.odonoghue@linaro.org>
To: Vikram Sharma <vikram.sharma@oss.qualcomm.com>,
Bryan O'Donoghue <bod@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
Michael Turquette <mturquette@baylibre.com>,
Stephen Boyd <sboyd@kernel.org>, Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Robert Foss <rfoss@kernel.org>, Todor Tomov <todor.too@gmail.com>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Konrad Dybcio <konradybcio@kernel.org>,
Vladimir Zapolskiy <vladimir.zapolskiy@linaro.org>,
Loic Poulain <loic.poulain@oss.qualcomm.com>
Cc: linux-arm-msm@vger.kernel.org, linux-clk@vger.kernel.org,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-media@vger.kernel.org,
Krzysztof Kozlowski <krzk@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
Subject: Re: [PATCH v12 2/6] dt-bindings: media: qcom,x1e80100-camss: Describe iommu entries
Date: Thu, 9 Jul 2026 16:50:26 +0100 [thread overview]
Message-ID: <abb179ca-a3fb-4bcf-bf7c-9766f939431c@linaro.org> (raw)
In-Reply-To: <85a05836-6298-4111-97ca-80d7e3b3a9c4@oss.qualcomm.com>
On 09/07/2026 16:28, Vikram Sharma wrote:
>
> On 7/9/2026 3:02 AM, Bryan O'Donoghue wrote:
>> On 08/07/2026 16:15, Vikram Sharma wrote:
>>>
>>> On 7/8/2026 5:36 AM, Bryan O'Donoghue wrote:
>>>> iommus = <&apps_smmu 0x800 0x60>,
>>>> + <&apps_smmu 0x820 0x60>,
>>>> + <&apps_smmu 0x840 0x60>,
>>>> <&apps_smmu 0x860 0x60>,
>>>
>>> I think only "iommus = <&apps_smmu 0x800 0x60>" should be enough as mask which 0x60 is implicitly covering sids like 0x820, 0x840 and 0x860.
>>>
>>> Regards,
>>> Vikram
>>>
>>
>> These all come from the Hamoa iommu defintions in qcom docs.
>>
>> Can you double check for yourself and let me know.
> Hi Bryan,
>
> Confirmed — all four SIDs (0x800, 0x820, 0x840, 0x860) are valid and documented for IFE/SFE. My point was specifically about how the ARM SMMU SMR matching logic handles these with the given mask.
>
> In SMR hardware, the mask field marks bits as "don't care" during stream ID comparison. With SID = 0x800 and MASK = 0x60:
>
> MASK = 0x60 = 0b 0110 0000 → bits [6:5] are don't-care
> The four SIDs differ only in bits [6:5]:
>
> 0x800 = 0b 1000 0000 0000 → bits[6:5] = 00
> 0x820 = 0b 1000 0010 0000 → bits[6:5] = 01
> 0x840 = 0b 1000 0100 0000 → bits[6:5] = 10
> 0x860 = 0b 1000 0110 0000 → bits[6:5] = 11
>
> Since 0x60 masks out exactly those differing bits, a single entry <&apps_smmu 0x800 0x60> will match all four SIDs.
>
> That said, I'd say this is more of a preference — both forms are functionally correct, and if you prefer keeping the four explicit entries for clarity or to stay aligned with how the Qcom docs enumerate them, that's perfectly fine too.
>
> Regards,
> Vikram
I rote-copied with my brain switched off.
Your suggestion seems correct to me.
---
bod
next prev parent reply other threads:[~2026-07-09 15:50 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-08 0:06 [PATCH v12 0/6] Add dt-bindings and PHY updates for CAMSS on x1e80100 silicon Bryan O'Donoghue
2026-07-08 0:06 ` [PATCH v12 1/6] dt-bindings: media: qcom,x1e80100-camss: Add optional PHY handle definitions Bryan O'Donoghue
2026-07-08 0:16 ` sashiko-bot
2026-07-08 1:34 ` Rob Herring (Arm)
2026-07-08 7:49 ` Vladimir Zapolskiy
2026-07-08 22:09 ` Frank Li
2026-07-08 22:15 ` Bryan O'Donoghue
2026-07-08 0:06 ` [PATCH v12 2/6] dt-bindings: media: qcom,x1e80100-camss: Describe iommu entries Bryan O'Donoghue
2026-07-08 12:39 ` Loic Poulain
2026-07-08 15:15 ` Vikram Sharma
2026-07-08 21:32 ` Bryan O'Donoghue
2026-07-09 15:28 ` Vikram Sharma
2026-07-09 15:50 ` Bryan O'Donoghue [this message]
2026-07-08 0:06 ` [PATCH v12 3/6] media: qcom: camss: Add support to populate sub-devices Bryan O'Donoghue
2026-07-08 0:18 ` sashiko-bot
2026-07-09 15:47 ` Frank Li
2026-07-08 0:06 ` [PATCH v12 4/6] media: qcom: camss: Add legacy_phy flag to SoC definition structures Bryan O'Donoghue
2026-07-08 0:14 ` sashiko-bot
2026-07-08 0:16 ` Bryan O'Donoghue
2026-07-09 15:48 ` Frank Li
2026-07-09 16:33 ` Loic Poulain
2026-07-08 0:06 ` [PATCH v12 5/6] media: qcom: camss: Add support for PHY API devices Bryan O'Donoghue
2026-07-08 0:19 ` sashiko-bot
2026-07-09 16:08 ` Frank Li
2026-07-08 0:07 ` [PATCH v12 6/6] media: qcom: camss: Drop legacy PHY descriptions from x1e Bryan O'Donoghue
2026-07-08 0:26 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=abb179ca-a3fb-4bcf-bf7c-9766f939431c@linaro.org \
--to=bryan.odonoghue@linaro.org \
--cc=andersson@kernel.org \
--cc=bod@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=konradybcio@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=krzk@kernel.org \
--cc=krzysztof.kozlowski@oss.qualcomm.com \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-clk@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=loic.poulain@oss.qualcomm.com \
--cc=mchehab@kernel.org \
--cc=mturquette@baylibre.com \
--cc=rfoss@kernel.org \
--cc=robh@kernel.org \
--cc=sboyd@kernel.org \
--cc=todor.too@gmail.com \
--cc=vikram.sharma@oss.qualcomm.com \
--cc=vladimir.zapolskiy@linaro.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox