Devicetree
 help / color / mirror / Atom feed
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Chen-Yu Tsai <wenst@chromium.org>
Cc: sashiko-reviews@lists.linux.dev, devicetree@vger.kernel.org,
	driver-core@lists.linux.dev,
	Bartosz Golaszewski <bartosz.golaszewski@oss.qualcomm.com>
Subject: Re: [PATCH v5 02/16] device property: Add fwnode_graph_get_next_port_endpoint()
Date: Fri, 17 Jul 2026 19:33:25 +0300	[thread overview]
Message-ID: <alpZVUEOidfGMpfD@ashevche-desk.local> (raw)
In-Reply-To: <CAGXv+5HS3neb=8EW0FT2-tP-dhPFqQ+q8YRS8Gy_XBic4z4Mug@mail.gmail.com>

On Fri, Jul 17, 2026 at 07:05:56PM +0800, Chen-Yu Tsai wrote:
> On Fri, Jul 17, 2026 at 5:04 AM Andy Shevchenko
> <andriy.shevchenko@linux.intel.com> wrote:
> > On Thu, Jul 16, 2026 at 04:52:27PM +0800, Chen-Yu Tsai wrote:
> > > On Wed, Jul 15, 2026 at 5:09 PM <sashiko-bot@kernel.org> wrote:

...

> > > > > +struct fwnode_handle *fwnode_graph_get_next_port_endpoint(const struct fwnode_handle *port,
> > > > > +                                                       struct fwnode_handle *prev)
> > > > > +{
> > > > > +     do {
> > > > > +             prev = fwnode_get_next_child_node(port, prev);
> > > >
> > > > [Severity: High]
> > > > This is a pre-existing issue, but iterating over endpoints using
> > > > fwnode_get_next_child_node() can cause an infinite loop and a use-after-free
> > > > if a device has secondary fwnodes attached.
> > > >
> > > > If a device port has both primary children and a secondary fwnode, the primary
> > > > ops finish and drop the reference to the last primary child, returning NULL.
> > > > Then, fwnode_get_next_child_node() incorrectly passes this same dropped child
> > > > pointer to the secondary ops:
> > > >
> > > > drivers/base/property.c:fwnode_get_next_child_node() {
> > > >         /* Try to find a child in primary fwnode */
> > > >         next = fwnode_call_ptr_op(fwnode, get_next_child_node, child);
> > > >         if (next)
> > > >                 return next;
> > > >
> > > >         /* When no more children in primary, continue with secondary */
> > > >         return fwnode_call_ptr_op(fwnode->secondary, get_next_child_node, child);
> > > > }
> > > >
> > > > This can result in a double-put. Furthermore, when traversing secondary
> > > > children, the primary ops don't recognize the software node, treat it as NULL,
> > > > and return the first primary child again, creating an infinite loop.
> >
> > Yeah, it has to be implemented in a way how fwnode_graph_get_next_endpoint() is done.
> 
> If your patch series addresses the issue, I guess we can consider it
> covered? Sashiko labeled this a pre-existing.

I noticed that it addresses only main get_next case, but get_next_available is
still with the same issue. It's not that critical, we don't use much that API,
but still will be good to fix at some point.

> > > > [Severity: Medium]
> > > > Does this fail to unconditionally put the prev reference if the provided port
> > > > is invalid?
> > > >
> > > > If a caller passes a valid prev node but port is NULL or an error pointer,
> > > > fwnode_get_next_child_node() returns early without dropping prev:
> > > >
> > > > drivers/base/property.c:fwnode_get_next_child_node() {
> > > >         struct fwnode_handle *next;
> > > >
> > > >         if (IS_ERR_OR_NULL(fwnode))
> > > >                 return NULL;
> > > >     ...
> > > > }
> > > >
> > > > Could this lead to a reference count leak, violating the documented API
> > > > contract that prev is unconditionally put?
> > >
> > > This seems like what the other fwnode_get_next_*() functions are doing.
> > > I'd say this is a pre-existing issue as well.
> >
> > See this series (not yet applied, you even have chance to review it!):
> > 20260611203537.1786399-1-andriy.shevchenko@linux.intel.com
> 
> I believe that series addresses the first issue, not this one, even
> though it partially mitigates it.
> 
> The contract says "puts a reference to @prev unconditionally." What it
> doesn't say is that it requires @node to be valid, i.e. the function
> is a no-op if node == NULL.
> 
> "node != NULL" being an implicit requirement seems to be the norm for
> the fwnode_* and of_* APIs. It's not explicitly spelled out and Sashiko
> lacks the context for it.
> 
> I'm not sure this should be changed within this patch. It would end up
> as a mismatch between the various functions and possibly lead to more
> confusion.

How does node become invalid after that patch?

> > > > > +             if (fwnode_name_eq(prev, "endpoint"))
> > > >
> > > > [Severity: High]
> > > > Does hardcoding this string match break the fwnode graph abstraction for
> > > > non-DeviceTree platforms?
> > > >
> > > > By strictly matching the "endpoint" prefix, this bypasses the provider-specific
> > > > fwnode_operations, which could silently ignore valid ACPI and software node
> > > > endpoints that don't follow this exact naming scheme. Shouldn't this rely on
> > > > the backend-specific graph_get_next_endpoint operations instead?
> > >
> > > From drivers/acpi/property.c it seems that ACPI graphs follow the same
> > > structure. I don't have visibility into ACPI implementations though.
> >
> > Sashiko might be right. ACPI has device and data nodes, for device nodes the
> > name will be FourCC, so never longer than 4 characters. For data nodes, it
> > takes their names, which are arbitrary strings and seems should follow the given
> > schema. You need Sakari Ailus to review this patch.
> 
> OK. Will add Sakari in the next version.

Hmm... This is interesting. For any fwnode API changes you should add the
respective reviewers. Do you use tools or doing that manually? You should use
tools. I know that `b4` is capable of doing that, but I use a script [1] I
wrote a few years ago.

> > > We also have the following in include/linux/fwnode.h:
> > >
> > > #define SWNODE_GRAPH_PORT_NAME_FMT              "port@%u"
> > > #define SWNODE_GRAPH_ENDPOINT_NAME_FMT          "endpoint@%u"
> > >
> > > So this should not be a problem.
> > >
> > > > > +                     break;
> > > > > +     } while (prev);
> > > > > +
> > > > > +     return prev;
> > > > > +}

[1]: https://github.com/andy-shev/home-bin-tools/blob/master/ge2maintainer.sh

-- 
With Best Regards,
Andy Shevchenko



  reply	other threads:[~2026-07-17 16:33 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-15  8:53 [PATCH v5 00/16] arm64: mediatek: Add M.2 E-key slot on Chromebooks Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 01/16] device property: Add fwnode_graph_get_port_by_id() Chen-Yu Tsai
2026-07-15  9:03   ` sashiko-bot
2026-07-16  5:00     ` Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 02/16] device property: Add fwnode_graph_get_next_port_endpoint() Chen-Yu Tsai
2026-07-15  9:09   ` sashiko-bot
2026-07-16  8:52     ` Chen-Yu Tsai
2026-07-16 21:04       ` Andy Shevchenko
2026-07-17 11:05         ` Chen-Yu Tsai
2026-07-17 16:33           ` Andy Shevchenko [this message]
2026-07-20  3:58             ` Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 03/16] power: sequencing: Add pwrseq_power_is_on() Chen-Yu Tsai
2026-07-15  9:08   ` sashiko-bot
2026-07-15  9:29   ` Andy Shevchenko
2026-07-15 12:10     ` Bartosz Golaszewski
2026-07-16  4:59       ` Chen-Yu Tsai
2026-07-16  8:14         ` Bartosz Golaszewski
2026-07-16  9:39           ` Chen-Yu Tsai
2026-07-16 12:39             ` Bartosz Golaszewski
2026-07-15  8:53 ` [PATCH v5 04/16] usb: hub: Use assign_bit() in usb_hub_set_port_power() Chen-Yu Tsai
2026-07-15  9:11   ` Andy Shevchenko
2026-07-15  8:53 ` [PATCH v5 05/16] usb: hub: Return actual error from hub_configure() in hub_probe() Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 06/16] usb: hub: Associate port@ fwnode with USB port device Chen-Yu Tsai
2026-07-15  9:20   ` Andy Shevchenko
2026-07-16  4:31     ` Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 07/16] usb: core: Move struct usb_port and related APIs to port.h Chen-Yu Tsai
2026-07-15  9:31   ` Andy Shevchenko
2026-07-15  8:53 ` [PATCH v5 08/16] usb: hub: Pass |struct usb_port*| to usb_port_is_power_on() Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 09/16] usb: hub: Use usb_hub_set_port_power() to control port power everywhere Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 10/16] usb: hub: Power on connected M.2 E-key connectors with power sequencing API Chen-Yu Tsai
2026-07-15  9:28   ` sashiko-bot
2026-07-16 10:54     ` Chen-Yu Tsai
2026-07-15 13:25   ` Andy Shevchenko
2026-07-16 10:02     ` Chen-Yu Tsai
2026-07-16 17:34       ` Andy Shevchenko
2026-07-17  8:32         ` Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 11/16] dt-bindings: usb: mediatek,mtk-xhci: Switch to ports for USB connections Chen-Yu Tsai
2026-07-15  8:53 ` [PATCH v5 12/16] power: sequencing: pcie-m2: support matching on remote "port" node Chen-Yu Tsai
2026-07-15  9:29   ` sashiko-bot
2026-07-15  8:53 ` [PATCH v5 13/16] power: sequencing: pcie-m2: Add usb and sdio targets for E-key connector Chen-Yu Tsai
2026-07-15  9:34   ` sashiko-bot
2026-07-15  8:53 ` [PATCH v5 14/16] power: sequencing: pcie-m2: Split Bluetooth unit based on interface Chen-Yu Tsai
2026-07-15  9:34   ` sashiko-bot
2026-07-15  8:53 ` [PATCH v5 15/16] arm64: dts: mediatek: mt8195-cherry: Add M.2 E-key slot Chen-Yu Tsai
2026-07-15  9:45   ` sashiko-bot
2026-07-15  8:53 ` [PATCH v5 16/16] arm64: dts: mediatek: mt8188-geralt: Add WiFi/BT as " Chen-Yu Tsai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpZVUEOidfGMpfD@ashevche-desk.local \
    --to=andriy.shevchenko@linux.intel.com \
    --cc=bartosz.golaszewski@oss.qualcomm.com \
    --cc=devicetree@vger.kernel.org \
    --cc=driver-core@lists.linux.dev \
    --cc=sashiko-reviews@lists.linux.dev \
    --cc=wenst@chromium.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox