Linux filesystem development
 help / color / mirror / Atom feed
* vfs_splice_read()?
@ 2007-07-23 14:39 hooanon05
  0 siblings, 0 replies; only message in thread
From: hooanon05 @ 2007-07-23 14:39 UTC (permalink / raw)
  To: linux-fsdevel


Hello list,

I am developing a filesystem which supports f_op->sendfile.
Recently I noticed, in -git tree, ->sendfile is removed and it should be
replaced by ->splice_read.
If VFS helper for splice_read, like vfs_read(), existed, it had to be
very helpful.

There already exists a static function called do_splice_to() and I'd
like to suggest to rename it to vfs_splice_read() and make it global,
EXPORT_SYMBOL.
If fsdevel members agree with that, I will send a small patch for it.


Junjiro Okajima

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2007-07-23 14:49 UTC | newest]

Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2007-07-23 14:39 vfs_splice_read()? hooanon05

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox