Linux ATA/IDE development
 help / color / mirror / Atom feed
From: Tejun Heo <tj@kernel.org>
To: Dan Williams <dan.j.williams@intel.com>
Cc: JBottomley@Parallels.com, Phillip Susi <psusi@ubuntu.com>,
	Todd Brandt <todd.e.brandt@intel.com>,
	Alan Stern <stern@rowland.harvard.edu>,
	linux-scsi@vger.kernel.org, linux-ide@vger.kernel.org
Subject: Re: [PATCH v5 1/3] libata, libsas: kill pm_result and related cleanup
Date: Mon, 10 Mar 2014 16:44:38 -0400	[thread overview]
Message-ID: <20140310204438.GI25290@htj.dyndns.org> (raw)
In-Reply-To: <20140310202947.GG25290@htj.dyndns.org>

On Mon, Mar 10, 2014 at 04:29:47PM -0400, Tejun Heo wrote:
> Let's please use proper static functions.  The compiler can deal with
> inlining.  Also, maybe ata_port_resume() and ata_port_resume_async()
> are better names for the wrappers?

So, if the suggested names don't jive well with the rest of the
series, my only concern is that none of other ATA functions start with
the verb, so something like ata_port_queue_resume() would be fine too.

Thanks.

-- 
tejun

  reply	other threads:[~2014-03-10 20:44 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-03-05 20:17 [PATCH v5 0/3] Accelerate Storage Resume (2x or more) Dan Williams
2014-03-05 20:17 ` [PATCH v5 1/3] libata, libsas: kill pm_result and related cleanup Dan Williams
2014-03-10 20:29   ` Tejun Heo
2014-03-10 20:44     ` Tejun Heo [this message]
2014-03-05 20:17 ` [PATCH v5 2/3] libata: async resume Dan Williams
2014-12-19 23:46   ` Phillip Susi
2014-12-20  1:42     ` Phillip Susi
2014-03-05 20:17 ` [PATCH v5 3/3] scsi: async sd resume Dan Williams
2014-03-07 15:42   ` Alan Stern
2014-03-08  0:41     ` Dan Williams
2014-03-08  2:52     ` Dan Williams
2014-03-10 15:49       ` Alan Stern
2014-03-10 20:43       ` Tejun Heo
2014-03-10 20:56         ` Dan Williams
2014-03-10 20:59           ` Alan Stern
2014-03-10 21:06             ` Dan Williams
2014-03-10 22:41             ` Phillip Susi
2014-03-11  4:19             ` James Bottomley
2014-03-11  4:47               ` Dan Williams
2014-03-11  5:16                 ` James Bottomley
2014-03-11  5:26                   ` Dan Williams
2014-03-11  6:29                     ` James Bottomley
2014-03-14 20:11                       ` Dan Williams
2014-03-15 21:47                         ` James Bottomley
2014-03-15 23:35                           ` Dan Williams
2014-03-16 18:21                             ` James Bottomley
2014-03-17 18:20                               ` Dan Williams
2014-03-21  0:09                                 ` Dan Williams

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20140310204438.GI25290@htj.dyndns.org \
    --to=tj@kernel.org \
    --cc=JBottomley@Parallels.com \
    --cc=dan.j.williams@intel.com \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=psusi@ubuntu.com \
    --cc=stern@rowland.harvard.edu \
    --cc=todd.e.brandt@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox