From: Nicolin Chen <nicolinc@nvidia.com>
To: Yi Liu <yi.l.liu@intel.com>
Cc: <joro@8bytes.org>, <jgg@nvidia.com>, <kevin.tian@intel.com>,
<baolu.lu@linux.intel.com>, <eric.auger@redhat.com>,
<chao.p.peng@linux.intel.com>, <iommu@lists.linux.dev>,
<vasant.hegde@amd.com>, <will@kernel.org>
Subject: Re: [PATCH v6 04/14] iommufd: Always pass iommu_attach_handle to iommu core
Date: Thu, 19 Dec 2024 22:58:03 -0800 [thread overview]
Message-ID: <Z2UVe/uQfQXUmZ+N@Asurada-Nvidia> (raw)
In-Reply-To: <02e60436-e93d-4452-9446-b0fc6e4c4192@intel.com>
On Fri, Dec 20, 2024 at 02:40:39PM +0800, Yi Liu wrote:
> > > static inline void iommufd_hwpt_detach_device(struct iommufd_hw_pagetable *hwpt,
> > > struct iommufd_device *idev)
> > > {
> > > + struct iommufd_attach_handle *handle;
> > > +
> > > if (hwpt->fault) {
> > > iommufd_fault_domain_detach_dev(hwpt, idev);
> > > return;
> > > }
> > > - iommu_detach_group(hwpt->domain, idev->igroup->group);
> > > + handle = iommufd_device_get_attach_handle(idev);
> > > + iommu_detach_group_handle(hwpt->domain, idev->igroup->group);
> > > + kfree(handle);
> > > }
> > > static inline int iommufd_hwpt_replace_device(struct iommufd_device *idev,
> > > struct iommufd_hw_pagetable *hwpt,
> > > struct iommufd_hw_pagetable *old)
> > > {
> > > + struct iommufd_attach_handle *curr;
> > > + int ret;
> > > +
> > > if (old->fault || hwpt->fault)
> > > return iommufd_fault_domain_replace_dev(idev, hwpt, old);
> > > - return iommu_group_replace_domain(idev->igroup->group, hwpt->domain);
> > > + curr = iommufd_device_get_attach_handle(idev);
> > > +
> > > + ret = iommufd_dev_replace_handle(idev, hwpt, old);
> > > + if (ret)
> > > + return ret;
> >
> > These inline functions feel heavier after this rework..
> >
> > I actually have the same patch for a different reason, yet haven't
> > sent yet:
> > https://github.com/nicolinc/iommufd/commits/wip/iommufd_msi_p1-v1
> > iommu: Turn fault_data to iommufd private pointer
> > =>iommufd: Make attach_handle generic
> >
> > I think we can align with each other on these functions with one
> > common patch: my series requires the fault_data and attach_handle
> > are common to all HWPTs, v.s. exclusive to an hwpt->fault.
>
> yeah, I'm ok to move the helpers to be in device.c to avoid inline.
> I've three remark on your patch [1]. I'm now also considering to do
> the work in one patch, hence it might be better for review w.r.t the
> comment from Baolu [2].
I replied: I moved attach_handle out of fault functions, leaving
them to only handle fault specific routines.
Yet, you might want to fix the iommufd_device_get_attach_handle()
in my patch to a normal function where NULL will be returned upon
an IS_ERR(attach_handle) v.s. just a to_iommufd_handle, which I
just realized a minute ago..
Thanks
Nic
next prev parent reply other threads:[~2024-12-20 6:58 UTC|newest]
Thread overview: 71+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-19 13:27 [PATCH v6 00/14] iommufd support pasid attach/replace Yi Liu
2024-12-19 13:27 ` [PATCH v6 01/14] iommu: Introduce a replace API for device pasid Yi Liu
2024-12-20 2:47 ` Baolu Lu
2025-01-09 7:08 ` Tian, Kevin
2025-01-09 7:20 ` Tian, Kevin
2025-01-09 14:43 ` Jason Gunthorpe
2025-01-10 2:31 ` Baolu Lu
2025-01-10 7:21 ` Tian, Kevin
2025-01-16 10:00 ` Yi Liu
2025-01-13 20:21 ` Jason Gunthorpe
2025-01-14 8:10 ` Tian, Kevin
2025-01-14 13:45 ` Jason Gunthorpe
2025-01-15 4:43 ` Tian, Kevin
2025-01-15 14:43 ` Jason Gunthorpe
2025-01-16 5:48 ` Tian, Kevin
2025-01-17 10:32 ` Yi Liu
2024-12-19 13:27 ` [PATCH v6 02/14] iommufd: Refactor __fault_domain_replace_dev() to be a wrapper of iommu_replace_group_handle() Yi Liu
2024-12-19 13:27 ` [PATCH v6 03/14] iommufd: Move the iommufd_handle helpers to device.c Yi Liu
2024-12-20 3:31 ` Baolu Lu
2024-12-20 6:34 ` Yi Liu
2024-12-19 13:27 ` [PATCH v6 04/14] iommufd: Always pass iommu_attach_handle to iommu core Yi Liu
2024-12-20 4:35 ` Nicolin Chen
2024-12-20 6:40 ` Yi Liu
2024-12-20 6:58 ` Nicolin Chen [this message]
2025-01-09 7:44 ` Tian, Kevin
2025-01-17 12:33 ` Yi Liu
2025-01-17 19:03 ` Nicolin Chen
2024-12-19 13:27 ` [PATCH v6 05/14] iommufd: Pass pasid through the device attach/replace path Yi Liu
2025-01-09 7:53 ` Tian, Kevin
2025-01-09 14:51 ` Jason Gunthorpe
2025-01-10 7:22 ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 06/14] iommufd: Mark PASID-compatible domain Yi Liu
2025-01-09 7:56 ` Tian, Kevin
2025-01-09 14:54 ` Jason Gunthorpe
2025-01-17 10:50 ` Yi Liu
2024-12-19 13:27 ` [PATCH v6 07/14] iommufd: Support pasid attach/replace Yi Liu
2025-01-09 8:25 ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 08/14] iommufd: Enforce PASID-compatible domain for RID Yi Liu
2025-01-09 8:31 ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 09/14] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support Yi Liu
2024-12-23 2:51 ` Baolu Lu
2024-12-24 11:35 ` Yi Liu
2024-12-25 1:02 ` Baolu Lu
2024-12-25 4:30 ` Yi Liu
2024-12-25 7:13 ` Baolu Lu
2025-02-12 7:47 ` Yi Liu
2025-02-12 12:59 ` Jason Gunthorpe
2025-02-13 9:34 ` Yi Liu
2025-02-13 12:56 ` Jason Gunthorpe
2025-02-14 3:24 ` Yi Liu
2025-02-12 13:00 ` Robin Murphy
2025-02-12 13:08 ` Jason Gunthorpe
2025-02-13 10:10 ` Yi Liu
2025-02-13 10:24 ` Robin Murphy
2025-02-13 12:53 ` Yi Liu
2025-02-19 8:02 ` Tian, Kevin
2025-02-19 12:50 ` Yi Liu
2025-02-20 6:57 ` Tian, Kevin
2025-01-09 15:27 ` Jason Gunthorpe
2025-01-10 2:41 ` Baolu Lu
2025-01-10 7:34 ` Tian, Kevin
2025-01-17 10:57 ` Yi Liu
2025-01-10 7:38 ` Tian, Kevin
2025-01-14 8:13 ` Tian, Kevin
2025-01-13 20:31 ` Jason Gunthorpe
2025-01-14 8:19 ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 10/14] iommufd: Allow allocating PASID-compatible domain Yi Liu
2024-12-19 13:27 ` [PATCH v6 11/14] iommufd/selftest: Add set_dev_pasid in mock iommu Yi Liu
2024-12-19 13:27 ` [PATCH v6 12/14] iommufd/selftest: Add a helper to get test device Yi Liu
2024-12-19 13:27 ` [PATCH v6 13/14] iommufd/selftest: Add test ops to test pasid attach/detach Yi Liu
2024-12-19 13:27 ` [PATCH v6 14/14] iommufd/selftest: Add coverage for iommufd " Yi Liu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z2UVe/uQfQXUmZ+N@Asurada-Nvidia \
--to=nicolinc@nvidia.com \
--cc=baolu.lu@linux.intel.com \
--cc=chao.p.peng@linux.intel.com \
--cc=eric.auger@redhat.com \
--cc=iommu@lists.linux.dev \
--cc=jgg@nvidia.com \
--cc=joro@8bytes.org \
--cc=kevin.tian@intel.com \
--cc=vasant.hegde@amd.com \
--cc=will@kernel.org \
--cc=yi.l.liu@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox