Linux IOMMU Development
 help / color / mirror / Atom feed
From: Yi Liu <yi.l.liu@intel.com>
To: Baolu Lu <baolu.lu@linux.intel.com>, <joro@8bytes.org>,
	<jgg@nvidia.com>, <kevin.tian@intel.com>
Cc: <eric.auger@redhat.com>, <nicolinc@nvidia.com>,
	<chao.p.peng@linux.intel.com>, <iommu@lists.linux.dev>,
	<vasant.hegde@amd.com>, <will@kernel.org>
Subject: Re: [PATCH v6 09/14] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support
Date: Tue, 24 Dec 2024 19:35:10 +0800	[thread overview]
Message-ID: <acb2bead-1597-4fdd-b949-26eab2e62b0a@intel.com> (raw)
In-Reply-To: <f4c1ca6a-4ed5-49a7-b399-dd148cfb16bd@linux.intel.com>

On 2024/12/23 10:51, Baolu Lu wrote:
> On 12/19/24 21:27, Yi Liu wrote:
>> Intel iommu driver just treats it as a nop since Intel VT-d does not have
>> special requirement on domains attached to either the PASID or RID of a
>> PASID-capable device.
>>
>> Signed-off-by: Yi Liu <yi.l.liu@intel.com>
>> ---
>>   drivers/iommu/intel/iommu.c  | 3 ++-
>>   drivers/iommu/intel/nested.c | 2 +-
>>   2 files changed, 3 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/iommu/intel/iommu.c b/drivers/iommu/intel/iommu.c
>> index cd5e339fd5bb..0a622a89d876 100644
>> --- a/drivers/iommu/intel/iommu.c
>> +++ b/drivers/iommu/intel/iommu.c
>> @@ -3347,7 +3347,8 @@ intel_iommu_domain_alloc_paging_flags(struct device 
>> *dev, u32 flags,
>>       bool first_stage;
>>       if (flags &
>> -        (~(IOMMU_HWPT_ALLOC_NEST_PARENT | 
>> IOMMU_HWPT_ALLOC_DIRTY_TRACKING)))
>> +        (~(IOMMU_HWPT_ALLOC_NEST_PARENT | IOMMU_HWPT_ALLOC_DIRTY_TRACKING |
>> +           IOMMU_HWPT_ALLOC_PASID)))
>>           return ERR_PTR(-EOPNOTSUPP);
>>       if (nested_parent && !nested_supported(iommu))
>>           return ERR_PTR(-EOPNOTSUPP);
>> diff --git a/drivers/iommu/intel/nested.c b/drivers/iommu/intel/nested.c
>> index aba92c00b427..6ac5c534bef4 100644
>> --- a/drivers/iommu/intel/nested.c
>> +++ b/drivers/iommu/intel/nested.c
>> @@ -198,7 +198,7 @@ intel_iommu_domain_alloc_nested(struct device *dev, 
>> struct iommu_domain *parent,
>>       struct dmar_domain *domain;
>>       int ret;
>> -    if (!nested_supported(iommu) || flags)
>> +    if (!nested_supported(iommu) || flags & ~IOMMU_HWPT_ALLOC_PASID)
>>           return ERR_PTR(-EOPNOTSUPP);
>>       /* Must be nested domain */
> 
> It's better to abort and fail a domain allocation when
> IOMMU_HWPT_ALLOC_PASID is set but the iommu lacks pasid support?

in concept, yes.

> Another related consideration is the support for page faults in nested
> domains once PASID is available in user space. Would it be reasonable to
> support page faults for nested domains?

yeah, it's good to discuss it.

> If so, perhaps it's time to open intel_iommu_domain_alloc_nested() to
> support IOMMU_HWPT_FAULT_ID_VALID when PRI is enabled on the device?

IMHO, the PRQ support for nested domains requires some more facility. PRQ
can happen at either stage-1 or stage-2, iommu driver may need to tell
it and forward to the correct domain (nested domain or parent domain). Or
the stage-2 is always pinned just as the VFIO/iommufd does. Hence, any PRQ
happens under nested translation should be due to stage-1.

-- 
Regards,
Yi Liu

  reply	other threads:[~2024-12-24 11:30 UTC|newest]

Thread overview: 71+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-12-19 13:27 [PATCH v6 00/14] iommufd support pasid attach/replace Yi Liu
2024-12-19 13:27 ` [PATCH v6 01/14] iommu: Introduce a replace API for device pasid Yi Liu
2024-12-20  2:47   ` Baolu Lu
2025-01-09  7:08   ` Tian, Kevin
2025-01-09  7:20   ` Tian, Kevin
2025-01-09 14:43     ` Jason Gunthorpe
2025-01-10  2:31       ` Baolu Lu
2025-01-10  7:21         ` Tian, Kevin
2025-01-16 10:00           ` Yi Liu
2025-01-13 20:21   ` Jason Gunthorpe
2025-01-14  8:10     ` Tian, Kevin
2025-01-14 13:45       ` Jason Gunthorpe
2025-01-15  4:43         ` Tian, Kevin
2025-01-15 14:43           ` Jason Gunthorpe
2025-01-16  5:48             ` Tian, Kevin
2025-01-17 10:32               ` Yi Liu
2024-12-19 13:27 ` [PATCH v6 02/14] iommufd: Refactor __fault_domain_replace_dev() to be a wrapper of iommu_replace_group_handle() Yi Liu
2024-12-19 13:27 ` [PATCH v6 03/14] iommufd: Move the iommufd_handle helpers to device.c Yi Liu
2024-12-20  3:31   ` Baolu Lu
2024-12-20  6:34     ` Yi Liu
2024-12-19 13:27 ` [PATCH v6 04/14] iommufd: Always pass iommu_attach_handle to iommu core Yi Liu
2024-12-20  4:35   ` Nicolin Chen
2024-12-20  6:40     ` Yi Liu
2024-12-20  6:58       ` Nicolin Chen
2025-01-09  7:44   ` Tian, Kevin
2025-01-17 12:33     ` Yi Liu
2025-01-17 19:03       ` Nicolin Chen
2024-12-19 13:27 ` [PATCH v6 05/14] iommufd: Pass pasid through the device attach/replace path Yi Liu
2025-01-09  7:53   ` Tian, Kevin
2025-01-09 14:51     ` Jason Gunthorpe
2025-01-10  7:22       ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 06/14] iommufd: Mark PASID-compatible domain Yi Liu
2025-01-09  7:56   ` Tian, Kevin
2025-01-09 14:54   ` Jason Gunthorpe
2025-01-17 10:50     ` Yi Liu
2024-12-19 13:27 ` [PATCH v6 07/14] iommufd: Support pasid attach/replace Yi Liu
2025-01-09  8:25   ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 08/14] iommufd: Enforce PASID-compatible domain for RID Yi Liu
2025-01-09  8:31   ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 09/14] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support Yi Liu
2024-12-23  2:51   ` Baolu Lu
2024-12-24 11:35     ` Yi Liu [this message]
2024-12-25  1:02       ` Baolu Lu
2024-12-25  4:30         ` Yi Liu
2024-12-25  7:13           ` Baolu Lu
2025-02-12  7:47             ` Yi Liu
2025-02-12 12:59               ` Jason Gunthorpe
2025-02-13  9:34                 ` Yi Liu
2025-02-13 12:56                   ` Jason Gunthorpe
2025-02-14  3:24                     ` Yi Liu
2025-02-12 13:00               ` Robin Murphy
2025-02-12 13:08                 ` Jason Gunthorpe
2025-02-13 10:10                 ` Yi Liu
2025-02-13 10:24                   ` Robin Murphy
2025-02-13 12:53                     ` Yi Liu
2025-02-19  8:02                     ` Tian, Kevin
2025-02-19 12:50                       ` Yi Liu
2025-02-20  6:57                         ` Tian, Kevin
2025-01-09 15:27     ` Jason Gunthorpe
2025-01-10  2:41       ` Baolu Lu
2025-01-10  7:34         ` Tian, Kevin
2025-01-17 10:57           ` Yi Liu
2025-01-10  7:38   ` Tian, Kevin
2025-01-14  8:13     ` Tian, Kevin
2025-01-13 20:31   ` Jason Gunthorpe
2025-01-14  8:19     ` Tian, Kevin
2024-12-19 13:27 ` [PATCH v6 10/14] iommufd: Allow allocating PASID-compatible domain Yi Liu
2024-12-19 13:27 ` [PATCH v6 11/14] iommufd/selftest: Add set_dev_pasid in mock iommu Yi Liu
2024-12-19 13:27 ` [PATCH v6 12/14] iommufd/selftest: Add a helper to get test device Yi Liu
2024-12-19 13:27 ` [PATCH v6 13/14] iommufd/selftest: Add test ops to test pasid attach/detach Yi Liu
2024-12-19 13:27 ` [PATCH v6 14/14] iommufd/selftest: Add coverage for iommufd " Yi Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=acb2bead-1597-4fdd-b949-26eab2e62b0a@intel.com \
    --to=yi.l.liu@intel.com \
    --cc=baolu.lu@linux.intel.com \
    --cc=chao.p.peng@linux.intel.com \
    --cc=eric.auger@redhat.com \
    --cc=iommu@lists.linux.dev \
    --cc=jgg@nvidia.com \
    --cc=joro@8bytes.org \
    --cc=kevin.tian@intel.com \
    --cc=nicolinc@nvidia.com \
    --cc=vasant.hegde@amd.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox