From: Nicolin Chen <nicolinc@nvidia.com>
To: Yi Liu <yi.l.liu@intel.com>
Cc: <kevin.tian@intel.com>, <jgg@nvidia.com>, <joro@8bytes.org>,
<baolu.lu@linux.intel.com>, <iommu@lists.linux.dev>
Subject: Re: [PATCH v10 17/18] iommufd/selftest: Add test ops to test pasid attach/detach
Date: Thu, 20 Mar 2025 16:42:45 -0700 [thread overview]
Message-ID: <Z9yn9c46eyz4kkpt@Asurada-Nvidia> (raw)
In-Reply-To: <Z9yiIEaWyMGyyc2A@Asurada-Nvidia>
On Thu, Mar 20, 2025 at 04:17:58PM -0700, Nicolin Chen wrote:
> On Thu, Mar 20, 2025 at 06:47:43AM -0700, Yi Liu wrote:
> > +static int iommufd_test_pasid_check_domain(struct iommufd_ucmd *ucmd,
> > + struct iommu_test_cmd *cmd)
> > +{
> > + struct iommu_domain *attached_domain, *expect_domain = NULL;
> > + struct iommufd_hw_pagetable *hwpt = NULL;
> > + struct iommu_attach_handle *handle;
> > + struct selftest_obj *sobj;
> > + struct mock_dev *mdev;
> > + bool result;
> > + int rc = 0;
> > +
> > + sobj = iommufd_test_get_selftest_obj(ucmd->ictx, cmd->id);
> > + if (IS_ERR(sobj))
> > + return PTR_ERR(sobj);
> > +
> > + mdev = sobj->idev.mock_dev;
> > +
> > + handle = iommu_attach_handle_get(mdev->dev.iommu_group,
> > + cmd->pasid_check.pasid, 0);
> > + if (IS_ERR(handle))
> > + attached_domain = NULL;
> > + else
> > + attached_domain = handle->domain;
> > +
> > + if (cmd->pasid_check.hwpt_id) {
> > + hwpt = iommufd_get_hwpt(ucmd, cmd->pasid_check.hwpt_id);
> > + if (IS_ERR(hwpt)) {
>
> Do we need cmd->pasid_check.hwpt_id to be optional?
Okay. After reading PATCH-18, it looks like what we want is to
verify whether the hwpt is detached or not using hwpt_id=0.
Similar to check_iotlb() and check_cache(), I think this can be:
/* hwpt_id=0 is to check whether pasid is detached or not */
if (!attached_domain && !cmd->pasid_check.hwpt_id)
goto put_and_return_0;
hwpt = iommufd_get_hwpt(ucmd, cmd->pasid_check.hwpt_id);
if (IS_ERR())
goto put_and_return_PTR_ERR;
if (hwpt->domain != attached_domain)
rc = -EINVAL;
Also, given that we pass in hwpt_id, let's call it:
iommufd_test_pasid_check_hwpt/IOMMU_TEST_OP_PASID_CHECK_HWPT?
Thanks
Nicolin
next prev parent reply other threads:[~2025-03-20 23:43 UTC|newest]
Thread overview: 78+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-20 13:47 [PATCH v10 00/18] iommufd support pasid attach/replace Yi Liu
2025-03-20 13:47 ` [PATCH v10 01/18] iommu: Require passing new handles to APIs supporting handle Yi Liu
2025-03-20 15:23 ` Jason Gunthorpe
2025-03-20 23:51 ` Yi Liu
2025-03-21 2:35 ` Baolu Lu
2025-03-20 13:47 ` [PATCH v10 02/18] iommu: Introduce a replace API for device pasid Yi Liu
2025-03-20 17:24 ` Nicolin Chen
2025-03-20 23:58 ` Yi Liu
2025-03-21 0:14 ` Yi Liu
2025-03-21 3:21 ` Nicolin Chen
2025-03-21 4:06 ` Yi Liu
2025-03-21 3:08 ` Baolu Lu
2025-03-21 4:19 ` Yi Liu
2025-03-20 13:47 ` [PATCH v10 03/18] iommufd: Pass @pasid through the device attach/replace path Yi Liu
2025-03-21 3:13 ` Baolu Lu
2025-03-20 13:47 ` [PATCH v10 04/18] iommufd/device: Only add reserved_iova in non-pasid path Yi Liu
2025-03-21 3:14 ` Baolu Lu
2025-03-20 13:47 ` [PATCH v10 05/18] iommufd/device: Replace idev->igroup with local variable Yi Liu
2025-03-21 3:14 ` Baolu Lu
2025-03-20 13:47 ` [PATCH v10 06/18] iommufd/device: Add helper to detect the first attach of a group Yi Liu
2025-03-20 15:36 ` Jason Gunthorpe
2025-03-20 17:36 ` Nicolin Chen
2025-03-20 17:51 ` Nicolin Chen
2025-03-21 0:02 ` Yi Liu
2025-03-20 18:04 ` Jason Gunthorpe
2025-03-20 18:24 ` Nicolin Chen
2025-03-21 3:18 ` Baolu Lu
2025-03-20 13:47 ` [PATCH v10 07/18] iommufd/device: Wrap igroup->hwpt and igroup->device_list into attach struct Yi Liu
2025-03-20 15:48 ` Jason Gunthorpe
2025-03-20 18:03 ` Nicolin Chen
2025-03-21 3:22 ` Baolu Lu
2025-03-20 13:47 ` [PATCH v10 08/18] iommufd/device: Replace device_list with device_array Yi Liu
2025-03-20 17:20 ` Jason Gunthorpe
2025-03-21 0:25 ` Yi Liu
2025-03-20 18:38 ` Nicolin Chen
2025-03-21 0:30 ` Yi Liu
2025-03-21 3:25 ` Nicolin Chen
2025-03-20 13:47 ` [PATCH v10 09/18] iommufd/device: Add pasid_attach array to track per-PASID attach Yi Liu
2025-03-20 17:33 ` Jason Gunthorpe
2025-03-20 19:19 ` Nicolin Chen
2025-03-20 19:29 ` Jason Gunthorpe
2025-03-20 20:13 ` Nicolin Chen
2025-03-21 0:15 ` Yi Liu
2025-03-20 13:47 ` [PATCH v10 10/18] iommufd: Enforce PASID-compatible domain in PASID path Yi Liu
2025-03-20 13:47 ` [PATCH v10 11/18] iommufd: Support pasid attach/replace Yi Liu
2025-03-20 20:42 ` Nicolin Chen
2025-03-20 23:29 ` Jason Gunthorpe
2025-03-21 0:31 ` Yi Liu
2025-03-21 0:35 ` Nicolin Chen
2025-03-21 1:05 ` Yi Liu
2025-03-21 11:45 ` Jason Gunthorpe
2025-03-20 13:47 ` [PATCH v10 12/18] iommufd: Enforce PASID-compatible domain for RID Yi Liu
2025-03-20 17:35 ` Jason Gunthorpe
2025-03-20 22:23 ` Nicolin Chen
2025-03-20 23:31 ` Jason Gunthorpe
2025-03-21 0:45 ` Yi Liu
2025-03-21 0:41 ` Yi Liu
2025-03-20 13:47 ` [PATCH v10 13/18] iommu/vt-d: Add IOMMU_HWPT_ALLOC_PASID support Yi Liu
2025-03-20 13:47 ` [PATCH v10 14/18] iommufd: Allow allocating PASID-compatible domain Yi Liu
2025-03-20 17:51 ` Jason Gunthorpe
2025-03-21 0:52 ` Yi Liu
2025-03-20 22:36 ` Nicolin Chen
2025-03-20 13:47 ` [PATCH v10 15/18] iommufd/selftest: Add set_dev_pasid in mock iommu Yi Liu
2025-03-20 22:48 ` Nicolin Chen
2025-03-20 13:47 ` [PATCH v10 16/18] iommufd/selftest: Add a helper to get test device Yi Liu
2025-03-20 13:47 ` [PATCH v10 17/18] iommufd/selftest: Add test ops to test pasid attach/detach Yi Liu
2025-03-20 23:17 ` Nicolin Chen
2025-03-20 23:33 ` Jason Gunthorpe
2025-03-20 23:42 ` Nicolin Chen [this message]
2025-03-21 1:43 ` Yi Liu
2025-03-21 17:25 ` Nicolin Chen
2025-03-20 23:20 ` Nicolin Chen
2025-03-21 1:20 ` Yi Liu
2025-03-20 13:47 ` [PATCH v10 18/18] iommufd/selftest: Add coverage for iommufd " Yi Liu
2025-03-21 0:34 ` Nicolin Chen
2025-03-21 15:26 ` Yi Liu
2025-03-21 17:10 ` Nicolin Chen
2025-03-20 13:59 ` [PATCH v10 00/18] iommufd support pasid attach/replace Yi Liu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z9yn9c46eyz4kkpt@Asurada-Nvidia \
--to=nicolinc@nvidia.com \
--cc=baolu.lu@linux.intel.com \
--cc=iommu@lists.linux.dev \
--cc=jgg@nvidia.com \
--cc=joro@8bytes.org \
--cc=kevin.tian@intel.com \
--cc=yi.l.liu@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox