From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: Yong Zhi <yong.zhi@intel.com>, Bingbu Cao <bingbu.cao@intel.com>,
Tian Shu Qiu <tian.shu.qiu@intel.com>,
linux-media@vger.kernel.org,
Mauro Carvalho Chehab <mchehab@kernel.org>
Subject: Re: [PATCH v1 2/7] media: ipu3-cio2: Introduce CIO2_MAX_ENTRIES constant
Date: Mon, 17 Aug 2020 14:46:46 +0300 [thread overview]
Message-ID: <20200817114646.GL1891694@smile.fi.intel.com> (raw)
In-Reply-To: <20200814201836.GF24582@paasikivi.fi.intel.com>
On Fri, Aug 14, 2020 at 11:18:36PM +0300, Sakari Ailus wrote:
> On Fri, Aug 14, 2020 at 07:30:12PM +0300, Andy Shevchenko wrote:
> > This constant is used in several places in the code, define it
> > for better maintenance.
...
> > +#define CIO2_MAX_ENTRIES (PAGE_SIZE / sizeof(u32))
>
> How about calling this CIO2_ENTRIES_PER_LOP (or CIO2_LOP_ENTRIES) instead?
Sure. (I like the latter).
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2020-08-17 11:46 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-08-14 16:30 [PATCH v1 1/7] media: ipu3-cio2: Simplify cleanup code Andy Shevchenko
2020-08-14 16:30 ` [PATCH v1 2/7] media: ipu3-cio2: Introduce CIO2_MAX_ENTRIES constant Andy Shevchenko
2020-08-14 20:18 ` Sakari Ailus
2020-08-17 11:46 ` Andy Shevchenko [this message]
2020-08-14 16:30 ` [PATCH v1 3/7] media: ipu2-cio2: Replace custom definition with PAGE_SIZE Andy Shevchenko
2020-08-14 16:30 ` [PATCH v1 4/7] media: ipu3-cio2: Use macros from pfn.h Andy Shevchenko
2020-08-14 16:30 ` [PATCH v1 5/7] media: ipu3-cio2: Replace infinite loop by one with clear exit condition Andy Shevchenko
2020-08-17 10:21 ` Bingbu Cao
2020-08-17 11:47 ` Andy Shevchenko
2020-08-14 16:30 ` [PATCH v1 6/7] media: ipu3-cio2: Use readl_poll_timeout() helper Andy Shevchenko
2020-08-17 9:27 ` Bingbu Cao
2020-08-17 9:44 ` Andy Shevchenko
2020-08-17 11:13 ` Sakari Ailus
2020-08-17 11:20 ` Andy Shevchenko
2020-08-17 11:27 ` Sakari Ailus
2020-08-17 11:33 ` Andy Shevchenko
2020-08-17 11:55 ` Sakari Ailus
2020-08-17 12:29 ` Andy Shevchenko
2020-08-17 12:44 ` Sakari Ailus
2020-08-14 16:30 ` [PATCH v1 7/7] media: ipu3-cio2: Update Copyright year and fix indentation issues Andy Shevchenko
2020-08-14 20:16 ` [PATCH v1 1/7] media: ipu3-cio2: Simplify cleanup code Sakari Ailus
2020-08-17 14:37 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200817114646.GL1891694@smile.fi.intel.com \
--to=andriy.shevchenko@linux.intel.com \
--cc=bingbu.cao@intel.com \
--cc=linux-media@vger.kernel.org \
--cc=mchehab@kernel.org \
--cc=sakari.ailus@linux.intel.com \
--cc=tian.shu.qiu@intel.com \
--cc=yong.zhi@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox