Linux Media Controller development
 help / color / mirror / Atom feed
From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: linux-media@vger.kernel.org, hans@jjverkuil.nl,
	Prabhakar <prabhakar.csengg@gmail.com>,
	"Kate Hsuan" <hpa@redhat.com>,
	"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
	"Tommaso Merciai" <tomm.merciai@gmail.com>,
	"Benjamin Mugnier" <benjamin.mugnier@foss.st.com>,
	"Sylvain Petinot" <sylvain.petinot@foss.st.com>,
	"Christophe JAILLET" <christophe.jaillet@wanadoo.fr>,
	"Julien Massot" <julien.massot@collabora.com>,
	"Naushir Patuck" <naush@raspberrypi.com>,
	"Yan, Dongcheng" <dongcheng.yan@intel.com>,
	"Stefan Klug" <stefan.klug@ideasonboard.com>,
	"Mirela Rabulea" <mirela.rabulea@nxp.com>,
	"André Apitzsch" <git@apitzsch.eu>,
	"Heimir Thor Sverrisson" <heimir.sverrisson@gmail.com>,
	"Kieran Bingham" <kieran.bingham@ideasonboard.com>,
	"Mehdi Djait" <mehdi.djait@linux.intel.com>,
	"Ricardo Ribalda Delgado" <ribalda@kernel.org>,
	"Hans de Goede" <hansg@kernel.org>,
	"Jacopo Mondi" <jacopo.mondi@ideasonboard.com>,
	"Tomi Valkeinen" <tomi.valkeinen@ideasonboard.com>,
	"David Plowman" <david.plowman@raspberrypi.com>,
	"Yu, Ong Hock" <ong.hock.yu@intel.com>,
	"Ng, Khai Wen" <khai.wen.ng@intel.com>,
	"Jai Luthra" <jai.luthra@ideasonboard.com>,
	"Rishikesh Donadkar" <r-donadkar@ti.com>
Subject: Re: [PATCH v6 09/16] media: v4l2-subdev: Always call get_fmt() if set_fmt() is unavailable
Date: Mon, 20 Jul 2026 11:29:47 +0300	[thread overview]
Message-ID: <20260720082947.GA3679@killaraus.ideasonboard.com> (raw)
In-Reply-To: <al3Ry7tmWX0dnVpz@kekkonen.localdomain>

On Mon, Jul 20, 2026 at 10:44:11AM +0300, Sakari Ailus wrote:
> On Mon, Jul 20, 2026 at 09:53:37AM +0300, Laurent Pinchart wrote:
> > On Wed, Jul 01, 2026 at 03:26:26PM +0300, Sakari Ailus wrote:
> > > Many drivers implement set_fmt() pad op that simply returns the format
> > > just as get_fmt() would do, usually because the driver only supports a
> > > single one. As a driver should always implement set_fmt() either on its
> > > own or via get_fmt(), call get_fmt() in case set_fmt() isn't implemented
> > > by the driver. This allows removing a fair amount of boilerplate code as
> > > well as ensures that set_fmt() works whenever get_fmt() does.
> > > 
> > > Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> > > ---
> > >  drivers/media/v4l2-core/v4l2-subdev.c | 7 +++++--
> > >  1 file changed, 5 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/drivers/media/v4l2-core/v4l2-subdev.c b/drivers/media/v4l2-core/v4l2-subdev.c
> > > index 86be4d51c9a5..c2be59e4c4a7 100644
> > > --- a/drivers/media/v4l2-core/v4l2-subdev.c
> > > +++ b/drivers/media/v4l2-core/v4l2-subdev.c
> > > @@ -260,8 +260,11 @@ static int call_set_fmt(struct v4l2_subdev *sd,
> > >  			struct v4l2_subdev_state *state,
> > >  			struct v4l2_subdev_format *format)
> > >  {
> > > -	return do_subdev_call(sd, check_format(sd, state, format), pad, set_fmt,
> > > -			      state, format);
> > > +	return check_format(sd, state, format) ? :
> > > +		sd->ops->pad->set_fmt ?
> > > +		sd->ops->pad->set_fmt(sd, state, format) :
> > > +		sd->ops->pad->get_fmt ?
> > > +		sd->ops->pad->get_fmt(sd, state, format) : -ENOIOCTLCMD;
> > 
> > This changes the behaviour: if neither operations are implemented, and
> > the format check fails, userspace will get an error from check_format()
> > instead of -ENOIOCTLCMD. It's probably not an issue in practice, but...
> 
> Indeed, that needs to be addressed.
> 
> > Also, the code becomes really unreadable.
> 
> I guess it's up to the reader; similar patterns are also used elsewhere in
> the file -- and I don't think I've written them. :-) I'm fine with the code
> you suggested below, too, and I'll use it for v7.

Thank you.

> > 
> > 	int ret;
> > 
> > 	ret = check_format(sd, state, format);
> > 	if (ret)
> > 		return ret;
> > 
> > 	if (sd->ops->pad->set_fmt)
> > 		return sd->ops->pad->set_fmt(sd, state, format);
> > 	if (sd->ops->pad->get_fmt)
> > 		return sd->ops->pad->get_fmt(sd, state, format);
> > 
> > 	return -ENOIOCTLCMD;
> > 
> > There's no tax on the number of lines of code.
> > 
> > If you want to avoid changing the behaviour, write
> > 
> > 	int ret;
> > 
> > 	if (!sd->ops->pad->set_fmt && !sd->ops->pad->get_fmt)
> > 		return -ENOIOCTLCMD;
> > 
> > 	ret = check_format(sd, state, format);
> > 	if (ret)
> > 		return ret;
> > 
> > 	if (sd->ops->pad->set_fmt)
> > 		return sd->ops->pad->set_fmt(sd, state, format);
> > 	else
> 
> This else isn't useful.

It's not required, but I find it useful as it more clearly conveys the
meaning here: if the set_fmt operation exists, call it, otherwise, call
get_fmt. I think it's different than a

 	if (sd->ops->pad->set_fmt)
 		return sd->ops->pad->set_fmt(sd, state, format);

	return -ENOIOCTLCMD;

where the last statement is a "catch all".

> > 		return sd->ops->pad->get_fmt(sd, state, format);
> > 
> > Re-reading patch 08/16, I think it would also be more readable without
> > quite a few of the ternary operators. I'll leave that one up to you as
> > the code is already hard to read before 08/16.

-- 
Regards,

Laurent Pinchart

  reply	other threads:[~2026-07-20  8:29 UTC|newest]

Thread overview: 132+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-07 21:53 [PATCH v5 00/10] Metadata series preparation Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 01/10] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 02/10] media: imx219: Scale the vblank limits according to rate_factor Sakari Ailus
2026-06-08  7:26   ` Laurent Pinchart
2026-06-08 15:29   ` Dave Stevenson
2026-06-08 21:28     ` Laurent Pinchart
2026-06-09  5:58       ` Jai Luthra
2026-06-09  6:01         ` Jai Luthra
2026-06-10 11:48           ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 03/10] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-06-07 22:05   ` sashiko-bot
2026-06-08  9:06   ` Laurent Pinchart
2026-06-08 13:44     ` Sakari Ailus
2026-06-08 15:42   ` Dave Stevenson
2026-06-08 21:38     ` Laurent Pinchart
2026-06-18 10:40     ` Sakari Ailus
2026-07-02 17:04       ` Dave Stevenson
2026-07-03 21:36         ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 04/10] media: imx219: Make control handler ops for PIXEL_RATE NULL Sakari Ailus
2026-06-08  7:36   ` Laurent Pinchart
2026-06-08  7:53     ` Jacopo Mondi
2026-06-08  8:03       ` Laurent Pinchart
2026-06-08  8:14         ` Sakari Ailus
2026-06-08  8:24           ` Laurent Pinchart
2026-06-08 10:21             ` Sakari Ailus
2026-06-08 10:27               ` Laurent Pinchart
2026-06-08 13:47                 ` Sakari Ailus
2026-06-08 14:42                   ` Laurent Pinchart
2026-06-09  6:29                     ` Jacopo Mondi
2026-06-09 14:55                       ` Hans Verkuil
2026-06-09 15:15                         ` Laurent Pinchart
2026-06-09 15:56                           ` Dave Stevenson
2026-06-09 16:07                             ` Laurent Pinchart
2026-06-09 16:44                               ` Dave Stevenson
2026-06-07 21:53 ` [PATCH v5 05/10] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-06-08 15:45   ` Dave Stevenson
2026-06-07 21:53 ` [PATCH v5 06/10] media: imx219: Fix vertical blanking and exposure for analogue binning Sakari Ailus
2026-06-07 22:07   ` sashiko-bot
2026-06-08  6:58   ` Jacopo Mondi
2026-06-08  9:10     ` Laurent Pinchart
2026-06-08 14:07       ` Sakari Ailus
2026-06-08 16:23         ` Jai Luthra
2026-06-08 21:52           ` Laurent Pinchart
2026-06-10  8:27             ` Sakari Ailus
2026-06-10  8:45               ` Jai Luthra
2026-06-08 10:31     ` Jai Luthra
2026-06-08 11:19       ` Jai Luthra
2026-06-10  9:47         ` Sakari Ailus
2026-06-10 10:29           ` Jai Luthra
2026-06-10 10:57             ` Jai Luthra
2026-06-11  8:58             ` Sakari Ailus
2026-06-08 18:06       ` Dave Stevenson
2026-06-09 16:48         ` Jai Luthra
2026-06-10 10:30           ` Sakari Ailus
2026-06-10 11:59             ` Jai Luthra
2026-06-10 10:13         ` Sakari Ailus
2026-06-10 16:00           ` Jai Luthra
2026-06-08 21:01       ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 07/10] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-06-08  9:29   ` Laurent Pinchart
2026-06-08 14:28     ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 08/10] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-06-08  9:34   ` Laurent Pinchart
2026-06-08 14:35     ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 09/10] media: v4l2-subdev: Add v4l2_subdev_get_fmt_ci() Sakari Ailus
2026-06-08  7:48   ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 10/10] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
2026-06-08 10:16   ` Laurent Pinchart
2026-06-28 14:20     ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 00/16] Metadata series preparation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 01/16] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 02/16] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-07-02 17:10   ` Dave Stevenson
2026-07-16 13:45   ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 03/16] media: imx219: Account for rate_factor in control steps Sakari Ailus
2026-07-02 17:09   ` Dave Stevenson
2026-07-17 14:21   ` Laurent Pinchart
2026-07-19 21:00     ` Sakari Ailus
2026-07-20  5:52       ` Laurent Pinchart
2026-07-20  7:15         ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 04/16] media: imx219: The horizontal blanking step is 8 Sakari Ailus
2026-07-02 13:57   ` Dave Stevenson
2026-07-20  6:28   ` Laurent Pinchart
2026-07-20  7:17     ` Sakari Ailus
2026-07-20  8:30       ` Laurent Pinchart
2026-07-20  8:37         ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 05/16] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 06/16] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-07-20  6:34   ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 07/16] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-07-01 16:17   ` Frank Li
2026-07-20  6:35   ` Laurent Pinchart
2026-07-20  7:20     ` Sakari Ailus
2026-07-20  8:31       ` Laurent Pinchart
2026-07-20  8:39         ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 08/16] media: v4l2-subdev: Move op check to sub-device op wrappers Sakari Ailus
2026-07-01 16:37   ` Frank Li
2026-07-04 12:11     ` Sakari Ailus
2026-07-20  6:45   ` Laurent Pinchart
2026-07-20  6:45     ` Laurent Pinchart
2026-07-20  7:22       ` Sakari Ailus
2026-07-20  7:30         ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 09/16] media: v4l2-subdev: Always call get_fmt() if set_fmt() is unavailable Sakari Ailus
2026-07-01 16:42   ` Frank Li
2026-07-04 12:15     ` Sakari Ailus
2026-07-20  6:53   ` Laurent Pinchart
2026-07-20  7:44     ` Sakari Ailus
2026-07-20  8:29       ` Laurent Pinchart [this message]
2026-07-20  8:36         ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 10/16] media: rdacm20: Don't assign set_fmt() Sakari Ailus
2026-07-20  7:31   ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 11/16] " Sakari Ailus
2026-07-20  7:31   ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 12/16] media: gc0310: " Sakari Ailus
2026-07-20  7:32   ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 13/16] media: v4l2-subdev: Add v4l2_subdev_call_ci_state_{active,try} Sakari Ailus
2026-07-01 16:57   ` Frank Li
2026-07-04 12:16     ` Sakari Ailus
2026-07-20  8:45   ` Laurent Pinchart
2026-07-20  8:51     ` Sakari Ailus
2026-07-20 12:46       ` Laurent Pinchart
2026-07-20 14:13         ` Sakari Ailus
2026-07-20 14:37           ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 14/16] media: mt9m001: Pass sub-device state to set_selection() callback Sakari Ailus
2026-07-20  7:00   ` Laurent Pinchart
2026-07-20  7:05     ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 15/16] media: cvs: Drop comments on sub-device operations Sakari Ailus
2026-07-20  7:33   ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 15/15] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
2026-07-01 17:00   ` Frank Li
2026-07-01 12:26 ` [PATCH v6 16/16] " Sakari Ailus
2026-07-01 17:01   ` Frank Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260720082947.GA3679@killaraus.ideasonboard.com \
    --to=laurent.pinchart@ideasonboard.com \
    --cc=benjamin.mugnier@foss.st.com \
    --cc=christophe.jaillet@wanadoo.fr \
    --cc=dave.stevenson@raspberrypi.com \
    --cc=david.plowman@raspberrypi.com \
    --cc=dongcheng.yan@intel.com \
    --cc=git@apitzsch.eu \
    --cc=hans@jjverkuil.nl \
    --cc=hansg@kernel.org \
    --cc=heimir.sverrisson@gmail.com \
    --cc=hpa@redhat.com \
    --cc=jacopo.mondi@ideasonboard.com \
    --cc=jai.luthra@ideasonboard.com \
    --cc=julien.massot@collabora.com \
    --cc=khai.wen.ng@intel.com \
    --cc=kieran.bingham@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=mehdi.djait@linux.intel.com \
    --cc=mirela.rabulea@nxp.com \
    --cc=naush@raspberrypi.com \
    --cc=ong.hock.yu@intel.com \
    --cc=prabhakar.csengg@gmail.com \
    --cc=r-donadkar@ti.com \
    --cc=ribalda@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    --cc=stefan.klug@ideasonboard.com \
    --cc=sylvain.petinot@foss.st.com \
    --cc=tomi.valkeinen@ideasonboard.com \
    --cc=tomm.merciai@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox