From: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: linux-media@vger.kernel.org, hans@jjverkuil.nl,
Prabhakar <prabhakar.csengg@gmail.com>,
"Kate Hsuan" <hpa@redhat.com>,
"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
"Tommaso Merciai" <tomm.merciai@gmail.com>,
"Benjamin Mugnier" <benjamin.mugnier@foss.st.com>,
"Sylvain Petinot" <sylvain.petinot@foss.st.com>,
"Christophe JAILLET" <christophe.jaillet@wanadoo.fr>,
"Julien Massot" <julien.massot@collabora.com>,
"Naushir Patuck" <naush@raspberrypi.com>,
"Yan, Dongcheng" <dongcheng.yan@intel.com>,
"Stefan Klug" <stefan.klug@ideasonboard.com>,
"Mirela Rabulea" <mirela.rabulea@nxp.com>,
"André Apitzsch" <git@apitzsch.eu>,
"Heimir Thor Sverrisson" <heimir.sverrisson@gmail.com>,
"Kieran Bingham" <kieran.bingham@ideasonboard.com>,
"Mehdi Djait" <mehdi.djait@linux.intel.com>,
"Ricardo Ribalda Delgado" <ribalda@kernel.org>,
"Hans de Goede" <hansg@kernel.org>,
"Jacopo Mondi" <jacopo.mondi@ideasonboard.com>,
"Tomi Valkeinen" <tomi.valkeinen@ideasonboard.com>,
"David Plowman" <david.plowman@raspberrypi.com>,
"Yu, Ong Hock" <ong.hock.yu@intel.com>,
"Ng, Khai Wen" <khai.wen.ng@intel.com>,
"Jai Luthra" <jai.luthra@ideasonboard.com>,
"Rishikesh Donadkar" <r-donadkar@ti.com>
Subject: Re: [PATCH v6 13/16] media: v4l2-subdev: Add v4l2_subdev_call_ci_state_{active,try}
Date: Mon, 20 Jul 2026 11:45:53 +0300 [thread overview]
Message-ID: <20260720084553.GD3679@killaraus.ideasonboard.com> (raw)
In-Reply-To: <20260701122634.1728782-13-sakari.ailus@linux.intel.com>
Hi Sakari,
Thank you for the patch.
On Wed, Jul 01, 2026 at 03:26:30PM +0300, Sakari Ailus wrote:
> Add v4l2_subdev_call_ci_state_active(), and
> v4l2_subdev_call_ci_state_try() to call sub-device pad ops that
> take struct v4l2_subdev_client_info pointer as an argument. These ops
> cannot be called using v4l2_subdev_call_state_active() or
> v4l2_subdev_call_state_try() as the client_info argument precedes the
> state argument.
Is there a reason why the state argument can't go first ? This patch
then wouldn't be needed.
> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> ---
> include/media/v4l2-subdev.h | 95 +++++++++++++++++++++++++++++--------
> 1 file changed, 74 insertions(+), 21 deletions(-)
>
> diff --git a/include/media/v4l2-subdev.h b/include/media/v4l2-subdev.h
> index e08615179e7b..056eaa949786 100644
> --- a/include/media/v4l2-subdev.h
> +++ b/include/media/v4l2-subdev.h
> @@ -1964,6 +1964,22 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> __result; \
> })
>
> +#define v4l2_subdev_call_drop_fourth(first, second, third, fourth, rest...) \
> + v4l2_subdev_call(first, second, third, ##rest)
> +
> +#define __v4l2_subdev_call_state_active(call, sd, o, f, args...) \
> + ({ \
> + int __result; \
> + struct v4l2_subdev_state *state; \
> + state = v4l2_subdev_get_unlocked_active_state(sd); \
> + if (state) \
> + v4l2_subdev_lock_state(state); \
> + __result = call(sd, o, f, NULL, state, ##args); \
> + if (state) \
> + v4l2_subdev_unlock_state(state); \
> + __result; \
> + })
> +
> /**
> * v4l2_subdev_call_state_active - call an operation of a v4l2_subdev which
> * takes state as a parameter, passing the
> @@ -1982,22 +1998,13 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> * active state, lock it before calling the op and unlock it after the call.
> */
> #define v4l2_subdev_call_state_active(sd, o, f, args...) \
> - ({ \
> - int __result; \
> - struct v4l2_subdev_state *state; \
> - state = v4l2_subdev_get_unlocked_active_state(sd); \
> - if (state) \
> - v4l2_subdev_lock_state(state); \
> - __result = v4l2_subdev_call(sd, o, f, state, ##args); \
> - if (state) \
> - v4l2_subdev_unlock_state(state); \
> - __result; \
> - })
> + __v4l2_subdev_call_state_active(v4l2_subdev_call_drop_fourth, \
> + sd, o, f, ##args)
>
> /**
> - * v4l2_subdev_call_state_try - call an operation of a v4l2_subdev which
> - * takes state as a parameter, passing the
> - * subdev a newly allocated try state.
> + * v4l2_subdev_call_ci_state_active - call an operation of a v4l2_subdev which
> + * takes state as a parameter, passing the
> + * subdev its active state.
> *
> * @sd: pointer to the &struct v4l2_subdev
> * @o: name of the element at &struct v4l2_subdev_ops that contains @f.
> @@ -2007,13 +2014,14 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> * each element at &struct v4l2_subdev_ops.
> * @args: arguments for @f.
> *
> - * This is similar to v4l2_subdev_call_state_active(), except that as this
> - * version allocates a new state, this is only usable for
> - * V4L2_SUBDEV_FORMAT_TRY use cases.
> - *
> - * Note: only legacy non-MC drivers may need this macro.
> + * This macro is just as v4l2_subdev_call_state_active(), with the exception
> + * that it passes NULL as the client info to sub-device ops that need it
> + * (currently pad ops set_fmt, get_selection and set_selection).
> */
> -#define v4l2_subdev_call_state_try(sd, o, f, args...) \
> +#define v4l2_subdev_call_ci_state_active(sd, o, f, args...) \
> + __v4l2_subdev_call_state_active(v4l2_subdev_call, sd, o, f, ##args)
> +
> +#define __v4l2_subdev_call_state_try(call, sd, o, f, args...) \
> ({ \
> int __result; \
> static struct lock_class_key __key; \
> @@ -2025,13 +2033,58 @@ extern const struct v4l2_subdev_ops v4l2_subdev_call_wrappers;
> __result = PTR_ERR(state); \
> } else { \
> v4l2_subdev_lock_state(state); \
> - __result = v4l2_subdev_call(sd, o, f, state, ##args); \
> + __result = call(sd, o, f, NULL, state, ##args); \
> v4l2_subdev_unlock_state(state); \
> __v4l2_subdev_state_free(state); \
> } \
> __result; \
> })
>
> +/**
> + * v4l2_subdev_call_state_try - call an operation of a v4l2_subdev which
> + * takes state as a parameter, passing the
> + * subdev a newly allocated try state.
> + *
> + * @sd: pointer to the &struct v4l2_subdev
> + * @o: name of the element at &struct v4l2_subdev_ops that contains @f.
> + * Each element there groups a set of callbacks functions.
> + * @f: callback function to be called.
> + * The callback functions are defined in groups, according to
> + * each element at &struct v4l2_subdev_ops.
> + * @args: arguments for @f.
> + *
> + * This is similar to v4l2_subdev_call_state_active(), except that as this
> + * version allocates a new state, this is only usable for
> + * V4L2_SUBDEV_FORMAT_TRY use cases.
> + *
> + * Note: only legacy non-MC drivers may need this macro.
> + */
> +#define v4l2_subdev_call_state_try(sd, o, f, args...) \
> + __v4l2_subdev_call_state_try(v4l2_subdev_call_drop_fourth, sd, o, f, \
> + ##args);
> +
> +/**
> + * v4l2_subdev_call_ci_state_try - call an operation of a v4l2_subdev which
> + * takes state as a parameter, passing the
> + * subdev a newly allocated try state.
> + *
> + * @sd: pointer to the &struct v4l2_subdev
> + * @o: name of the element at &struct v4l2_subdev_ops that contains @f.
> + * Each element there groups a set of callbacks functions.
> + * @f: callback function to be called.
> + * The callback functions are defined in groups, according to
> + * each element at &struct v4l2_subdev_ops.
> + * @args: arguments for @f.
> + *
> + * This is similar to v4l2_subdev_call_state_try(), with the exception
> + * that it passes NULL as the client info to sub-device ops that need it
> + * (currently pad ops set_fmt, get_selection and set_selection).
> + *
> + * Note: only legacy non-MC drivers may need this macro.
> + */
> +#define v4l2_subdev_call_ci_state_try(sd, o, f, args...) \
> + __v4l2_subdev_call_state_try(v4l2_subdev_call, sd, o, f, ##args);
> +
> /**
> * v4l2_subdev_has_op - Checks if a subdev defines a certain operation.
> *
--
Regards,
Laurent Pinchart
next prev parent reply other threads:[~2026-07-20 8:45 UTC|newest]
Thread overview: 132+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-07 21:53 [PATCH v5 00/10] Metadata series preparation Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 01/10] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 02/10] media: imx219: Scale the vblank limits according to rate_factor Sakari Ailus
2026-06-08 7:26 ` Laurent Pinchart
2026-06-08 15:29 ` Dave Stevenson
2026-06-08 21:28 ` Laurent Pinchart
2026-06-09 5:58 ` Jai Luthra
2026-06-09 6:01 ` Jai Luthra
2026-06-10 11:48 ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 03/10] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-06-07 22:05 ` sashiko-bot
2026-06-08 9:06 ` Laurent Pinchart
2026-06-08 13:44 ` Sakari Ailus
2026-06-08 15:42 ` Dave Stevenson
2026-06-08 21:38 ` Laurent Pinchart
2026-06-18 10:40 ` Sakari Ailus
2026-07-02 17:04 ` Dave Stevenson
2026-07-03 21:36 ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 04/10] media: imx219: Make control handler ops for PIXEL_RATE NULL Sakari Ailus
2026-06-08 7:36 ` Laurent Pinchart
2026-06-08 7:53 ` Jacopo Mondi
2026-06-08 8:03 ` Laurent Pinchart
2026-06-08 8:14 ` Sakari Ailus
2026-06-08 8:24 ` Laurent Pinchart
2026-06-08 10:21 ` Sakari Ailus
2026-06-08 10:27 ` Laurent Pinchart
2026-06-08 13:47 ` Sakari Ailus
2026-06-08 14:42 ` Laurent Pinchart
2026-06-09 6:29 ` Jacopo Mondi
2026-06-09 14:55 ` Hans Verkuil
2026-06-09 15:15 ` Laurent Pinchart
2026-06-09 15:56 ` Dave Stevenson
2026-06-09 16:07 ` Laurent Pinchart
2026-06-09 16:44 ` Dave Stevenson
2026-06-07 21:53 ` [PATCH v5 05/10] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-06-08 15:45 ` Dave Stevenson
2026-06-07 21:53 ` [PATCH v5 06/10] media: imx219: Fix vertical blanking and exposure for analogue binning Sakari Ailus
2026-06-07 22:07 ` sashiko-bot
2026-06-08 6:58 ` Jacopo Mondi
2026-06-08 9:10 ` Laurent Pinchart
2026-06-08 14:07 ` Sakari Ailus
2026-06-08 16:23 ` Jai Luthra
2026-06-08 21:52 ` Laurent Pinchart
2026-06-10 8:27 ` Sakari Ailus
2026-06-10 8:45 ` Jai Luthra
2026-06-08 10:31 ` Jai Luthra
2026-06-08 11:19 ` Jai Luthra
2026-06-10 9:47 ` Sakari Ailus
2026-06-10 10:29 ` Jai Luthra
2026-06-10 10:57 ` Jai Luthra
2026-06-11 8:58 ` Sakari Ailus
2026-06-08 18:06 ` Dave Stevenson
2026-06-09 16:48 ` Jai Luthra
2026-06-10 10:30 ` Sakari Ailus
2026-06-10 11:59 ` Jai Luthra
2026-06-10 10:13 ` Sakari Ailus
2026-06-10 16:00 ` Jai Luthra
2026-06-08 21:01 ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 07/10] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-06-08 9:29 ` Laurent Pinchart
2026-06-08 14:28 ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 08/10] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-06-08 9:34 ` Laurent Pinchart
2026-06-08 14:35 ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 09/10] media: v4l2-subdev: Add v4l2_subdev_get_fmt_ci() Sakari Ailus
2026-06-08 7:48 ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 10/10] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
2026-06-08 10:16 ` Laurent Pinchart
2026-06-28 14:20 ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 00/16] Metadata series preparation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 01/16] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 02/16] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-07-02 17:10 ` Dave Stevenson
2026-07-16 13:45 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 03/16] media: imx219: Account for rate_factor in control steps Sakari Ailus
2026-07-02 17:09 ` Dave Stevenson
2026-07-17 14:21 ` Laurent Pinchart
2026-07-19 21:00 ` Sakari Ailus
2026-07-20 5:52 ` Laurent Pinchart
2026-07-20 7:15 ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 04/16] media: imx219: The horizontal blanking step is 8 Sakari Ailus
2026-07-02 13:57 ` Dave Stevenson
2026-07-20 6:28 ` Laurent Pinchart
2026-07-20 7:17 ` Sakari Ailus
2026-07-20 8:30 ` Laurent Pinchart
2026-07-20 8:37 ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 05/16] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 06/16] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-07-20 6:34 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 07/16] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-07-01 16:17 ` Frank Li
2026-07-20 6:35 ` Laurent Pinchart
2026-07-20 7:20 ` Sakari Ailus
2026-07-20 8:31 ` Laurent Pinchart
2026-07-20 8:39 ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 08/16] media: v4l2-subdev: Move op check to sub-device op wrappers Sakari Ailus
2026-07-01 16:37 ` Frank Li
2026-07-04 12:11 ` Sakari Ailus
2026-07-20 6:45 ` Laurent Pinchart
2026-07-20 6:45 ` Laurent Pinchart
2026-07-20 7:22 ` Sakari Ailus
2026-07-20 7:30 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 09/16] media: v4l2-subdev: Always call get_fmt() if set_fmt() is unavailable Sakari Ailus
2026-07-01 16:42 ` Frank Li
2026-07-04 12:15 ` Sakari Ailus
2026-07-20 6:53 ` Laurent Pinchart
2026-07-20 7:44 ` Sakari Ailus
2026-07-20 8:29 ` Laurent Pinchart
2026-07-20 8:36 ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 10/16] media: rdacm20: Don't assign set_fmt() Sakari Ailus
2026-07-20 7:31 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 11/16] " Sakari Ailus
2026-07-20 7:31 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 12/16] media: gc0310: " Sakari Ailus
2026-07-20 7:32 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 13/16] media: v4l2-subdev: Add v4l2_subdev_call_ci_state_{active,try} Sakari Ailus
2026-07-01 16:57 ` Frank Li
2026-07-04 12:16 ` Sakari Ailus
2026-07-20 8:45 ` Laurent Pinchart [this message]
2026-07-20 8:51 ` Sakari Ailus
2026-07-20 12:46 ` Laurent Pinchart
2026-07-20 14:13 ` Sakari Ailus
2026-07-20 14:37 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 14/16] media: mt9m001: Pass sub-device state to set_selection() callback Sakari Ailus
2026-07-20 7:00 ` Laurent Pinchart
2026-07-20 7:05 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 15/16] media: cvs: Drop comments on sub-device operations Sakari Ailus
2026-07-20 7:33 ` Laurent Pinchart
2026-07-01 12:26 ` [PATCH v6 15/15] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
2026-07-01 17:00 ` Frank Li
2026-07-01 12:26 ` [PATCH v6 16/16] " Sakari Ailus
2026-07-01 17:01 ` Frank Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260720084553.GD3679@killaraus.ideasonboard.com \
--to=laurent.pinchart@ideasonboard.com \
--cc=benjamin.mugnier@foss.st.com \
--cc=christophe.jaillet@wanadoo.fr \
--cc=dave.stevenson@raspberrypi.com \
--cc=david.plowman@raspberrypi.com \
--cc=dongcheng.yan@intel.com \
--cc=git@apitzsch.eu \
--cc=hans@jjverkuil.nl \
--cc=hansg@kernel.org \
--cc=heimir.sverrisson@gmail.com \
--cc=hpa@redhat.com \
--cc=jacopo.mondi@ideasonboard.com \
--cc=jai.luthra@ideasonboard.com \
--cc=julien.massot@collabora.com \
--cc=khai.wen.ng@intel.com \
--cc=kieran.bingham@ideasonboard.com \
--cc=linux-media@vger.kernel.org \
--cc=mehdi.djait@linux.intel.com \
--cc=mirela.rabulea@nxp.com \
--cc=naush@raspberrypi.com \
--cc=ong.hock.yu@intel.com \
--cc=prabhakar.csengg@gmail.com \
--cc=r-donadkar@ti.com \
--cc=ribalda@kernel.org \
--cc=sakari.ailus@linux.intel.com \
--cc=stefan.klug@ideasonboard.com \
--cc=sylvain.petinot@foss.st.com \
--cc=tomi.valkeinen@ideasonboard.com \
--cc=tomm.merciai@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox