Linux Media Controller development
 help / color / mirror / Atom feed
From: Frank Li <Frank.li@oss.nxp.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: linux-media@vger.kernel.org, hans@jjverkuil.nl,
	laurent.pinchart@ideasonboard.com,
	Prabhakar <prabhakar.csengg@gmail.com>,
	"Kate Hsuan" <hpa@redhat.com>,
	"Dave Stevenson" <dave.stevenson@raspberrypi.com>,
	"Tommaso Merciai" <tomm.merciai@gmail.com>,
	"Benjamin Mugnier" <benjamin.mugnier@foss.st.com>,
	"Sylvain Petinot" <sylvain.petinot@foss.st.com>,
	"Christophe JAILLET" <christophe.jaillet@wanadoo.fr>,
	"Julien Massot" <julien.massot@collabora.com>,
	"Naushir Patuck" <naush@raspberrypi.com>,
	"Yan, Dongcheng" <dongcheng.yan@intel.com>,
	"Stefan Klug" <stefan.klug@ideasonboard.com>,
	"Mirela Rabulea" <mirela.rabulea@nxp.com>,
	"André Apitzsch" <git@apitzsch.eu>,
	"Heimir Thor Sverrisson" <heimir.sverrisson@gmail.com>,
	"Kieran Bingham" <kieran.bingham@ideasonboard.com>,
	"Mehdi Djait" <mehdi.djait@linux.intel.com>,
	"Ricardo Ribalda Delgado" <ribalda@kernel.org>,
	"Hans de Goede" <hansg@kernel.org>,
	"Jacopo Mondi" <jacopo.mondi@ideasonboard.com>,
	"Tomi Valkeinen" <tomi.valkeinen@ideasonboard.com>,
	"David Plowman" <david.plowman@raspberrypi.com>,
	"Yu, Ong Hock" <ong.hock.yu@intel.com>,
	"Ng, Khai Wen" <khai.wen.ng@intel.com>,
	"Jai Luthra" <jai.luthra@ideasonboard.com>,
	"Rishikesh Donadkar" <r-donadkar@ti.com>
Subject: Re: [PATCH v6 08/16] media: v4l2-subdev: Move op check to sub-device op wrappers
Date: Wed, 1 Jul 2026 12:37:48 -0400	[thread overview]
Message-ID: <akVCXOP8Nwsv8Ji2@lizhi-Precision-Tower-5810> (raw)
In-Reply-To: <20260701122634.1728782-8-sakari.ailus@linux.intel.com>

On Wed, Jul 01, 2026 at 03:26:25PM +0300, Sakari Ailus wrote:
> In anticipation of performing work for sub-device operation when the
> driver doesn't implement one, move the check of operation existence to the
> wrapper itself.
>
> No functional change intended.
>
> Many drivers implement set_fmt() pad op that simply returns the format
> just as get_fmt() would do, usually because the driver only supports a
> single one. The arguments to set_fmt() and get_fmt() are about to get
> differentiated so call get_fmt() always if set_fmt() isn't supported by
> the driver. This avoids changing drivers now and allows removing
> boilerplate code from existing drivers.
>
> Signed-off-by: Sakari Ailus <sakari.ailus@linux.intel.com>
> ---
>  drivers/media/v4l2-core/v4l2-subdev.c | 117 ++++++++++++++++++--------
>  include/media/v4l2-subdev.h           |   6 +-
>  2 files changed, 84 insertions(+), 39 deletions(-)
>
> diff --git a/drivers/media/v4l2-core/v4l2-subdev.c b/drivers/media/v4l2-core/v4l2-subdev.c
> index 070a9e607fe3..86be4d51c9a5 100644
> --- a/drivers/media/v4l2-core/v4l2-subdev.c
> +++ b/drivers/media/v4l2-core/v4l2-subdev.c
> @@ -244,20 +244,24 @@ static inline int check_format(struct v4l2_subdev *sd,
>  	       check_state(sd, state, format->which, format->pad, format->stream);
>  }
>
...
>
> -	return check_which(code->which) ? : check_pad(sd, code->pad) ? :
> -	       check_state(sd, state, code->which, code->pad, code->stream) ? :
> -	       sd->ops->pad->enum_mbus_code(sd, state, code);
> +	/*
> +	 * FIXME: Convert the check below to use the ternary operator once
> +	 * smatch can handle it.
> +	 */
> +	return do_subdev_call(sd,
> +			      ({
> +				      int ret = check_which(code->which);
> +				      if (!ret)
> +					      ret = check_pad(sd, code->pad);
> +				      if (!ret)
> +					      ret = check_state(sd, state, code->which,
> +								code->pad, code->stream);
> +				      ret;
> +			      }), pad, enum_mbus_code, state, code);
>  }
>
>  static int call_enum_frame_size(struct v4l2_subdev *sd,
> @@ -279,9 +294,20 @@ static int call_enum_frame_size(struct v4l2_subdev *sd,
>  	if (!fse)
>  		return -EINVAL;
>
> -	return check_which(fse->which) ? : check_pad(sd, fse->pad) ? :
> -	       check_state(sd, state, fse->which, fse->pad, fse->stream) ? :
> -	       sd->ops->pad->enum_frame_size(sd, state, fse);
> +	/*
> +	 * FIXME: Convert the check below to use the ternary operator once
> +	 * smatch can handle it.
> +	 */
> +	return do_subdev_call(sd,
> +			      ({
> +				      int ret = check_which(fse->which);
> +				      if (!ret)
> +					      ret = check_pad(sd, fse->pad);
> +				      if (!ret)
> +					      ret = check_state(sd, state, fse->which,
> +								fse->pad, fse->stream);
> +				      ret;
> +			      }), pad, enum_frame_size, state, fse);

>  }
>
>  static int call_enum_frame_interval(struct v4l2_subdev *sd,
> @@ -291,9 +317,20 @@ static int call_enum_frame_interval(struct v4l2_subdev *sd,
>  	if (!fie)
>  		return -EINVAL;
>
> -	return check_which(fie->which) ? : check_pad(sd, fie->pad) ? :
> -	       check_state(sd, state, fie->which, fie->pad, fie->stream) ? :
> -	       sd->ops->pad->enum_frame_interval(sd, state, fie);
> +	/*
> +	 * FIXME: Convert the check below to use the ternary operator once
> +	 * smatch can handle it.
> +	 */
> +	return do_subdev_call(sd,
> +			      ({
> +				      int ret = check_which(fie->which);
> +				      if (!ret)
> +					      ret = check_pad(sd, fie->pad);
> +				      if (!ret)
> +					      ret = check_state(sd, state, fie->which,
> +								fie->pad, fie->stream);
> +				      ret;
> +			      }), pad, enum_frame_interval, state, fie);

look like similar with above check logic, can you use helper funciton
or macro to reduce duplicate and easy to read.

Frank

  reply	other threads:[~2026-07-01 16:38 UTC|newest]

Thread overview: 99+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-06-07 21:53 [PATCH v5 00/10] Metadata series preparation Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 01/10] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 02/10] media: imx219: Scale the vblank limits according to rate_factor Sakari Ailus
2026-06-08  7:26   ` Laurent Pinchart
2026-06-08 15:29   ` Dave Stevenson
2026-06-08 21:28     ` Laurent Pinchart
2026-06-09  5:58       ` Jai Luthra
2026-06-09  6:01         ` Jai Luthra
2026-06-10 11:48           ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 03/10] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-06-07 22:05   ` sashiko-bot
2026-06-08  9:06   ` Laurent Pinchart
2026-06-08 13:44     ` Sakari Ailus
2026-06-08 15:42   ` Dave Stevenson
2026-06-08 21:38     ` Laurent Pinchart
2026-06-18 10:40     ` Sakari Ailus
2026-07-02 17:04       ` Dave Stevenson
2026-07-03 21:36         ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 04/10] media: imx219: Make control handler ops for PIXEL_RATE NULL Sakari Ailus
2026-06-08  7:36   ` Laurent Pinchart
2026-06-08  7:53     ` Jacopo Mondi
2026-06-08  8:03       ` Laurent Pinchart
2026-06-08  8:14         ` Sakari Ailus
2026-06-08  8:24           ` Laurent Pinchart
2026-06-08 10:21             ` Sakari Ailus
2026-06-08 10:27               ` Laurent Pinchart
2026-06-08 13:47                 ` Sakari Ailus
2026-06-08 14:42                   ` Laurent Pinchart
2026-06-09  6:29                     ` Jacopo Mondi
2026-06-09 14:55                       ` Hans Verkuil
2026-06-09 15:15                         ` Laurent Pinchart
2026-06-09 15:56                           ` Dave Stevenson
2026-06-09 16:07                             ` Laurent Pinchart
2026-06-09 16:44                               ` Dave Stevenson
2026-06-07 21:53 ` [PATCH v5 05/10] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-06-08 15:45   ` Dave Stevenson
2026-06-07 21:53 ` [PATCH v5 06/10] media: imx219: Fix vertical blanking and exposure for analogue binning Sakari Ailus
2026-06-07 22:07   ` sashiko-bot
2026-06-08  6:58   ` Jacopo Mondi
2026-06-08  9:10     ` Laurent Pinchart
2026-06-08 14:07       ` Sakari Ailus
2026-06-08 16:23         ` Jai Luthra
2026-06-08 21:52           ` Laurent Pinchart
2026-06-10  8:27             ` Sakari Ailus
2026-06-10  8:45               ` Jai Luthra
2026-06-08 10:31     ` Jai Luthra
2026-06-08 11:19       ` Jai Luthra
2026-06-10  9:47         ` Sakari Ailus
2026-06-10 10:29           ` Jai Luthra
2026-06-10 10:57             ` Jai Luthra
2026-06-11  8:58             ` Sakari Ailus
2026-06-08 18:06       ` Dave Stevenson
2026-06-09 16:48         ` Jai Luthra
2026-06-10 10:30           ` Sakari Ailus
2026-06-10 11:59             ` Jai Luthra
2026-06-10 10:13         ` Sakari Ailus
2026-06-10 16:00           ` Jai Luthra
2026-06-08 21:01       ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 07/10] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-06-08  9:29   ` Laurent Pinchart
2026-06-08 14:28     ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 08/10] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-06-08  9:34   ` Laurent Pinchart
2026-06-08 14:35     ` Sakari Ailus
2026-06-07 21:53 ` [PATCH v5 09/10] media: v4l2-subdev: Add v4l2_subdev_get_fmt_ci() Sakari Ailus
2026-06-08  7:48   ` Laurent Pinchart
2026-06-07 21:53 ` [PATCH v5 10/10] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
2026-06-08 10:16   ` Laurent Pinchart
2026-06-28 14:20     ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 00/16] Metadata series preparation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 01/16] media: Documentation: Improve pixel rate calculation documentation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 02/16] media: imx219: Account rate_factor in setting upper exposure limit Sakari Ailus
2026-07-02 17:10   ` Dave Stevenson
2026-07-01 12:26 ` [PATCH v6 03/16] media: imx219: Account for rate_factor in control steps Sakari Ailus
2026-07-02 17:09   ` Dave Stevenson
2026-07-01 12:26 ` [PATCH v6 04/16] media: imx219: The horizontal blanking step is 8 Sakari Ailus
2026-07-02 13:57   ` Dave Stevenson
2026-07-01 12:26 ` [PATCH v6 05/16] media: imx219: Rename "binning" as "bin_hv" in imx219_set_pad_format Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 06/16] media: Improve enable_streams and disable_streams documentation Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 07/16] media: v4l2-subdev: Move subdev client capabilities into a new struct Sakari Ailus
2026-07-01 16:17   ` Frank Li
2026-07-01 12:26 ` [PATCH v6 08/16] media: v4l2-subdev: Move op check to sub-device op wrappers Sakari Ailus
2026-07-01 16:37   ` Frank Li [this message]
2026-07-04 12:11     ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 09/16] media: v4l2-subdev: Always call get_fmt() if set_fmt() is unavailable Sakari Ailus
2026-07-01 16:42   ` Frank Li
2026-07-04 12:15     ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 10/16] media: rdacm20: Don't assign set_fmt() Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 11/16] " Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 12/16] media: gc0310: " Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 13/16] media: v4l2-subdev: Add v4l2_subdev_call_ci_state_{active,try} Sakari Ailus
2026-07-01 16:57   ` Frank Li
2026-07-04 12:16     ` Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 14/16] media: mt9m001: Pass sub-device state to set_selection() callback Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 15/16] media: cvs: Drop comments on sub-device operations Sakari Ailus
2026-07-01 12:26 ` [PATCH v6 15/15] media: v4l2-subdev: Add struct v4l2_subdev_client_info pointer to pad ops Sakari Ailus
2026-07-01 17:00   ` Frank Li
2026-07-01 12:26 ` [PATCH v6 16/16] " Sakari Ailus
2026-07-01 17:01   ` Frank Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=akVCXOP8Nwsv8Ji2@lizhi-Precision-Tower-5810 \
    --to=frank.li@oss.nxp.com \
    --cc=benjamin.mugnier@foss.st.com \
    --cc=christophe.jaillet@wanadoo.fr \
    --cc=dave.stevenson@raspberrypi.com \
    --cc=david.plowman@raspberrypi.com \
    --cc=dongcheng.yan@intel.com \
    --cc=git@apitzsch.eu \
    --cc=hans@jjverkuil.nl \
    --cc=hansg@kernel.org \
    --cc=heimir.sverrisson@gmail.com \
    --cc=hpa@redhat.com \
    --cc=jacopo.mondi@ideasonboard.com \
    --cc=jai.luthra@ideasonboard.com \
    --cc=julien.massot@collabora.com \
    --cc=khai.wen.ng@intel.com \
    --cc=kieran.bingham@ideasonboard.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=mehdi.djait@linux.intel.com \
    --cc=mirela.rabulea@nxp.com \
    --cc=naush@raspberrypi.com \
    --cc=ong.hock.yu@intel.com \
    --cc=prabhakar.csengg@gmail.com \
    --cc=r-donadkar@ti.com \
    --cc=ribalda@kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    --cc=stefan.klug@ideasonboard.com \
    --cc=sylvain.petinot@foss.st.com \
    --cc=tomi.valkeinen@ideasonboard.com \
    --cc=tomm.merciai@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox