Linux MIPS Architecture development
 help / color / mirror / Atom feed
* [PATCH 0/6] vDSO: Clean up the HAVE_GENERIC_VDSO kconfig symbol
@ 2026-07-09  7:28 Thomas Weißschuh
  2026-07-09  7:28 ` [PATCH 1/6] futex: Remove dependency on HAVE_GENERIC_VDSO from FUTEX_ROBUST_UNLOCK Thomas Weißschuh
                   ` (5 more replies)
  0 siblings, 6 replies; 15+ messages in thread
From: Thomas Weißschuh @ 2026-07-09  7:28 UTC (permalink / raw)
  To: Andy Lutomirski, Thomas Gleixner, Vincenzo Frascino,
	Thomas Bogendoerfer
  Cc: linux-kernel, linux-mips, Thomas Weißschuh

Simplify the usage of HAVE_GENERIC_VDSO and rename it to better match
its function.

Signed-off-by: Thomas Weißschuh <thomas.weissschuh@linutronix.de>
---
Thomas Weißschuh (6):
      futex: Remove dependency on HAVE_GENERIC_VDSO from FUTEX_ROBUST_UNLOCK
      vDSO: Remove the dependency on HAVE_GENERIC_VDSO from ARCH_HAS_VDSO_ARCH_DATA
      MIPS: vdso: Stop using CONFIG_HAVE_GENERIC_VDSO
      vDSO: Automatically select HAVE_GENERIC_VDSO if necessary
      vDSO: Drop HAVE_GENERIC_VDSO from architecture kconfig files
      vDSO: Rename HAVE_GENERIC_VDSO to VDSO_DATASTORE

 arch/Kconfig                   | 1 -
 arch/arm/mm/Kconfig            | 1 -
 arch/arm64/Kconfig             | 1 -
 arch/loongarch/Kconfig         | 2 +-
 arch/mips/Kconfig              | 1 -
 arch/mips/kernel/vdso.c        | 4 ++--
 arch/powerpc/Kconfig           | 2 +-
 arch/riscv/Kconfig             | 8 ++++----
 arch/s390/Kconfig              | 1 -
 arch/sparc/Kconfig             | 1 -
 arch/x86/Kconfig               | 1 -
 include/linux/vdso_datastore.h | 6 +++---
 init/Kconfig                   | 2 +-
 lib/vdso/Kconfig               | 8 +++-----
 lib/vdso/Makefile              | 2 +-
 15 files changed, 16 insertions(+), 25 deletions(-)
---
base-commit: 369cecd238ac8317cccd27cf2452a8a6b6da1581
change-id: 20260708-vdso-have_generic_vdso-478346d5c859

Best regards,
--  
Thomas Weißschuh <thomas.weissschuh@linutronix.de>


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2026-07-09 11:10 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-09  7:28 [PATCH 0/6] vDSO: Clean up the HAVE_GENERIC_VDSO kconfig symbol Thomas Weißschuh
2026-07-09  7:28 ` [PATCH 1/6] futex: Remove dependency on HAVE_GENERIC_VDSO from FUTEX_ROBUST_UNLOCK Thomas Weißschuh
2026-07-09  9:27   ` Vincenzo Frascino
2026-07-09  7:28 ` [PATCH 2/6] vDSO: Remove the dependency on HAVE_GENERIC_VDSO from ARCH_HAS_VDSO_ARCH_DATA Thomas Weißschuh
2026-07-09  9:28   ` Vincenzo Frascino
2026-07-09  7:28 ` [PATCH 3/6] MIPS: vdso: Stop using CONFIG_HAVE_GENERIC_VDSO Thomas Weißschuh
2026-07-09  9:29   ` Vincenzo Frascino
2026-07-09  7:28 ` [PATCH 4/6] vDSO: Automatically select HAVE_GENERIC_VDSO if necessary Thomas Weißschuh
2026-07-09  9:30   ` Vincenzo Frascino
2026-07-09 11:09   ` Philippe Mathieu-Daudé
2026-07-09  7:28 ` [PATCH 5/6] vDSO: Drop HAVE_GENERIC_VDSO from architecture kconfig files Thomas Weißschuh
2026-07-09  9:31   ` Vincenzo Frascino
2026-07-09  7:28 ` [PATCH 6/6] vDSO: Rename HAVE_GENERIC_VDSO to VDSO_DATASTORE Thomas Weißschuh
2026-07-09  9:31   ` Vincenzo Frascino
2026-07-09 11:10   ` Philippe Mathieu-Daudé

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox