Linux PCI subsystem development
 help / color / mirror / Atom feed
From: Shawn Lin <shawn.lin@rock-chips.com>
To: Manivannan Sadhasivam <mani@kernel.org>,
	Bjorn Helgaas <bhelgaas@google.com>
Cc: linux-pci@vger.kernel.org, Shawn Lin <shawn.lin@rock-chips.com>
Subject: [PATCH 0/2] PCI: dwc: Make the MSI domain naming explicit
Date: Wed, 30 Sep 2026 10:22:08 +0800	[thread overview]
Message-ID: <1790734930-217000-1-git-send-email-shawn.lin@rock-chips.com> (raw)


I was looking into whether the DWC core provides a common INTx irq
domain registration and handling flow, as several glue drivers owning
a legacy interrupt controller copy-paste the same code (get the
"legacy-interrupt-controller" child node, create a linear domain with
a one-line .map callback, install a chained handler).

The DWC core has no INTx equivalent at all: dw_pcie_allocate_domains()
looks like it could be that helper at first glance, but it only
creates the MSI parent irq domain (msi_create_parent_irq_domain() with
DOMAIN_BUS_PCI_MSI). Likewise, struct dw_pcie_rp::irq_domain only
serves the MSI parent domain.

So make the naming explicit:

patch 1 renames dw_pcie_allocate_domains() to
dw_pcie_allocate_msi_domains().

patch 2 renames struct dw_pcie_rp::irq_domain to ::msi_irq_domain.



Shawn Lin (2):
  PCI: dwc: Rename dw_pcie_allocate_domains to
    dw_pcie_allocate_msi_domains
  PCI: dwc: Rename pp->irq_domain to pp->msi_irq_domain

 drivers/pci/controller/dwc/pci-dra7xx.c           |  2 +-
 drivers/pci/controller/dwc/pci-keystone.c         |  4 ++--
 drivers/pci/controller/dwc/pcie-designware-host.c | 14 +++++++-------
 drivers/pci/controller/dwc/pcie-designware.h      |  6 +++---
 4 files changed, 13 insertions(+), 13 deletions(-)

-- 
2.7.4


             reply	other threads:[~2026-09-30  2:37 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-30  2:22 Shawn Lin [this message]
2026-09-30  2:22 ` [PATCH 1/2] PCI: dwc: Rename dw_pcie_allocate_domains to dw_pcie_allocate_msi_domains Shawn Lin
2026-09-30  9:16   ` sashiko-bot
2026-09-30  2:22 ` [PATCH 2/2] PCI: dwc: Rename pp->irq_domain to pp->msi_irq_domain Shawn Lin
2026-09-30  4:10   ` Vignesh Raghavendra
2026-09-30  9:17   ` sashiko-bot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1790734930-217000-1-git-send-email-shawn.lin@rock-chips.com \
    --to=shawn.lin@rock-chips.com \
    --cc=bhelgaas@google.com \
    --cc=linux-pci@vger.kernel.org \
    --cc=mani@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox