Linux s390 Architecture development
 help / color / mirror / Atom feed
* [PATCH v1] s390/ap: Drop unused member from ap_device_id
@ 2026-08-06 15:57 Uwe Kleine-König (The Capable Hub)
  2026-08-06 16:07 ` sashiko-bot
  2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
  0 siblings, 2 replies; 4+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-08-06 15:57 UTC (permalink / raw)
  To: Harald Freudenberger, Holger Dengler
  Cc: Heiko Carstens, Vasily Gorbik, Alexander Gordeev,
	Christian Borntraeger, Sven Schnelle, linux-s390, linux-kernel,
	Pawel Zalewski

ap_device_id::device_info is not used in the kernel. The structure is
also not part of API/ABI, so the unused member can just be dropped.

Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
---
 include/linux/device-id/ap.h | 1 -
 1 file changed, 1 deletion(-)

diff --git a/include/linux/device-id/ap.h b/include/linux/device-id/ap.h
index 0992333a34db..011af33c0bcf 100644
--- a/include/linux/device-id/ap.h
+++ b/include/linux/device-id/ap.h
@@ -14,7 +14,6 @@ typedef unsigned long kernel_ulong_t;
 struct ap_device_id {
 	__u16 match_flags;	/* which fields to match against */
 	__u8 dev_type;		/* device type */
-	kernel_ulong_t driver_info;
 };
 
 #endif /* ifndef LINUX_DEVICE_ID_AP_H */

base-commit: 1701fda2f58e345c050f4309971bdc07cd6146ba
-- 
2.55.0.11.g153666a7d9bb


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v1] s390/ap: Drop unused member from ap_device_id
  2026-08-06 15:57 [PATCH v1] s390/ap: Drop unused member from ap_device_id Uwe Kleine-König (The Capable Hub)
@ 2026-08-06 16:07 ` sashiko-bot
  2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
  1 sibling, 0 replies; 4+ messages in thread
From: sashiko-bot @ 2026-08-06 16:07 UTC (permalink / raw)
  To: Uwe Kleine-König (The Capable Hub)
  Cc: linux-s390, Alexander Gordeev, Heiko Carstens, Vasily Gorbik

Thank you for your contribution! Sashiko AI review found 2 potential issue(s) to consider:
- [Medium] The commit message incorrectly references `device_info` instead of `driver_info`.
- [Low] The `kernel_ulong_t` typedef is no longer used after the removal of `driver_info`.
--

--- Patch [1]: [PATCH v1] s390/ap: Drop unused member from ap_device_id ---
commit 88f5caa72995cfeb3eb825fd5c1c4f333ad8e5d7
Author: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>

s390/ap: Drop unused member from ap_device_id

This commit removes the driver_info member from the ap_device_id structure.
The structure is not part of the API/ABI and the member has no in-kernel
users.

> ap_device_id::device_info is not used in the kernel. The structure is
> also not part of API/ABI, so the unused member can just be dropped.

[Severity: Medium]
This isn't a bug in the code, but the commit message references device_info.
The struct member actually being removed by this patch is named driver_info.

> diff --git a/include/linux/device-id/ap.h b/include/linux/device-id/ap.h
> index 0992333a34db2..011af33c0bcf2 100644
> --- a/include/linux/device-id/ap.h
> +++ b/include/linux/device-id/ap.h
> @@ -14,7 +14,6 @@ typedef unsigned long kernel_ulong_t;

[Severity: Low]
Does this change leave behind an unused typedef?

With the removal of driver_info, it appears the kernel_ulong_t typedef and
its enclosing #ifdef __KERNEL__ block are no longer used anywhere in this
header file.

>  struct ap_device_id {
>  	__u16 match_flags;	/* which fields to match against */
>  	__u8 dev_type;		/* device type */
> -	kernel_ulong_t driver_info;
>  };
>  
>  #endif /* ifndef LINUX_DEVICE_ID_AP_H */

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/20260806155757.1281233-2-u.kleine-koenig@baylibre.com?part=1

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH v2] s390/ap: Drop unused member from ap_device_id
  2026-08-06 15:57 [PATCH v1] s390/ap: Drop unused member from ap_device_id Uwe Kleine-König (The Capable Hub)
  2026-08-06 16:07 ` sashiko-bot
@ 2026-08-06 16:21 ` Uwe Kleine-König (The Capable Hub)
  2026-08-06 16:31   ` sashiko-bot
  1 sibling, 1 reply; 4+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-08-06 16:21 UTC (permalink / raw)
  To: Harald Freudenberger, Holger Dengler
  Cc: Heiko Carstens, Vasily Gorbik, Alexander Gordeev,
	Christian Borntraeger, Sven Schnelle, linux-s390, linux-kernel,
	Pawel Zalewski

ap_device_id::driver_info is not used in the kernel. The structure is
also not part of API/ABI, so the unused member can just be dropped.

Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>
---
Hello,

Sashiko was quick to identify two issues in my patch. Before someone
gets around to review v1 by hand, here is a v2 addressing Sashiko's
concerns:

 - remove the typedef for kernel_ulong_t
 - s/device_info/driver_info/ in the commit log

Thanks
Uwe

 include/linux/device-id/ap.h | 2 --
 1 file changed, 2 deletions(-)

diff --git a/include/linux/device-id/ap.h b/include/linux/device-id/ap.h
index 0992333a34db..e050abebbf3d 100644
--- a/include/linux/device-id/ap.h
+++ b/include/linux/device-id/ap.h
@@ -4,7 +4,6 @@
 
 #ifdef __KERNEL__
 #include <linux/types.h>
-typedef unsigned long kernel_ulong_t;
 #endif
 
 #define AP_DEVICE_ID_MATCH_CARD_TYPE		0x01
@@ -14,7 +13,6 @@ typedef unsigned long kernel_ulong_t;
 struct ap_device_id {
 	__u16 match_flags;	/* which fields to match against */
 	__u8 dev_type;		/* device type */
-	kernel_ulong_t driver_info;
 };
 
 #endif /* ifndef LINUX_DEVICE_ID_AP_H */

base-commit: 1701fda2f58e345c050f4309971bdc07cd6146ba
-- 
2.55.0.11.g153666a7d9bb


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] s390/ap: Drop unused member from ap_device_id
  2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
@ 2026-08-06 16:31   ` sashiko-bot
  0 siblings, 0 replies; 4+ messages in thread
From: sashiko-bot @ 2026-08-06 16:31 UTC (permalink / raw)
  To: Uwe Kleine-König (The Capable Hub)
  Cc: Heiko Carstens, Vasily Gorbik, Alexander Gordeev, linux-s390

> ap_device_id::driver_info is not used in the kernel. The structure is
> also not part of API/ABI, so the unused member can just be dropped.
> 
> Signed-off-by: Uwe Kleine-König (The Capable Hub) <u.kleine-koenig@baylibre.com>

Sashiko has reviewed this patch and found no issues. It looks great!

-- 
Sashiko AI review · https://sashiko.dev/#/patchset/55aa5d3b5b1794b5fca7f3ae75b48dcefa09e808.1786033091.git.ukleinek@kernel.org?part=1


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-08-06 16:31 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-06 15:57 [PATCH v1] s390/ap: Drop unused member from ap_device_id Uwe Kleine-König (The Capable Hub)
2026-08-06 16:07 ` sashiko-bot
2026-08-06 16:21 ` [PATCH v2] " Uwe Kleine-König (The Capable Hub)
2026-08-06 16:31   ` sashiko-bot

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox