Linux kernel staging patches
 help / color / mirror / Atom feed
* [PATCH] staging: rtl8723bs: coding style cleanup in rtw_mlme.c
@ 2026-07-25 13:57 Akhmad
  2026-07-25 17:28 ` Greg KH
  0 siblings, 1 reply; 2+ messages in thread
From: Akhmad @ 2026-07-25 13:57 UTC (permalink / raw)
  To: gregkh; +Cc: linux-staging, Akhmad

Fix multiple coding style issues to improve code readability:

- Break a 140-character line to comply with the kernel coding
  style guideline of maximum 100 characters per line
- Move comment before the code for better readability
- Fix typo in comment (varable -> variable)
- Remove dead code: empty if block with only a TODO comment

These changes improve code quality and compliance with kernel
coding style guidelines.

Signed-off-by: Akhmad <Akhmad100913@gmail.com>
---
 drivers/staging/rtl8723bs/core/rtw_mlme.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/staging/rtl8723bs/core/rtw_mlme.c b/drivers/staging/rtl8723bs/core/rtw_mlme.c
index 1196ec011..a29ab63f7 100644
--- a/drivers/staging/rtl8723bs/core/rtw_mlme.c
+++ b/drivers/staging/rtl8723bs/core/rtw_mlme.c
@@ -52,7 +52,10 @@ int	rtw_init_mlme_priv(struct adapter *padapter)
 	pmlmepriv->pscanned = NULL;
 	pmlmepriv->fw_state = WIFI_STATION_STATE; /*  Must sync with rtw_wdev_alloc() */
 	pmlmepriv->cur_network.network.infrastructure_mode = Ndis802_11AutoUnknown;
-	pmlmepriv->scan_mode = SCAN_ACTIVE;/*  1: active, 0: passive. Maybe someday we should rename this varable to "active_mode" (Jeff) */
+	/* 1: active, 0: passive.
+	 * Maybe someday we should rename this variable to "active_mode" (Jeff)
+	 */
+	pmlmepriv->scan_mode = SCAN_ACTIVE;
 
 	spin_lock_init(&pmlmepriv->lock);
 	INIT_LIST_HEAD(&pmlmepriv->free_bss_pool.queue);
@@ -2426,9 +2429,6 @@ void rtw_update_ht_cap(struct adapter *padapter, u8 *pie, uint ie_len, u8 channe
 
 	len = 0;
 	p = rtw_get_ie(pie + sizeof(struct ndis_802_11_fix_ie), WLAN_EID_HT_OPERATION, &len, ie_len - sizeof(struct ndis_802_11_fix_ie));
-	if (p && len > 0) {
-		/* todo: */
-	}
 
 	if ((pregistrypriv->bw_mode & 0x0f) > 0)
 		cbw40_enable = 1;
-- 
2.37.1 (Apple Git-137.1)


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] staging: rtl8723bs: coding style cleanup in rtw_mlme.c
  2026-07-25 13:57 [PATCH] staging: rtl8723bs: coding style cleanup in rtw_mlme.c Akhmad
@ 2026-07-25 17:28 ` Greg KH
  0 siblings, 0 replies; 2+ messages in thread
From: Greg KH @ 2026-07-25 17:28 UTC (permalink / raw)
  To: Akhmad; +Cc: linux-staging

On Sat, Jul 25, 2026 at 04:57:55PM +0300, Akhmad wrote:
> Fix multiple coding style issues to improve code readability:
> 
> - Break a 140-character line to comply with the kernel coding
>   style guideline of maximum 100 characters per line
> - Move comment before the code for better readability
> - Fix typo in comment (varable -> variable)
> - Remove dead code: empty if block with only a TODO comment
> 
> These changes improve code quality and compliance with kernel
> coding style guidelines.
> 
> Signed-off-by: Akhmad <Akhmad100913@gmail.com>
> ---
>  drivers/staging/rtl8723bs/core/rtw_mlme.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)

Hi,

This is the friendly patch-bot of Greg Kroah-Hartman.  You have sent him
a patch that has triggered this response.  He used to manually respond
to these common problems, but in order to save his sanity (he kept
writing the same thing over and over, yet to different people), I was
created.  Hopefully you will not take offence and will fix the problem
in your patch and resubmit it so that it can be accepted into the Linux
kernel tree.

You are receiving this message because of the following common error(s)
as indicated below:

- Your patch did many different things all at once, making it difficult
  to review.  All Linux kernel patches need to only do one thing at a
  time.  If you need to do multiple things (such as clean up all coding
  style issues in a file/driver), do it in a sequence of patches, each
  one doing only one thing.  This will make it easier to review the
  patches to ensure that they are correct, and to help alleviate any
  merge issues that larger patches can cause.

- It looks like you did not use your "real" name for the patch on either
  the Signed-off-by: line, or the From: line (both of which have to
  match).  Please read the kernel file,
  Documentation/process/submitting-patches.rst for how to do this
  correctly.

If you wish to discuss this problem further, or you have questions about
how to resolve this issue, please feel free to respond to this email and
Greg will reply once he has dug out from the pending patches received
from other developers.

thanks,

greg k-h's patch email bot

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2026-07-25 17:29 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-25 13:57 [PATCH] staging: rtl8723bs: coding style cleanup in rtw_mlme.c Akhmad
2026-07-25 17:28 ` Greg KH

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox