Linux wireless drivers development
 help / color / mirror / Atom feed
From: Johannes Berg <johannes@sipsolutions.net>
To: Michael Wu <flamingice@sourmilk.net>
Cc: John Linville <linville@tuxdriver.com>,
	linux-wireless <linux-wireless@vger.kernel.org>,
	Ivo van Doorn <ivdoorn@gmail.com>,
	Tomas Winkler <tomasw@gmail.com>,
	Reinette Chatre <reinette.chatre@intel.com>,
	Zhu Yi <yi.zhu@intel.com>, Daniel Drake <dsd@gentoo.org>,
	Yanbo Li <dreamfly281@gmail.com>
Subject: Re: [PATCH] mac80211: don't use interface indizes
Date: Wed, 05 Dec 2007 11:18:20 +0100	[thread overview]
Message-ID: <1196849900.4121.4.camel@johannes.berg> (raw)
In-Reply-To: <200712050057.19819.flamingice@sourmilk.net>

[-- Attachment #1: Type: text/plain, Size: 1044 bytes --]


> That's a pretty terrible name. mac80211 is not a valid prefix to be used in 
> the codebase, at least not for structures and functions. Everything else uses 
> ieee80211 so use of mac80211 is not acceptable, especially for driver facing 
> API. (the use of that prefix in event.c isn't right either.. need to fix 
> that)

Heh. True, I'll s/mac80211_vif/ieee80211_vif/

> Leaving it to the driver to allocate the private space isn't too great either. 
> Something like a char subif_priv[] at the end of ieee80211_sub_if_data and a 
> way to specify the length of the private area will be more useful to drivers 
> which wish to use the per-subif private space by avoiding extra allocation 
> and allocation failure handling and also for drivers which don't, by 
> eliminating the overhead of storing an unused pointer. It is also more 
> consistent with the other apis that allocate ieee80211_hw and net_device.

Most drivers won't ever need private space, so leaving it to them to
allocate is more efficient.

johannes

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 828 bytes --]

  reply	other threads:[~2007-12-05 10:18 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-12-04 15:40 [PATCH] mac80211: don't use interface indizes Johannes Berg
2007-12-05  5:57 ` Michael Wu
2007-12-05 10:18   ` Johannes Berg [this message]
2007-12-11 18:44     ` Johannes Berg
2007-12-11 20:15     ` [PATCH v2] mac80211: don't use interface indices in drivers Johannes Berg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1196849900.4121.4.camel@johannes.berg \
    --to=johannes@sipsolutions.net \
    --cc=dreamfly281@gmail.com \
    --cc=dsd@gentoo.org \
    --cc=flamingice@sourmilk.net \
    --cc=ivdoorn@gmail.com \
    --cc=linux-wireless@vger.kernel.org \
    --cc=linville@tuxdriver.com \
    --cc=reinette.chatre@intel.com \
    --cc=tomasw@gmail.com \
    --cc=yi.zhu@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox