Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH 00/16] iwlwifi update for 2.6.37
@ 2010-08-18 16:22 Wey-Yi Guy
  2010-08-18 16:22 ` [PATCH 01/16] iwlwifi: remove unused define Wey-Yi Guy
                   ` (15 more replies)
  0 siblings, 16 replies; 17+ messages in thread
From: Wey-Yi Guy @ 2010-08-18 16:22 UTC (permalink / raw)
  To: linville; +Cc: linux-wireless, ipw3945-devel, Wey-Yi Guy

We enable the capabilities to use experimental uCode for debugging.
We also do some code cleanup and refactor works in iwlwifi driver
There is a possibility of race condition while performing roaming,
not sure it is the case, but to avoid the possibility is a much
better approach.

Jay Sternberg (2):
  iwlwifi: enable experimental ucode support
  iwlwifi: move debug options into submenu

Johannes Berg (1):
  iwlwifi: refactor iwl_setup_rxon_timing

Shanyu Zhao (3):
  iwlwifi: do not call ieee80211_frequency_to_channel
  iwlwifi: avoid race condition in channel change
  iwlwifi: cleanup iwl_set_rxon_channel()

Wey-Yi Guy (10):
  iwlwifi: remove unused define
  iwlwifi: additional comments in iwl_cfg
  iwlwifi: max/min aggregation time limit
  iwlwifi: make aggregation time limit configurable
  iwlagn: adjust starting action for rate scale
  iwlagn: continue perform rate scale when error detected
  iwlwifi: additional parameter in REPLY_RX_PHY_CMD
  iwlwifi: more generic name for rssi calc in iwlagn
  iwlwifi: configurable ampdu factor and density
  iwlwifi: remove unused iwl_send_card_state function

these patches are also available from wireless-next-2.6 branch on
 git://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/iwlwifi-2.6.git

 drivers/net/wireless/iwlwifi/Kconfig        |   10 ++++
 drivers/net/wireless/iwlwifi/iwl-4965.c     |    2 +-
 drivers/net/wireless/iwlwifi/iwl-5000.c     |    2 +-
 drivers/net/wireless/iwlwifi/iwl-6000.c     |    2 +-
 drivers/net/wireless/iwlwifi/iwl-agn-hcmd.c |   21 +++++---
 drivers/net/wireless/iwlwifi/iwl-agn-lib.c  |    2 +-
 drivers/net/wireless/iwlwifi/iwl-agn-rs.c   |   42 +++++++++++++---
 drivers/net/wireless/iwlwifi/iwl-agn.c      |   56 ++++++++++++---------
 drivers/net/wireless/iwlwifi/iwl-commands.h |   45 +++++++++--------
 drivers/net/wireless/iwlwifi/iwl-core.c     |   71 +++++++++------------------
 drivers/net/wireless/iwlwifi/iwl-core.h     |   12 +++-
 drivers/net/wireless/iwlwifi/iwl-debugfs.c  |    6 +--
 drivers/net/wireless/iwlwifi/iwl-dev.h      |   14 +++++-
 drivers/net/wireless/iwlwifi/iwl3945-base.c |   11 +---
 14 files changed, 168 insertions(+), 128 deletions(-)


^ permalink raw reply	[flat|nested] 17+ messages in thread

end of thread, other threads:[~2010-08-18 16:18 UTC | newest]

Thread overview: 17+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2010-08-18 16:22 [PATCH 00/16] iwlwifi update for 2.6.37 Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 01/16] iwlwifi: remove unused define Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 02/16] iwlwifi: additional comments in iwl_cfg Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 03/16] iwlwifi: max/min aggregation time limit Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 04/16] iwlwifi: make aggregation time limit configurable Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 05/16] iwlwifi: do not call ieee80211_frequency_to_channel Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 06/16] iwlwifi: avoid race condition in channel change Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 07/16] iwlwifi: cleanup iwl_set_rxon_channel() Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 08/16] iwlwifi: refactor iwl_setup_rxon_timing Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 09/16] iwlagn: adjust starting action for rate scale Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 10/16] iwlagn: continue perform rate scale when error detected Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 11/16] iwlwifi: additional parameter in REPLY_RX_PHY_CMD Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 12/16] iwlwifi: more generic name for rssi calc in iwlagn Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 13/16] iwlwifi: configurable ampdu factor and density Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 14/16] iwlwifi: remove unused iwl_send_card_state function Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 15/16] iwlwifi: enable experimental ucode support Wey-Yi Guy
2010-08-18 16:22 ` [PATCH 16/16] iwlwifi: move debug options into submenu Wey-Yi Guy

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox