Linux wireless drivers development
 help / color / mirror / Atom feed
* [PATCH 0/6] ath10k: CE cleanups
@ 2013-08-21  6:57 Michal Kazior
  2013-08-21  6:57 ` [PATCH 1/6] ath10k: use inline ce_state structure Michal Kazior
                   ` (7 more replies)
  0 siblings, 8 replies; 20+ messages in thread
From: Michal Kazior @ 2013-08-21  6:57 UTC (permalink / raw)
  To: ath10k; +Cc: linux-wireless, Michal Kazior

Hi,

This patchset contains non-functional changes
except patch #1 which changes memory allocation
from dynamic to static.

There is still some more to clean up in PCI/CE
but it's probably better to keep patchsets compact
and more frequent.


Pozdrawiam / Best regards,
Michal Kazior.


Michal Kazior (6):
  ath10k: use inline ce_state structure
  ath10k: remove ce_op_state
  ath10k: remove unused ce_attr parameters
  ath10k: rename hif_ce_pipe_info to ath10k_pci_pipe
  ath10k: rename ce_state to ath10k_ce_pipe
  ath10k: rename ce_ring_state to ath10k_ce_ring

 drivers/net/wireless/ath/ath10k/ce.c  |  107 +++++++++++++++------------------
 drivers/net/wireless/ath/ath10k/ce.h  |   56 ++++++-----------
 drivers/net/wireless/ath/ath10k/pci.c |   78 ++++++++++++------------
 drivers/net/wireless/ath/ath10k/pci.h |   17 +++---
 4 files changed, 116 insertions(+), 142 deletions(-)

-- 
1.7.9.5


^ permalink raw reply	[flat|nested] 20+ messages in thread

end of thread, other threads:[~2013-09-02  5:29 UTC | newest]

Thread overview: 20+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2013-08-21  6:57 [PATCH 0/6] ath10k: CE cleanups Michal Kazior
2013-08-21  6:57 ` [PATCH 1/6] ath10k: use inline ce_state structure Michal Kazior
2013-08-21  6:57 ` [PATCH 2/6] ath10k: remove ce_op_state Michal Kazior
2013-08-21  6:57 ` [PATCH 3/6] ath10k: remove unused ce_attr parameters Michal Kazior
2013-08-21  6:57 ` [PATCH 4/6] ath10k: rename hif_ce_pipe_info to ath10k_pci_pipe Michal Kazior
2013-08-21  6:57 ` [PATCH 5/6] ath10k: rename ce_state to ath10k_ce_pipe Michal Kazior
2013-08-21  6:57 ` [PATCH 6/6] ath10k: rename ce_ring_state to ath10k_ce_ring Michal Kazior
2013-08-27  6:11 ` [PATCH 0/6] ath10k: CE cleanups Kalle Valo
2013-08-27 11:07 ` [PATCH v2 " Michal Kazior
2013-08-27 11:07   ` [PATCH v2 1/6] ath10k: use inline ce_state structure Michal Kazior
2013-08-28  4:12     ` Kalle Valo
2013-08-28  5:32       ` Michal Kazior
2013-09-01  6:34         ` Kalle Valo
2013-08-27 11:07   ` [PATCH v2 2/6] ath10k: remove ce_op_state Michal Kazior
2013-08-27 11:08   ` [PATCH v2 3/6] ath10k: remove unused ce_attr parameters Michal Kazior
2013-08-27 11:08   ` [PATCH v2 4/6] ath10k: rename hif_ce_pipe_info to ath10k_pci_pipe Michal Kazior
2013-08-27 11:08   ` [PATCH v2 5/6] ath10k: rename ce_state to ath10k_ce_pipe Michal Kazior
2013-08-27 11:08   ` [PATCH v2 6/6] ath10k: rename ce_ring_state to ath10k_ce_ring Michal Kazior
2013-09-01  6:36   ` [PATCH v2 0/6] ath10k: CE cleanups Kalle Valo
2013-09-02  5:29     ` Michal Kazior

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox