The Linux Kernel Mailing List
 help / color / mirror / Atom feed
* [PATCH 0/4] mm/mm_init: simplify zone_spanned_pages_in_node()
@ 2026-08-04 14:47 Sang-Heon Jeon
  2026-08-04 14:47 ` [PATCH 1/4] mm/mm_init: fold adjust_zone_range_for_zone_movable() into its sole caller Sang-Heon Jeon
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: Sang-Heon Jeon @ 2026-08-04 14:47 UTC (permalink / raw)
  To: Andrew Morton, Mike Rapoport; +Cc: linux-kernel, linux-mm

Hello,

This series simplifies zone_spanned_pages_in_node(), which adjusts
*zone_start_pfn and *zone_end_pfn before and after calling
adjust_zone_range_for_zone_movable(). The helper adjusts the same two
values, which makes the code harder to follow.

Split into four patches for easier review. Squashing them into one
patch when applying is also fine.

Patch 1 folds adjust_zone_range_for_zone_movable() into the caller.

Patch 2 removes the clamping to node_end_pfn, which has no effect.

Patch 3 moves the check and the clamping to node_start_pfn into the
ZONE_MOVABLE branch, which is the only place they have an effect.

Patch 4 extracts a local variable and reduces the indentation level.

No functional change.

Sang-Heon Jeon (4):
  mm/mm_init: fold adjust_zone_range_for_zone_movable() into its sole
    caller
  mm/mm_init: remove redundant clamping in zone_spanned_pages_in_node()
  mm/mm_init: move the range check and clamping inside ZONE_MOVABLE
    branch
  mm/mm_init: clean up zone_spanned_pages_in_node()

 mm/mm_init.c | 81 ++++++++++++++++++++++++----------------------------
 1 file changed, 37 insertions(+), 44 deletions(-)

-- 
2.43.0


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2026-08-06 14:42 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-08-04 14:47 [PATCH 0/4] mm/mm_init: simplify zone_spanned_pages_in_node() Sang-Heon Jeon
2026-08-04 14:47 ` [PATCH 1/4] mm/mm_init: fold adjust_zone_range_for_zone_movable() into its sole caller Sang-Heon Jeon
2026-08-04 14:47 ` [PATCH 2/4] mm/mm_init: remove redundant clamping in zone_spanned_pages_in_node() Sang-Heon Jeon
2026-08-04 14:48 ` [PATCH 3/4] mm/mm_init: move the range check and clamping inside ZONE_MOVABLE branch Sang-Heon Jeon
2026-08-04 14:48 ` [PATCH 4/4] mm/mm_init: clean up zone_spanned_pages_in_node() Sang-Heon Jeon
2026-08-06 14:41 ` [PATCH 0/4] mm/mm_init: simplify zone_spanned_pages_in_node() Sang-Heon Jeon

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox